summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-06-04 11:07:36 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-06-04 11:07:36 +0000
commitbe8c735c1b13db8963d0329969e76eff40940a19 (patch)
tree49f59899d744f83b6747f88275dfeccfb6400371 /sys-libs/libcap-ng
parentAdd pypi to remote-id in metadata.xml (diff)
downloadgentoo-2-be8c735c1b13db8963d0329969e76eff40940a19.tar.gz
gentoo-2-be8c735c1b13db8963d0329969e76eff40940a19.tar.bz2
gentoo-2-be8c735c1b13db8963d0329969e76eff40940a19.zip
Fix configuration for python3. Bug #551088.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-libs/libcap-ng')
-rw-r--r--sys-libs/libcap-ng/ChangeLog5
-rw-r--r--sys-libs/libcap-ng/libcap-ng-0.7.7.ebuild24
2 files changed, 20 insertions, 9 deletions
diff --git a/sys-libs/libcap-ng/ChangeLog b/sys-libs/libcap-ng/ChangeLog
index 472c4e3bf241..1b2eed0675cc 100644
--- a/sys-libs/libcap-ng/ChangeLog
+++ b/sys-libs/libcap-ng/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/libcap-ng
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/ChangeLog,v 1.79 2015/05/28 01:15:39 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/ChangeLog,v 1.80 2015/06/04 11:07:36 blueness Exp $
+
+ 04 Jun 2015; Anthony G. Basile <blueness@gentoo.org> libcap-ng-0.7.7.ebuild:
+ Fix configuration for python3. Bug #551088.
*libcap-ng-0.7.7 (28 May 2015)
*libcap-ng-0.7.6 (28 May 2015)
diff --git a/sys-libs/libcap-ng/libcap-ng-0.7.7.ebuild b/sys-libs/libcap-ng/libcap-ng-0.7.7.ebuild
index 6b5c5cbcf92c..fe6a2dbae9f1 100644
--- a/sys-libs/libcap-ng/libcap-ng-0.7.7.ebuild
+++ b/sys-libs/libcap-ng/libcap-ng-0.7.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/libcap-ng-0.7.7.ebuild,v 1.1 2015/05/28 01:15:39 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/libcap-ng-0.7.7.ebuild,v 1.2 2015/06/04 11:07:36 blueness Exp $
EAPI=5
@@ -24,6 +24,8 @@ DEPEND="${RDEPEND}
sys-kernel/linux-headers
python? ( >=dev-lang/swig-2 )"
+RESTRICT="test"
+
src_prepare() {
sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die
@@ -33,16 +35,22 @@ src_prepare() {
}
src_configure() {
- local myeconfargs=(
- --without-python
- )
-
# set up the library build
+ local myeconfargs=( --without-python --without-python3 )
autotools-utils_src_configure
- if use python; then
- python_parallel_foreach_impl \
- autotools-utils_src_configure --with-python
+ # set up python bindings build(s)
+ if use python ; then
+ setup_python_flags_configure() {
+ if [[ ${EPYTHON} == python2* ]] ; then
+ myeconfargs=( --with-python --without-python3 )
+ else
+ myeconfargs=( --with-python --with-python3 )
+ fi
+ autotools-utils_src_configure
+ }
+
+ python_foreach_impl setup_python_flags_configure
fi
}