summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-06-23 01:39:13 +0000
committerMike Frysinger <vapier@gentoo.org>2008-06-23 01:39:13 +0000
commit9349f859c6c589041c94855ba9d2b3140d1ba0ba (patch)
tree05097d2acda2237638ab87a65bcdf05314915b10 /sys-libs/glibc
parentRevision bump to add support for the ia32 USE flag to install a 32-bit Opera ... (diff)
downloadgentoo-2-9349f859c6c589041c94855ba9d2b3140d1ba0ba.tar.gz
gentoo-2-9349f859c6c589041c94855ba9d2b3140d1ba0ba.tar.bz2
gentoo-2-9349f859c6c589041c94855ba9d2b3140d1ba0ba.zip
Short circuit header building in pkg testing and ABI recursion.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25 x86_64)
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/ChangeLog7
-rw-r--r--sys-libs/glibc/files/eblits/src_compile.eblit13
-rw-r--r--sys-libs/glibc/files/eblits/src_install.eblit13
-rw-r--r--sys-libs/glibc/glibc-2.6.1.ebuild8
-rw-r--r--sys-libs/glibc/glibc-2.7-r2.ebuild8
-rw-r--r--sys-libs/glibc/glibc-2.8_p20080602.ebuild8
6 files changed, 41 insertions, 16 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 61e2f76e8ad0..e598984786f4 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.586 2008/06/23 00:48:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.587 2008/06/23 01:39:12 vapier Exp $
+
+ 23 Jun 2008; Mike Frysinger <vapier@gentoo.org>
+ files/eblits/src_compile.eblit, files/eblits/src_install.eblit,
+ glibc-2.6.1.ebuild, glibc-2.7-r2.ebuild, glibc-2.8_p20080602.ebuild:
+ Short circuit header building in pkg testing and ABI recursion.
23 Jun 2008; Mike Frysinger <vapier@gentoo.org> glibc-2.6.1.ebuild,
glibc-2.7-r2.ebuild, glibc-2.8_p20080602.ebuild:
diff --git a/sys-libs/glibc/files/eblits/src_compile.eblit b/sys-libs/glibc/files/eblits/src_compile.eblit
index 784829de538f..a1447d1029a0 100644
--- a/sys-libs/glibc/files/eblits/src_compile.eblit
+++ b/sys-libs/glibc/files/eblits/src_compile.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_compile.eblit,v 1.3 2007/11/18 03:49:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_compile.eblit,v 1.4 2008/06/23 01:39:13 vapier Exp $
glibc_do_configure() {
local myconf
@@ -151,6 +151,11 @@ toolchain-glibc_headers_compile() {
}
eblit-glibc-src_compile() {
+ if just_headers ; then
+ toolchain-glibc_headers_compile
+ return
+ fi
+
setup_env
if [[ -z ${OABI} ]] ; then
@@ -173,9 +178,5 @@ eblit-glibc-src_compile() {
fi
fi
- if just_headers ; then
- toolchain-glibc_headers_compile
- else
- toolchain-glibc_src_compile
- fi
+ toolchain-glibc_src_compile
}
diff --git a/sys-libs/glibc/files/eblits/src_install.eblit b/sys-libs/glibc/files/eblits/src_install.eblit
index aa3e8a51c8d9..54465c4ae5ad 100644
--- a/sys-libs/glibc/files/eblits/src_install.eblit
+++ b/sys-libs/glibc/files/eblits/src_install.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_install.eblit,v 1.5 2008/03/23 18:06:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_install.eblit,v 1.6 2008/06/23 01:39:13 vapier Exp $
toolchain-glibc_src_install() {
# These should not be set, else the
@@ -218,6 +218,11 @@ src_strip() {
}
eblit-glibc-src_install() {
+ if just_headers ; then
+ toolchain-glibc_headers_install
+ return
+ fi
+
setup_env
if [[ -z ${OABI} ]] ; then
@@ -241,10 +246,6 @@ eblit-glibc-src_install() {
fi
fi
- if just_headers ; then
- toolchain-glibc_headers_install
- else
- toolchain-glibc_src_install
- fi
+ toolchain-glibc_src_install
[[ -z ${OABI} ]] && src_strip
}
diff --git a/sys-libs/glibc/glibc-2.6.1.ebuild b/sys-libs/glibc/glibc-2.6.1.ebuild
index 19449b932395..0c3d455f5629 100644
--- a/sys-libs/glibc/glibc-2.6.1.ebuild
+++ b/sys-libs/glibc/glibc-2.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.6.1.ebuild,v 1.25 2008/06/23 00:48:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.6.1.ebuild,v 1.26 2008/06/23 01:39:12 vapier Exp $
inherit eutils versionator libtool toolchain-funcs flag-o-matic gnuconfig multilib
@@ -264,6 +264,9 @@ fix_lib64_symlinks() {
}
pkg_preinst() {
+ # nothing to do if just installing headers
+ just_headers && return
+
# PPC64+others may want to eventually be added to this logic if they
# decide to be multilib compatible and FHS compliant. note that this
# chunk of FHS compliance only applies to 64bit archs where 32bit
@@ -306,6 +309,9 @@ pkg_preinst() {
}
pkg_postinst() {
+ # nothing to do if just installing headers
+ just_headers && return
+
if ! tc-is-cross-compiler && [[ -x ${ROOT}/usr/sbin/iconvconfig ]] ; then
# Generate fastloading iconv module configuration file.
"${ROOT}"/usr/sbin/iconvconfig --prefix="${ROOT}"
diff --git a/sys-libs/glibc/glibc-2.7-r2.ebuild b/sys-libs/glibc/glibc-2.7-r2.ebuild
index 66fc9106acbe..cbaefce4196e 100644
--- a/sys-libs/glibc/glibc-2.7-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.7-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.7-r2.ebuild,v 1.9 2008/06/23 00:48:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.7-r2.ebuild,v 1.10 2008/06/23 01:39:12 vapier Exp $
inherit eutils versionator libtool toolchain-funcs flag-o-matic gnuconfig multilib
@@ -265,6 +265,9 @@ fix_lib64_symlinks() {
}
pkg_preinst() {
+ # nothing to do if just installing headers
+ just_headers && return
+
# PPC64+others may want to eventually be added to this logic if they
# decide to be multilib compatible and FHS compliant. note that this
# chunk of FHS compliance only applies to 64bit archs where 32bit
@@ -307,6 +310,9 @@ pkg_preinst() {
}
pkg_postinst() {
+ # nothing to do if just installing headers
+ just_headers && return
+
if ! tc-is-cross-compiler && [[ -x ${ROOT}/usr/sbin/iconvconfig ]] ; then
# Generate fastloading iconv module configuration file.
"${ROOT}"/usr/sbin/iconvconfig --prefix="${ROOT}"
diff --git a/sys-libs/glibc/glibc-2.8_p20080602.ebuild b/sys-libs/glibc/glibc-2.8_p20080602.ebuild
index e5d773e1959a..bca25df9f1f4 100644
--- a/sys-libs/glibc/glibc-2.8_p20080602.ebuild
+++ b/sys-libs/glibc/glibc-2.8_p20080602.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.8_p20080602.ebuild,v 1.6 2008/06/23 00:48:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.8_p20080602.ebuild,v 1.7 2008/06/23 01:39:12 vapier Exp $
inherit eutils versionator libtool toolchain-funcs flag-o-matic gnuconfig multilib
@@ -295,6 +295,9 @@ fix_lib64_symlinks() {
}
pkg_preinst() {
+ # nothing to do if just installing headers
+ just_headers && return
+
# PPC64+others may want to eventually be added to this logic if they
# decide to be multilib compatible and FHS compliant. note that this
# chunk of FHS compliance only applies to 64bit archs where 32bit
@@ -337,6 +340,9 @@ pkg_preinst() {
}
pkg_postinst() {
+ # nothing to do if just installing headers
+ just_headers && return
+
if ! tc-is-cross-compiler && [[ -x ${ROOT}/usr/sbin/iconvconfig ]] ; then
# Generate fastloading iconv module configuration file.
"${ROOT}"/usr/sbin/iconvconfig --prefix="${ROOT}"