summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-09-29 22:35:57 +0000
committerMike Frysinger <vapier@gentoo.org>2010-09-29 22:35:57 +0000
commitfba42e40efbfdda80afe84259395eaa18b7229f7 (patch)
tree0f80f2452fcfa36c1652518c3ddb4dbe265bad5c /sys-libs/cracklib
parentMarking abstract-1.0.0 ~ppc64 for bug 326353 (diff)
downloadgentoo-2-fba42e40efbfdda80afe84259395eaa18b7229f7.tar.gz
gentoo-2-fba42e40efbfdda80afe84259395eaa18b7229f7.tar.bz2
gentoo-2-fba42e40efbfdda80afe84259395eaa18b7229f7.zip
Version bump.
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/cracklib')
-rw-r--r--sys-libs/cracklib/ChangeLog7
-rw-r--r--sys-libs/cracklib/cracklib-2.8.18.ebuild90
2 files changed, 96 insertions, 1 deletions
diff --git a/sys-libs/cracklib/ChangeLog b/sys-libs/cracklib/ChangeLog
index 8bfe9600ade3..14bec4e07e0c 100644
--- a/sys-libs/cracklib/ChangeLog
+++ b/sys-libs/cracklib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/cracklib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/ChangeLog,v 1.156 2010/09/28 15:35:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/ChangeLog,v 1.157 2010/09/29 22:35:57 vapier Exp $
+
+*cracklib-2.8.18 (29 Sep 2010)
+
+ 29 Sep 2010; Mike Frysinger <vapier@gentoo.org> +cracklib-2.8.18.ebuild:
+ Version bump.
28 Sep 2010; Mike Frysinger <vapier@gentoo.org> cracklib-2.8.16.ebuild,
+files/cracklib-2.8.16-no-nls.patch:
diff --git a/sys-libs/cracklib/cracklib-2.8.18.ebuild b/sys-libs/cracklib/cracklib-2.8.18.ebuild
new file mode 100644
index 000000000000..74ce2a6e029e
--- /dev/null
+++ b/sys-libs/cracklib/cracklib-2.8.18.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.8.18.ebuild,v 1.1 2010/09/29 22:35:57 vapier Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit eutils distutils libtool toolchain-funcs
+
+MY_P=${P/_}
+DESCRIPTION="Password Checking Library"
+HOMEPAGE="http://sourceforge.net/projects/cracklib"
+SRC_URI="mirror://sourceforge/cracklib/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls python"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ python? ( dev-python/setuptools )"
+
+S=${WORKDIR}/${MY_P}
+
+PYTHON_MODNAME="cracklib.py"
+do_python() {
+ pushd python > /dev/null || die
+ distutils_src_${EBUILD_PHASE}
+ popd > /dev/null
+}
+
+pkg_setup() {
+ # workaround #195017
+ if has unmerge-orphans ${FEATURES} && has_version "<${CATEGORY}/${PN}-2.8.10" ; then
+ eerror "Upgrade path is broken with FEATURES=unmerge-orphans"
+ eerror "Please run: FEATURES=-unmerge-orphans emerge cracklib"
+ die "Please run: FEATURES=-unmerge-orphans emerge cracklib"
+ fi
+
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ elibtoolize #269003
+ use python && do_python
+}
+
+src_configure() {
+ econf \
+ --with-default-dict='$(libdir)/cracklib_dict' \
+ --without-python \
+ $(use_enable nls)
+}
+
+src_compile() {
+ default
+ use python && do_python
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -r "${ED}"/usr/share/cracklib
+
+ use python && do_python
+
+ # move shared libs to /
+ gen_usr_ldscript -a crack
+
+ insinto /usr/share/dict
+ doins dicts/cracklib-small || die "word dict"
+
+ dodoc AUTHORS ChangeLog NEWS README*
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} == "/" ]] ; then
+ ebegin "Regenerating cracklib dictionary"
+ create-cracklib-dict /usr/share/dict/* > /dev/null
+ eend $?
+ fi
+
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}