summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-12-13 19:58:10 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-12-13 19:58:10 +0000
commitff1238ee91e19cbc0ad48b710892656399133415 (patch)
tree00af80c66bea1b3437c1a4bf67e3f0f12b7d5a1d /sys-kernel
parentadded SLOT (diff)
downloadgentoo-2-ff1238ee91e19cbc0ad48b710892656399133415.tar.gz
gentoo-2-ff1238ee91e19cbc0ad48b710892656399133415.tar.bz2
gentoo-2-ff1238ee91e19cbc0ad48b710892656399133415.zip
bump
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ac-sources/ac-sources-2.4.20-r2.ebuild39
-rw-r--r--sys-kernel/ac-sources/files/digest-ac-sources-2.4.20-r22
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/ac-sources/ac-sources-2.4.20-r2.ebuild b/sys-kernel/ac-sources/ac-sources-2.4.20-r2.ebuild
new file mode 100644
index 000000000000..714f409d055a
--- /dev/null
+++ b/sys-kernel/ac-sources/ac-sources-2.4.20-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ac-sources/ac-sources-2.4.20-r2.ebuild,v 1.1 2002/12/13 19:58:10 lostlogic Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version.
+
+ETYPE="sources"
+
+inherit kernel || die
+
+OKV="2.4.20"
+ACV=ac${PR/r/}
+KV="${PV/_/-}-${ACV}"
+S=${WORKDIR}/linux-${KV}
+
+EXTRAVERSION="`echo ${KV}|sed -e 's:[^-]*\(-.*$\):\1:'`"
+BASE="`echo ${KV}|sed -e s:${EXTRAVERSION}::`"
+
+DESCRIPTION="Full sources for Alan Cox's Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+http://www.kernel.org/pub/linux/kernel/people/alan/linux-2.4/${BASE}/patch-${KV}.bz2"
+#add to src_uri for pre/rc patch ac-sources
+#http://www.kernel.org/pub/linux/kernel/v2.4/testing/patch-${PV/_/-}.bz2
+
+KEYWORDS="x86"
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+
+ cd linux-${KV}
+# Uncomment for pre/rc patch versions
+# bzcat ${DISTDIR}/patch-${PV/_/-}.bz2|patch -p1 || die "-marcelo patch failed"
+ bzcat ${DISTDIR}/patch-${KV}.bz2|patch -p1 || die "-ac patch failed"
+
+ kernel_universal_unpack
+}
diff --git a/sys-kernel/ac-sources/files/digest-ac-sources-2.4.20-r2 b/sys-kernel/ac-sources/files/digest-ac-sources-2.4.20-r2
new file mode 100644
index 000000000000..57f5fe62dd4b
--- /dev/null
+++ b/sys-kernel/ac-sources/files/digest-ac-sources-2.4.20-r2
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 4580b3702a3141db32a8488c2d355c27 patch-2.4.20-ac2.bz2 1309532