summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2003-10-16 03:22:20 +0000
committerJoshua Kinard <kumba@gentoo.org>2003-10-16 03:22:20 +0000
commitf5f789df901cfb6bae44472718e90386e5a6ef27 (patch)
tree6378964d55037f03c67282ab663d1833d17891d0 /sys-kernel
parentNew CVS snapshot; Allows for mips64 kernels to be built among other things. (diff)
downloadgentoo-2-f5f789df901cfb6bae44472718e90386e5a6ef27.tar.gz
gentoo-2-f5f789df901cfb6bae44472718e90386e5a6ef27.tar.bz2
gentoo-2-f5f789df901cfb6bae44472718e90386e5a6ef27.zip
New CVS snapshot; Allows for mips64 kernels to be built among other things.
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/mips-sources/ChangeLog14
-rw-r--r--sys-kernel/mips-sources/Manifest4
-rw-r--r--sys-kernel/mips-sources/files/bigendian-byteorder-fix.patch50
-rw-r--r--sys-kernel/mips-sources/files/digest-mips-sources-2.4.22-r32
-rw-r--r--sys-kernel/mips-sources/files/mipscvs-2.4.22-makefile-mips64-tweak.patch11
-rw-r--r--sys-kernel/mips-sources/mips-sources-2.4.22-r3.ebuild56
6 files changed, 134 insertions, 3 deletions
diff --git a/sys-kernel/mips-sources/ChangeLog b/sys-kernel/mips-sources/ChangeLog
index 22b69838a18d..550ce1ab8265 100644
--- a/sys-kernel/mips-sources/ChangeLog
+++ b/sys-kernel/mips-sources/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for sys-kernel/mips-sources
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/ChangeLog,v 1.11 2003/09/25 19:25:49 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/ChangeLog,v 1.12 2003/10/16 03:22:07 kumba Exp $
+
+
+*mips-sources-2.4.22-r3 (15 Oct 2003)
+
+ 15 Oct 2003; Joshua Kinard <kumba@gentoo.org> mips-sources-2.4.22-r3.ebuild,
+ files/mipscvs-2.4.22-makefile-mips64-tweak.patch:
+ New linux-mips.org CVS snap, dated 20031015. This snapshot allows mips64
+ kernels to be built and booted on Indy/Indigo2 systems, however this support
+ is very preliminary. Details on mips64 will be forthcoming.
+ The SGIWD scsi patch and bigendian byteorder patch are no longer needed in
+ this release
+ Lastly, we now install the sources in /usr/src/linux-<version>-<cvsdate>.
*mips-sources-2.4.22-r2 (25 Sep 2003)
diff --git a/sys-kernel/mips-sources/Manifest b/sys-kernel/mips-sources/Manifest
index 962c4d7de170..f573e3ad409b 100644
--- a/sys-kernel/mips-sources/Manifest
+++ b/sys-kernel/mips-sources/Manifest
@@ -1,9 +1,9 @@
-MD5 9868aec4bd45c19e28d7d42e77ceb87c ChangeLog 3660
+MD5 42c14021f9b8bc65fe7d89e07f3cb286 ChangeLog 3660
MD5 ad25a2a0b6ade60c13ad8040f3c319c6 metadata.xml 378
MD5 46a2892f6e39271209b313b0523629a1 mips-sources-2.4.21-r2.ebuild 1204
MD5 b351f7c79ce78b5745dd55ac21e16d49 mips-sources-2.4.22-r1.ebuild 1399
MD5 01b6cdc5f846d207cc36815a28b8f282 mips-sources-2.4.22-r2.ebuild 1400
-MD5 f3d7e97db2203186348fc64830b060d0 mips-sources-2.4.22-r3.ebuild 1590
+MD5 b2dc0081cab229db1fa6ca1757bc559b mips-sources-2.4.22-r3.ebuild 1590
MD5 76b0e72e1a0025451c3fcf8d00faaf0a files/digest-mips-sources-2.4.21-r2 145
MD5 98354eb02ecc6b8d0463a68eba698a85 files/digest-mips-sources-2.4.22-r1 144
MD5 4115e49b895cdd9dfcb7b02520e162ae files/digest-mips-sources-2.4.22-r2 144
diff --git a/sys-kernel/mips-sources/files/bigendian-byteorder-fix.patch b/sys-kernel/mips-sources/files/bigendian-byteorder-fix.patch
new file mode 100644
index 000000000000..bec279abce81
--- /dev/null
+++ b/sys-kernel/mips-sources/files/bigendian-byteorder-fix.patch
@@ -0,0 +1,50 @@
+--- linux/include/linux/byteorder/generic.h.orig 2003-08-10 18:15:07.000000000 -0700
++++ linux/include/linux/byteorder/generic.h 2003-08-10 18:16:36.000000000 -0700
+@@ -122,7 +122,7 @@
+ #define be16_to_cpus __be16_to_cpus
+ #endif
+
+-
++#if defined(__KERNEL__)
+ /*
+ * Handle ntohl and suches. These have various compatibility
+ * issues - like we want to give the prototype even though we
+@@ -146,35 +146,26 @@
+ * Do the prototypes. Somebody might want to take the
+ * address or some such sick thing..
+ */
+-#if defined(__KERNEL__) || (defined (__GLIBC__) && __GLIBC__ >= 2)
+ extern __u32 ntohl(__u32);
+ extern __u32 htonl(__u32);
+-#else
+-extern unsigned long int ntohl(unsigned long int);
+-extern unsigned long int htonl(unsigned long int);
+-#endif
+ extern unsigned short int ntohs(unsigned short int);
+ extern unsigned short int htons(unsigned short int);
+
+-
+-#if defined(__GNUC__) && (__GNUC__ >= 2) && defined(__OPTIMIZE__) && !defined(__STRICT_ANSI__)
++#if defined(__GNUC__) && defined(__OPTIMIZE__)
+
+ #define ___htonl(x) __cpu_to_be32(x)
+ #define ___htons(x) __cpu_to_be16(x)
+ #define ___ntohl(x) __be32_to_cpu(x)
+ #define ___ntohs(x) __be16_to_cpu(x)
+
+-#if defined(__KERNEL__) || (defined (__GLIBC__) && __GLIBC__ >= 2)
+ #define htonl(x) ___htonl(x)
+ #define ntohl(x) ___ntohl(x)
+-#else
+-#define htonl(x) ((unsigned long)___htonl(x))
+-#define ntohl(x) ((unsigned long)___ntohl(x))
+-#endif
+ #define htons(x) ___htons(x)
+ #define ntohs(x) ___ntohs(x)
+
+ #endif /* OPTIMIZE */
+
++#endif /* KERNEL */
++
+
+ #endif /* _LINUX_BYTEORDER_GENERIC_H */
diff --git a/sys-kernel/mips-sources/files/digest-mips-sources-2.4.22-r3 b/sys-kernel/mips-sources/files/digest-mips-sources-2.4.22-r3
new file mode 100644
index 000000000000..5276a20886f0
--- /dev/null
+++ b/sys-kernel/mips-sources/files/digest-mips-sources-2.4.22-r3
@@ -0,0 +1,2 @@
+MD5 75dc85149b06ac9432106b8941eb9f7b linux-2.4.22.tar.bz2 29528612
+MD5 d82efc4684e5b4f1b64092d9adaac7e8 mipscvs-2.4.22-20031015.diff.bz2 239716
diff --git a/sys-kernel/mips-sources/files/mipscvs-2.4.22-makefile-mips64-tweak.patch b/sys-kernel/mips-sources/files/mipscvs-2.4.22-makefile-mips64-tweak.patch
new file mode 100644
index 000000000000..2ec1cd9474c2
--- /dev/null
+++ b/sys-kernel/mips-sources/files/mipscvs-2.4.22-makefile-mips64-tweak.patch
@@ -0,0 +1,11 @@
+--- arch/mips64/Makefile.orig 2003-10-15 05:37:01.000000000 -0400
++++ arch/mips64/Makefile 2003-10-15 05:37:44.000000000 -0400
+@@ -288,7 +288,7 @@ endif
+ # convert to ECOFF using elf2ecoff.
+ #
+ ifdef CONFIG_BOOT_ELF32
+-GCCFLAGS += -Wa,-32 $(shell if $(CC) -Wa,-mgp64 -c -o /dev/null -xc /dev/null > /dev/null 2>&1; then echo "-Wa,-mgp64"; fi)
++GCCFLAGS += -Wa,mabi=o64 $(shell if $(CC) -Wa,-mgp64 -c -o /dev/null -xc /dev/null > /dev/null 2>&1; then echo "-Wa,-mgp64"; fi)
+ LINKFLAGS += -T arch/mips64/ld.script.elf32
+ endif
+ #
diff --git a/sys-kernel/mips-sources/mips-sources-2.4.22-r3.ebuild b/sys-kernel/mips-sources/mips-sources-2.4.22-r3.ebuild
new file mode 100644
index 000000000000..2eb16b914958
--- /dev/null
+++ b/sys-kernel/mips-sources/mips-sources-2.4.22-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-2.4.22-r3.ebuild,v 1.1 2003/10/16 03:22:07 kumba Exp $
+
+
+ETYPE="sources"
+inherit kernel eutils
+OKV=${PV/_/-}
+CVSDATE=20031015
+KV=${OKV}-${CVSDATE}
+S=${WORKDIR}/linux-${OKV}-${CVSDATE}
+EXTRAVERSION=-mipscvs-${CVSDATE}
+PROVIDE="virtual/linux-sources"
+
+
+# What's in this kernel?
+
+# INCLUDED:
+# 1) linux sources from kernel.org
+# 2) linux-mips.org CVS snapshot diff from 25 Sep 2003
+# 3) patch to fix arch/mips[64]/Makefile to pass appropriate CFLAGS
+# 4) patch to tweak arch/mips64/Makefile to pass -Wa,-mabi=o64 instead of -Wa,-32
+
+
+DESCRIPTION="Linux-Mips CVS sources for MIPS-based machines, dated ${CVSDATE}"
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/mipscvs-${OKV}-${CVSDATE}.diff.bz2"
+HOMEPAGE="http://www.linux-mips.org/"
+KEYWORDS="-* ~mips"
+SLOT="${OKV}"
+
+src_unpack() {
+ unpack ${A}
+ mv ${WORKDIR}/linux-${OKV} ${WORKDIR}/linux-${OKV}-${CVSDATE}
+ cd ${S}
+
+ # Update the vanilla sources with linux-mips CVS changes
+ epatch ${WORKDIR}/mipscvs-${OKV}-${CVSDATE}.diff
+
+ # Patch arch/mips/Makefile for gcc
+ epatch ${FILESDIR}/mipscvs-${OKV}-makefile-fix.patch
+
+ # Patch arch/mips64/Makefile to pass -Wa,mabi=o64
+ epatch ${FILESDIR}/mipscvs-${OKV}-makefile-mips64-tweak.patch
+
+ kernel_universal_unpack
+}
+
+pkg_postinst() {
+
+ # Do kernel postinst stuff
+ kernel_pkg_postinst
+
+ # Create /usr/src/linux symlink
+ ln -sf linux-${OKV}-${CVSDATE} ${ROOT}/usr/src/linux
+}