summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Johnson <livewire@gentoo.org>2003-04-20 16:25:04 +0000
committerBob Johnson <livewire@gentoo.org>2003-04-20 16:25:04 +0000
commitd04131deaf162bd7ae03318196b3d6d626f11458 (patch)
tree1d9f29078ef765b13f53e865bb834f3177c8c360 /sys-kernel
parentpull -r1 (diff)
downloadgentoo-2-d04131deaf162bd7ae03318196b3d6d626f11458.tar.gz
gentoo-2-d04131deaf162bd7ae03318196b3d6d626f11458.tar.bz2
gentoo-2-d04131deaf162bd7ae03318196b3d6d626f11458.zip
*** empty log message ***
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/gs-sources/Manifest2
-rw-r--r--sys-kernel/gs-sources/files/digest-gs-sources-2.4.21_pre7-r12
-rw-r--r--sys-kernel/gs-sources/gs-sources-2.4.21_pre7-r1.ebuild56
3 files changed, 60 insertions, 0 deletions
diff --git a/sys-kernel/gs-sources/Manifest b/sys-kernel/gs-sources/Manifest
index 42b59d059516..0c8093668568 100644
--- a/sys-kernel/gs-sources/Manifest
+++ b/sys-kernel/gs-sources/Manifest
@@ -2,6 +2,7 @@ MD5 90ba43c649a0b9cd36bb1fe20dd25c63 gs-sources-2.4.21_pre3.ebuild 2167
MD5 c53f938ae0985655856cb4d8fb980b58 gs-sources-2.4.21_pre5-r1.ebuild 1845
MD5 d561dfb1f6d10b9749ec0d9768a8ae4e gs-sources-2.4.21_pre5.ebuild 1837
MD5 1efb32254b680fb1f5cdb68d663bbafd gs-sources-2.4.21_pre7.ebuild 1943
+MD5 82e338da2ba626361ffc3f7cdadf1b81 gs-sources-2.4.21_pre7-r1.ebuild 1953
MD5 7b17bbc805e01879075d5241f0fc3805 gs-sources-2.4.21_pre4.ebuild 2169
MD5 cb57cb01450f378f90e994f86cae5364 ChangeLog 2482
MD5 dc86754e93e8a0c281291c64a3d6696f gs-sources-2.4.21_pre3-r3.ebuild 2187
@@ -13,4 +14,5 @@ MD5 932ab450aeab32018f00cfae5b664c9b files/digest-gs-sources-2.4.21_pre6 280
MD5 1d84ead5da2fdae8a336c41ccfe2d2ad files/digest-gs-sources-2.4.21_pre7 280
MD5 4102b5166c83b34fb1aefbcf59161020 files/digest-gs-sources-2.4.21_pre3-r3 147
MD5 ea093aa72a1538027f581a6ef1526082 files/digest-gs-sources-2.4.21_pre5-r1 147
+MD5 ec2af610cc4d00ceac01e106084647ef files/digest-gs-sources-2.4.21_pre7-r1 147
MD5 a3ec1083055b245758b2262dd2245145 files/pci.ids.patch 3376
diff --git a/sys-kernel/gs-sources/files/digest-gs-sources-2.4.21_pre7-r1 b/sys-kernel/gs-sources/files/digest-gs-sources-2.4.21_pre7-r1
new file mode 100644
index 000000000000..0231cc40f397
--- /dev/null
+++ b/sys-kernel/gs-sources/files/digest-gs-sources-2.4.21_pre7-r1
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 c2febe8f97316b7a2a8e879e98d3d5e0 patches-2.4.21_pre7-gss-r1.tar.bz2 5310299
diff --git a/sys-kernel/gs-sources/gs-sources-2.4.21_pre7-r1.ebuild b/sys-kernel/gs-sources/gs-sources-2.4.21_pre7-r1.ebuild
new file mode 100644
index 000000000000..b7f61da67181
--- /dev/null
+++ b/sys-kernel/gs-sources/gs-sources-2.4.21_pre7-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gs-sources/gs-sources-2.4.21_pre7-r1.ebuild,v 1.3 2003/04/20 16:23:56 livewire Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV=2.4.20
+EXTRAVERSION=_pre7-gss-r1
+KV=2.4.21_pre7-gss-r1
+S=${WORKDIR}/linux-${KV}
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/gs-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="This kernel stays up to date with current kernel -pres,
+ with recent acpi,evms,win3lin ,futexes,aic79xx,
+ superfreeswan,preempt/ll, and various hw fixes."
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
+KEYWORDS="~x86 -ppc -sparc "
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ if [ -z "`use crypt`" ]; then
+ einfo "No Cryptographic support, dropping patches..."
+ for file in 8*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ else
+ einfo "Cryptographic support enabled..."
+ fi
+
+ kernel_src_unpack
+}