summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-12-24 18:58:10 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-12-24 18:58:10 +0000
commitcf5b8c399db2c2b11edfa946120ee8f18efe2b3b (patch)
treec481782ba8707e4e132a7e4b1c307ee2e98366bc /sys-kernel
parentfix stripping; fix fontconfig borking (diff)
downloadgentoo-2-cf5b8c399db2c2b11edfa946120ee8f18efe2b3b.tar.gz
gentoo-2-cf5b8c399db2c2b11edfa946120ee8f18efe2b3b.tar.bz2
gentoo-2-cf5b8c399db2c2b11edfa946120ee8f18efe2b3b.zip
nother _pre
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/lolo-sources/ChangeLog22
-rw-r--r--sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_pre82
-rw-r--r--sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre8.ebuild55
3 files changed, 77 insertions, 2 deletions
diff --git a/sys-kernel/lolo-sources/ChangeLog b/sys-kernel/lolo-sources/ChangeLog
index 2357ab4373b1..166c14ba521a 100644
--- a/sys-kernel/lolo-sources/ChangeLog
+++ b/sys-kernel/lolo-sources/ChangeLog
@@ -1,8 +1,26 @@
# ChangeLog for sys-kernel/lolo-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.27 2002/12/24 16:46:04 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.28 2002/12/24 18:58:10 lostlogic Exp $
-*lolo-sources-2.4.20.1_pre6 (20 Dec 2002)
+*lolo-sources-2.4.20.1_pre8 (24 Dec 2002)
+
+ 24 Dec 2002; Brandon Low <lostlogic@gentoo.org> lolo-sources-2.4.20.1_pre8.ebuild :
+ Changes from _pre7:
+ * Officially drop the iptables-ROUTE
+ * fix NTFS modular and highmem support (I hope)
+ * Fix the FreeS/WAN patch so it doesn't make ~ files
+ * add i2c-2.7.0
+
+ TODO before _rc/final:
+ * Documentation
+ * Make sure hardware support is synched with xfs-sources
+ * Test away
+ * Possibly switch encrypted loopback patches?
+ * Possibly make the elevator.c changes a configurable option
+ * Possibly KT400 pci.ids
+ * Whatever else I'm forgetting
+
+*lolo-sources-2.4.20.1_pre7 (24 Dec 2002)
24 Dec 2002; Brandon Low <lostlogic@gentoo.org> lolo-sources-2.4.20.1_pre7.ebuild :
Changed last minute:
diff --git a/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_pre8 b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_pre8
new file mode 100644
index 000000000000..ed99a4b56e9e
--- /dev/null
+++ b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_pre8
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 3621d3d9c05d523f40baf299fca37758 patches-2.4.20-lolo-r1_pre8.tar.bz2 1903340
diff --git a/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre8.ebuild b/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre8.ebuild
new file mode 100644
index 000000000000..3575d9504c44
--- /dev/null
+++ b/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre8.ebuild,v 1.1 2002/12/24 18:58:10 lostlogic Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV="2.4.20"
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/lolo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for lostlogic's Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://lostlogicx.com/gentoo/patches-${KV}.tar.bz2"
+KEYWORDS="~x86 -ppc -sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ [ `use crypt` ] || rm 8*
+
+ kernel_src_unpack
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ einfo "Please be warned, you have just installed a very beta"
+ einfo "patchset of the linux kernel sources."
+ einfo "If there are problems with it, please report them"
+ einfo "by assigning bugs on bugs.gentoo.org to"
+ einfo "lostlogic@gentoo.org"
+
+}