summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2015-02-09 14:03:13 +0000
committerMike Pagano <mpagano@gentoo.org>2015-02-09 14:03:13 +0000
commitcf0dcf131ec2ef1b9a06184adae462521a318ac6 (patch)
treee4a964203630e93d5291aad4e05bf360c9fbaa3b /sys-kernel
parentchecked with kernel 3.18 (diff)
downloadgentoo-2-cf0dcf131ec2ef1b9a06184adae462521a318ac6.tar.gz
gentoo-2-cf0dcf131ec2ef1b9a06184adae462521a318ac6.tar.bz2
gentoo-2-cf0dcf131ec2ef1b9a06184adae462521a318ac6.zip
Patch to support for namespace user.pax.* on tmpfs. Patch to disable Windows 8 compatibility for some Lenovo ThinkPads. Patch to ensure that /dev/root doesn't appear in /proc/mounts when bootint without an initramfs. Patch: Do not lock when UMH is waiting on current thread spawned by linuxrc. (bug #481344). Add Gentoo Linux support config settings and defaults. Kernel patch enables gcc optimizations for additional CPUs.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B576E4E3)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/gentoo-sources/ChangeLog12
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-3.19.0.ebuild29
2 files changed, 40 insertions, 1 deletions
diff --git a/sys-kernel/gentoo-sources/ChangeLog b/sys-kernel/gentoo-sources/ChangeLog
index 06d711305285..b6ed9fcd2af9 100644
--- a/sys-kernel/gentoo-sources/ChangeLog
+++ b/sys-kernel/gentoo-sources/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-kernel/gentoo-sources
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.1493 2015/02/07 02:02:36 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.1494 2015/02/09 14:03:13 mpagano Exp $
+
+*gentoo-sources-3.19.0 (09 Feb 2015)
+
+ 09 Feb 2015; Mike Pagano <mpagano@gentoo.org> +gentoo-sources-3.19.0.ebuild:
+ Patch to support for namespace user.pax.* on tmpfs. Patch to disable Windows
+ 8 compatibility for some Lenovo ThinkPads. Patch to ensure that /dev/root
+ doesn't appear in /proc/mounts when bootint without an initramfs. Patch: Do
+ not lock when UMH is waiting on current thread spawned by linuxrc. (bug
+ #481344). Add Gentoo Linux support config settings and defaults. Kernel patch
+ enables gcc optimizations for additional CPUs.
*gentoo-sources-3.10.68 (07 Feb 2015)
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-3.19.0.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-3.19.0.ebuild
new file mode 100644
index 000000000000..7820bffe5c82
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-3.19.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-3.19.0.ebuild,v 1.1 2015/02/09 14:03:13 mpagano Exp $
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="1"
+K_DEBLOB_AVAILABLE="0"
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches"
+IUSE="deblob experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}