summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2002-10-18 20:57:54 +0000
committerMichael Imhof <tantive@gentoo.org>2002-10-18 20:57:54 +0000
commit98ed6ef1f5c7af6e6522cd653ba4ca403934efaf (patch)
treed68ba33ba10bf398d330bf44bc790a293aa81451 /sys-kernel
parentUpdated SRC_URI to use mirror://sourceforge (diff)
downloadgentoo-2-98ed6ef1f5c7af6e6522cd653ba4ca403934efaf.tar.gz
gentoo-2-98ed6ef1f5c7af6e6522cd653ba4ca403934efaf.tar.bz2
gentoo-2-98ed6ef1f5c7af6e6522cd653ba4ca403934efaf.zip
Version bump, includes openMosix-2.4.19-6. Should fix all known issues.
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/openmosix-sources/ChangeLog8
-rw-r--r--sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.19-r73
-rw-r--r--sys-kernel/openmosix-sources/openmosix-sources-2.4.19-r7.ebuild112
3 files changed, 122 insertions, 1 deletions
diff --git a/sys-kernel/openmosix-sources/ChangeLog b/sys-kernel/openmosix-sources/ChangeLog
index 6ceb05ca6e33..50bd08dea555 100644
--- a/sys-kernel/openmosix-sources/ChangeLog
+++ b/sys-kernel/openmosix-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/openmosix-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/ChangeLog,v 1.9 2002/10/05 14:25:41 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/ChangeLog,v 1.10 2002/10/18 20:57:54 tantive Exp $
+
+*openmosix-sources-2.4.19-r7 (18 Oct 2002)
+
+ 18 Oct 2002; Michael Imhof <tantive@gentoo.org>
+ Version bumped: Including openmosix-2.4.19-6 and evms 1.2.0 (and the gcc3 compile patch).
+ This revision should fix most of the known issues.
*openmosix-sources-2.4.19-r6 (05 Oct 2002)
diff --git a/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.19-r7 b/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.19-r7
new file mode 100644
index 000000000000..38b0c57681ac
--- /dev/null
+++ b/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.19-r7
@@ -0,0 +1,3 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 6e9f84f0f620fe355f6f7cde49e25d4f linux-gentoo-2.4.19-openmosix-r7.patch.bz2 453071
+MD5 deeb285ed6754146306564fbdca65ddc linux-gentoo-2.4.19-openmosix-r7-gcc3.patch.bz2 362
diff --git a/sys-kernel/openmosix-sources/openmosix-sources-2.4.19-r7.ebuild b/sys-kernel/openmosix-sources/openmosix-sources-2.4.19-r7.ebuild
new file mode 100644
index 000000000000..abdc0ba5e7b9
--- /dev/null
+++ b/sys-kernel/openmosix-sources/openmosix-sources-2.4.19-r7.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/openmosix-sources-2.4.19-r7.ebuild,v 1.1 2002/10/18 20:57:54 tantive Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=2.4.19
+[ "${PR}" == "r0" ] && KV=${OKV}-openmosix || KV=${OKV}-openmosix-${PR}
+EXTRAVERSION="`echo ${KV}|sed -e 's:[0-9]\+\.[0-9]\+\.[0-9]\+\(.*\):\1:'`"
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# 2.4.19, plus:
+# 2.4.19 openmosix-2.4.19-6
+# 2.4.19 evms-1.2.0 (evms-linux-2.4.19-common-files, evms-1.2.0-linux-2.4.patch, linux-2.4.19.VFS-lock.patch)
+# for gcc3 there is a patch applied that helps you compiling this kernel using gcc3.
+
+DESCRIPTION="Full sources for the Gentoo openMosix Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://www.ibiblio.org/gentoo/distfiles/linux-gentoo-${KV}.patch.bz2 http://www.ibiblio.org/gentoo/distfiles/linux-gentoo-${KV}-gcc3.patch.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/ http://www.openmosix.org/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc -sparc64 -alpha"
+
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${S}
+ cat ${DISTDIR}/linux-gentoo-${KV}.patch.bz2 | bzip2 -d | patch -p1 || die
+
+ #if the used gcc is gcc3 there is a seperate patch applied.
+ if [ `gcc -dumpversion | cut -d. -f1` == 3 ]; then
+ cat ${DISTDIR}/linux-gentoo-${KV}-gcc3.patch.bz2 | bzip2 -d | patch -p1 || die
+ fi
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ -e "s:^\(EXTRAVERSION =\).*:\1 ${EXTRAVERSION}:" \
+ Makefile.orig > Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ fi
+}