summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Rickard <frogger@gentoo.org>2003-09-13 01:09:04 +0000
committerMatt Rickard <frogger@gentoo.org>2003-09-13 01:09:04 +0000
commit1c7aa0ebad141f88163da1a7891c7e480286c053 (patch)
treec145cd0db54f6dcab4876b4b3640cc28aa9f099b /sys-kernel
parentVersion bump to -pre4 (diff)
downloadgentoo-2-1c7aa0ebad141f88163da1a7891c7e480286c053.tar.gz
gentoo-2-1c7aa0ebad141f88163da1a7891c7e480286c053.tar.bz2
gentoo-2-1c7aa0ebad141f88163da1a7891c7e480286c053.zip
Version bump to -pre4
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/vanilla-prepatch-sources/ChangeLog5
-rw-r--r--sys-kernel/vanilla-prepatch-sources/Manifest4
-rw-r--r--sys-kernel/vanilla-prepatch-sources/files/digest-vanilla-prepatch-sources-2.4.23_pre42
-rw-r--r--sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.23_pre4.ebuild46
4 files changed, 54 insertions, 3 deletions
diff --git a/sys-kernel/vanilla-prepatch-sources/ChangeLog b/sys-kernel/vanilla-prepatch-sources/ChangeLog
index 3670dc001a88..c820f1a9696e 100644
--- a/sys-kernel/vanilla-prepatch-sources/ChangeLog
+++ b/sys-kernel/vanilla-prepatch-sources/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-kernel/vanilla-prepatch-sources
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-prepatch-sources/ChangeLog,v 1.9 2003/09/04 10:25:54 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-prepatch-sources/ChangeLog,v 1.10 2003/09/13 01:08:58 frogger Exp $
+
+ 12 Sep 2003; Matthew Rickard <frogger@gentoo.org> :
+ Version bump.
*vanilla-prepatch-sources-2.4.23_pre3 (04 Sep 2003)
diff --git a/sys-kernel/vanilla-prepatch-sources/Manifest b/sys-kernel/vanilla-prepatch-sources/Manifest
index d94a4e6f4bef..c33d811028be 100644
--- a/sys-kernel/vanilla-prepatch-sources/Manifest
+++ b/sys-kernel/vanilla-prepatch-sources/Manifest
@@ -1,7 +1,7 @@
-MD5 2845b5bd249e4b2900ec17a7f2421ac1 vanilla-prepatch-sources-2.4.23_pre4.ebuild 1456
+MD5 4f15cbc16b46388eb3daccc6bf105b35 vanilla-prepatch-sources-2.4.23_pre4.ebuild 1459
MD5 404b214e0fe6c570ff4d6a96ace89ac0 vanilla-prepatch-sources-2.4.23_pre1.ebuild 1478
MD5 2845b5bd249e4b2900ec17a7f2421ac1 vanilla-prepatch-sources-2.4.23_pre3.ebuild 1456
-MD5 b6bf0dbd3406f3a00a3b2e3f2c1bd9dd ChangeLog 1790
+MD5 73735db56be4a49999dd28cee7c59240 ChangeLog 1865
MD5 2f225d1148ba5241abd41cd48c4909b6 vanilla-prepatch-sources-2.4.23_pre2.ebuild 1456
MD5 fe38999b2c32f6a517b9ff32586ab03a files/digest-vanilla-prepatch-sources-2.4.23_pre1 133
MD5 089c84bf255abea66cf7ca3ea1f1439c files/digest-vanilla-prepatch-sources-2.4.23_pre2 133
diff --git a/sys-kernel/vanilla-prepatch-sources/files/digest-vanilla-prepatch-sources-2.4.23_pre4 b/sys-kernel/vanilla-prepatch-sources/files/digest-vanilla-prepatch-sources-2.4.23_pre4
new file mode 100644
index 000000000000..71ee19e92f5f
--- /dev/null
+++ b/sys-kernel/vanilla-prepatch-sources/files/digest-vanilla-prepatch-sources-2.4.23_pre4
@@ -0,0 +1,2 @@
+MD5 75dc85149b06ac9432106b8941eb9f7b linux-2.4.22.tar.bz2 29528612
+MD5 2077d25414ae48bcae804f689d04d286 patch-2.4.23-pre4.bz2 1319718
diff --git a/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.23_pre4.ebuild b/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.23_pre4.ebuild
new file mode 100644
index 000000000000..02a3da0a0072
--- /dev/null
+++ b/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.23_pre4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.23_pre4.ebuild,v 1.1 2003/09/13 01:08:58 frogger Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version.
+
+ETYPE="sources"
+
+inherit kernel || die
+
+OKV="2.4.22"
+KV="${PV/_/-}"
+S=${WORKDIR}/linux-${KV}
+
+EXTRAVERSION="`echo ${KV}|sed -e 's:[^-]*\(-.*$\):\1:'`"
+BASE="`echo ${KV}|sed -e s:${EXTRAVERSION}::`"
+
+DESCRIPTION="Full sources for the prerelease vanilla Linux kernel"
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://kernel/linux/kernel/v2.4/testing/patch-${PV/_/-}.bz2"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+
+ cd linux-${KV}
+
+ bzcat ${DISTDIR}/patch-${PV/_/-}.bz2|patch -p1 || die "-marcelo patch failed"
+
+ kernel_universal_unpack
+}
+
+pkg_postinst() {
+ einfo "Prepatches are the equivalent to alpha releases for Linux."
+ einfo "They may be poorly tested, and may not work at all."
+ einfo "Prepatches with -rc in the name are release candidates and"
+ einfo "may become full versions. It is particularly important"
+ einfo "that these are thoroughly tested and bugs are reported back"
+ einfo "upstream (and not to the Gentoo team)."
+}