summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2015-02-18 17:02:17 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2015-02-18 17:02:17 +0000
commit1468449edc3b195967d7df4f397728578f0c41c5 (patch)
treefb6d9e43be9dd8c5f38e451d22cfa2df7df3cf3c /sys-kernel
parentFix typos in README.gentoo, https://github.com/gentoo/gentoo-portage-rsync-mi... (diff)
downloadgentoo-2-1468449edc3b195967d7df4f397728578f0c41c5.tar.gz
gentoo-2-1468449edc3b195967d7df4f397728578f0c41c5.tar.bz2
gentoo-2-1468449edc3b195967d7df4f397728578f0c41c5.zip
Version bump.
NEWS ~~~~ - fixed the shutdown loop - fixed gzip compression for versions, which do not have --rsyncable - fixed ifcfg generation for persistent interface names - multipath: * new option to turn off multipath "rd.multipath=0" completly * preload scsi dh modules * start multipathd via systemd service - do not fail, if user pressed ESC during media check - fixed systemd-journal by symlinking /var/log to /run/initramfs/log - initrd-release moved to /usr/lib - lots of iSCSI fixes - new "rd.timeout" to specify the systemd JobTimeoutSec for devices - if $initrd/etc/cmdline.d/* has a "root=" and the kernel cmdline does not, generate a mount unit for it - increased the initqueue timeout for non systemd initramfs to 180s - $initrd/etc/cmdline.d/ hostonly files are now generated for NFS - make use of systemd-hibernate-resume, if available - fixed ldconfig parsing for hwcap output - network: add support for comma separated autoconf options like ip=eth0:auto6,dhcp - new parameter "rd.live.overlay.size" to specify the overlay for live images - added cache tools for dm-cache setups (Portage version: 2.2.16/cvs/Linux x86_64, signed Manifest commit with key F0134531E1DBFAB5)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/dracut/ChangeLog37
-rw-r--r--sys-kernel/dracut/dracut-041.ebuild271
-rw-r--r--sys-kernel/dracut/files/041-0001-dracut-functions.sh-support-for-altern.patch41
-rw-r--r--sys-kernel/dracut/files/041-0002-gentoo.conf-let-udevdir-be-handled-by-.patch30
-rw-r--r--sys-kernel/dracut/files/041-0003-Use-the-same-paths-in-dracut.sh-as-tho.patch74
-rw-r--r--sys-kernel/dracut/files/041-0004-Install-dracut-install-into-libexec-di.patch81
-rw-r--r--sys-kernel/dracut/files/041-0005-Take-into-account-lib64-dirs-when-dete.patch44
7 files changed, 577 insertions, 1 deletions
diff --git a/sys-kernel/dracut/ChangeLog b/sys-kernel/dracut/ChangeLog
index 5c5aca3c96bb..0d5a92cf43f8 100644
--- a/sys-kernel/dracut/ChangeLog
+++ b/sys-kernel/dracut/ChangeLog
@@ -1,6 +1,41 @@
# ChangeLog for sys-kernel/dracut
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/ChangeLog,v 1.185 2015/01/11 14:30:10 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/ChangeLog,v 1.186 2015/02/18 17:02:17 aidecoe Exp $
+
+*dracut-041 (17 Feb 2015)
+
+ 17 Feb 2015; Amadeusz Żołnowski <aidecoe@gentoo.org> +dracut-041.ebuild,
+ +files/041-0001-dracut-functions.sh-support-for-altern.patch,
+ +files/041-0002-gentoo.conf-let-udevdir-be-handled-by-.patch,
+ +files/041-0003-Use-the-same-paths-in-dracut.sh-as-tho.patch,
+ +files/041-0004-Install-dracut-install-into-libexec-di.patch,
+ +files/041-0005-Take-into-account-lib64-dirs-when-dete.patch:
+ Version bump.
+
+ NEWS
+ ~~~~
+ - fixed the shutdown loop
+ - fixed gzip compression for versions, which do not have --rsyncable
+ - fixed ifcfg generation for persistent interface names
+ - multipath:
+ * new option to turn off multipath "rd.multipath=0" completly
+ * preload scsi dh modules
+ * start multipathd via systemd service
+ - do not fail, if user pressed ESC during media check
+ - fixed systemd-journal by symlinking /var/log to /run/initramfs/log
+ - initrd-release moved to /usr/lib
+ - lots of iSCSI fixes
+ - new "rd.timeout" to specify the systemd JobTimeoutSec for devices
+ - if $initrd/etc/cmdline.d/* has a "root=" and the kernel cmdline does not,
+ generate a mount unit for it
+ - increased the initqueue timeout for non systemd initramfs to 180s
+ - $initrd/etc/cmdline.d/ hostonly files are now generated for NFS
+ - make use of systemd-hibernate-resume, if available
+ - fixed ldconfig parsing for hwcap output
+ - network: add support for comma separated autoconf options like
+ ip=eth0:auto6,dhcp
+ - new parameter "rd.live.overlay.size" to specify the overlay for live images
+ - added cache tools for dm-cache setups
11 Jan 2015; Amadeusz Żołnowski <aidecoe@gentoo.org> -dracut-040.ebuild,
-dracut-040-r1.ebuild:
diff --git a/sys-kernel/dracut/dracut-041.ebuild b/sys-kernel/dracut/dracut-041.ebuild
new file mode 100644
index 000000000000..cfda414d76a7
--- /dev/null
+++ b/sys-kernel/dracut/dracut-041.ebuild
@@ -0,0 +1,271 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/dracut-041.ebuild,v 1.1 2015/02/18 17:02:17 aidecoe Exp $
+
+EAPI=4
+
+inherit bash-completion-r1 eutils linux-info multilib systemd
+
+DESCRIPTION="Generic initramfs generation tool"
+HOMEPAGE="http://dracut.wiki.kernel.org"
+SRC_URI="mirror://kernel/linux/utils/boot/${PN}/${P}.tar.xz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug selinux systemd"
+
+RESTRICT="test"
+
+CDEPEND="virtual/udev
+ systemd? ( >=sys-apps/systemd-199 )
+ "
+RDEPEND="${CDEPEND}
+ app-arch/cpio
+ >=app-shells/bash-4.0
+ >sys-apps/kmod-5[tools]
+ || ( >=sys-apps/sysvinit-2.87-r3 sys-apps/systemd[sysv-utils] sys-apps/systemd-sysv-utils )
+ >=sys-apps/util-linux-2.21
+
+ debug? ( dev-util/strace )
+ selinux? (
+ sys-libs/libselinux
+ sys-libs/libsepol
+ sec-policy/selinux-dracut
+ )
+ "
+DEPEND="${CDEPEND}
+ app-text/asciidoc
+ >=dev-libs/libxslt-1.1.26
+ app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75.2
+ virtual/pkgconfig
+ "
+
+DOCS=( AUTHORS HACKING NEWS README README.generic README.kernel README.modules
+ README.testsuite TODO )
+MY_LIBDIR=/usr/lib
+PATCHES=(
+ "${FILESDIR}/${PV}-0001-dracut-functions.sh-support-for-altern.patch"
+ "${FILESDIR}/${PV}-0002-gentoo.conf-let-udevdir-be-handled-by-.patch"
+ "${FILESDIR}/${PV}-0003-Use-the-same-paths-in-dracut.sh-as-tho.patch"
+ "${FILESDIR}/${PV}-0004-Install-dracut-install-into-libexec-di.patch"
+ "${FILESDIR}/${PV}-0005-Take-into-account-lib64-dirs-when-dete.patch"
+ )
+QA_MULTILIB_PATHS="
+ usr/lib/dracut/dracut-install
+ usr/lib/dracut/skipcpio
+ "
+
+#
+# Helper functions
+#
+
+# Removes module from modules.d.
+# $1 = module name
+# Module name can be specified without number prefix.
+rm_module() {
+ local force m
+ [[ $1 = -f ]] && force=-f
+
+ for m in $@; do
+ if [[ $m =~ ^[0-9][0-9][^\ ]*$ ]]; then
+ rm ${force} --interactive=never -r "${modules_dir}"/$m
+ else
+ rm ${force} --interactive=never -r "${modules_dir}"/[0-9][0-9]$m
+ fi
+ done
+}
+
+# Grabbed from net-misc/netctl ebuild.
+optfeature() {
+ local desc=$1
+ shift
+ while (( $# )); do
+ if has_version "$1"; then
+ elog " [I] $1 to ${desc}"
+ else
+ elog " [ ] $1 to ${desc}"
+ fi
+ shift
+ done
+}
+
+#
+# ebuild functions
+#
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+
+ local libdirs="/$(get_libdir) /usr/$(get_libdir)"
+ if [[ ${SYMLINK_LIB} = yes ]]; then
+ # Preserve lib -> lib64 symlinks in initramfs
+ [[ $libdirs =~ /lib\ ]] || libdirs+=" /lib /usr/lib"
+ fi
+ einfo "Setting libdirs to \"${libdirs}\" ..."
+ sed -e "3alibdirs=\"${libdirs}\"" \
+ -i "${S}/dracut.conf.d/gentoo.conf.example" || die
+
+ local udevdir="$("$(tc-getPKG_CONFIG)" udev --variable=udevdir)"
+ einfo "Setting udevdir to ${udevdir}..."
+ sed -r -e "s|^(udevdir=).*$|\1${udevdir}|" \
+ -i "${S}/dracut.conf.d/gentoo.conf.example" || die
+
+ if use systemd; then
+ local systemdutildir="$(systemd_get_utildir)"
+ local systemdsystemunitdir="$(systemd_get_unitdir)"
+ local systemdsystemconfdir="$("$(tc-getPKG_CONFIG)" systemd \
+ --variable=systemdsystemconfdir)"
+ [[ ${systemdsystemconfdir} ]] \
+ || systemdsystemconfdir=/etc/systemd/system
+ einfo "Setting systemdutildir to ${systemdutildir} and ..."
+ sed -e "5asystemdutildir=\"${systemdutildir}\"" \
+ -i "${S}/dracut.conf.d/gentoo.conf.example" || die
+ einfo "Setting systemdsystemunitdir to ${systemdsystemunitdir} and..."
+ sed -e "6asystemdsystemunitdir=\"${systemdsystemunitdir}\"" \
+ -i "${S}/dracut.conf.d/gentoo.conf.example" || die
+ einfo "Setting systemdsystemconfdir to ${systemdsystemconfdir}..."
+ sed -e "7asystemdsystemconfdir=\"${systemdsystemconfdir}\"" \
+ -i "${S}/dracut.conf.d/gentoo.conf.example" || die
+ else
+ local systemdutildir="/lib/systemd"
+ einfo "Setting systemdutildir for standalone udev to" \
+ "${systemdutildir}..."
+ sed -e "5asystemdutildir=\"${systemdutildir}\"" \
+ -i "${S}/dracut.conf.d/gentoo.conf.example" || die
+ fi
+
+ epatch_user
+}
+
+src_configure() {
+ local myconf="--libdir=${MY_LIBDIR}"
+ myconf+=" --bashcompletiondir=$(get_bashcompdir)"
+
+ if use systemd; then
+ myconf+=" --systemdsystemunitdir='$(systemd_get_unitdir)'"
+ fi
+
+ econf ${myconf}
+}
+
+src_compile() {
+ tc-export CC
+ emake doc install/dracut-install skipcpio/skipcpio
+}
+
+src_install() {
+ default
+
+ local my_libdir="${MY_LIBDIR}"
+ local dracutlibdir="${my_libdir#/}/dracut"
+
+ echo "DRACUT_VERSION=$PVR" > "${D%/}/${dracutlibdir}/dracut-version.sh"
+
+ insinto "${dracutlibdir}/dracut.conf.d/"
+ newins dracut.conf.d/gentoo.conf.example gentoo.conf
+
+ insinto /etc/logrotate.d
+ newins dracut.logrotate dracut
+
+ dodir /var/lib/dracut/overlay
+
+ dohtml dracut.html
+
+ #
+ # Modules
+ #
+ local module
+ modules_dir="${D%/}/${dracutlibdir}/modules.d"
+
+ use debug || rm_module 95debug
+ use selinux || rm_module 98selinux
+
+ if use systemd; then
+ # With systemd following modules do not make sense
+ rm_module 96securityfs 97masterkey 98integrity
+ else
+ rm_module 98systemd
+ # Without systemd following modules do not make sense
+ rm_module 00systemd-bootchart
+ fi
+
+ # Remove modules which won't work for sure
+ rm_module 95fcoe # no tools
+ # fips module depends on masked app-crypt/hmaccalc
+ rm_module 01fips 02fips-aesni
+}
+
+pkg_postinst() {
+ if linux-info_get_any_version && linux_config_src_exists; then
+ ewarn ""
+ ewarn "If the following test report contains a missing kernel"
+ ewarn "configuration option, you should reconfigure and rebuild your"
+ ewarn "kernel before booting image generated with this Dracut version."
+ ewarn ""
+
+ local CONFIG_CHECK="~BLK_DEV_INITRD ~DEVTMPFS"
+
+ # Kernel configuration options descriptions:
+ local desc_DEVTMPFS="Maintain a devtmpfs filesystem to mount at /dev"
+ local desc_BLK_DEV_INITRD="Initial RAM filesystem and RAM disk "\
+"(initramfs/initrd) support"
+
+ local opt desc
+
+ # Generate ERROR_* variables for check_extra_config.
+ for opt in ${CONFIG_CHECK}; do
+ opt=${opt#\~}
+ desc=desc_${opt}
+ eval "local ERROR_${opt}='CONFIG_${opt}: \"${!desc}\"" \
+ "is missing and REQUIRED'"
+ done
+
+ check_extra_config
+ echo
+ else
+ ewarn ""
+ ewarn "Your kernel configuration couldn't be checked. Do you have"
+ ewarn "/usr/src/linux/.config file there? Please check manually if"
+ ewarn "following options are enabled:"
+ ewarn ""
+ ewarn " CONFIG_BLK_DEV_INITRD"
+ ewarn " CONFIG_DEVTMPFS"
+ ewarn ""
+ fi
+
+ elog "To get additional features, a number of optional runtime"
+ elog "dependencies may be installed:"
+ elog ""
+ optfeature "Networking support" net-misc/curl "net-misc/dhcp[client]" \
+ sys-apps/iproute2
+ optfeature \
+ "Measure performance of the boot process for later visualisation" \
+ app-benchmarks/bootchart2 app-admin/killproc sys-process/acct
+ optfeature "Scan for Btrfs on block devices" sys-fs/btrfs-progs
+ optfeature "Load kernel modules and drop this privilege for real init" \
+ sys-libs/libcap
+ optfeature "Support CIFS" net-fs/cifs-utils
+ optfeature "Decrypt devices encrypted with cryptsetup/LUKS" \
+ sys-fs/cryptsetup
+ optfeature "Support for GPG-encrypted keys for crypt module" \
+ app-crypt/gnupg
+ optfeature \
+ "Allows use of dash instead of default bash (on your own risk)" \
+ app-shells/dash
+ optfeature "Framebuffer splash (media-gfx/splashutils)" \
+ media-gfx/splashutils
+ optfeature "Support iSCSI" sys-block/open-iscsi
+ optfeature "Support Logical Volume Manager" sys-fs/lvm2
+ optfeature "Support MD devices, also known as software RAID devices" \
+ sys-fs/mdadm
+ optfeature "Support Device Mapper multipathing" sys-fs/multipath-tools
+ optfeature "Plymouth boot splash" '>=sys-boot/plymouth-0.8.5-r5'
+ optfeature "Support network block devices" sys-block/nbd
+ optfeature "Support NFS" net-fs/nfs-utils net-nds/rpcbind
+ optfeature \
+ "Install ssh and scp along with config files and specified keys" \
+ net-misc/openssh
+ optfeature "Enable logging with syslog-ng or rsyslog" app-admin/syslog-ng \
+ app-admin/rsyslog
+}
diff --git a/sys-kernel/dracut/files/041-0001-dracut-functions.sh-support-for-altern.patch b/sys-kernel/dracut/files/041-0001-dracut-functions.sh-support-for-altern.patch
new file mode 100644
index 000000000000..acd998c4ab00
--- /dev/null
+++ b/sys-kernel/dracut/files/041-0001-dracut-functions.sh-support-for-altern.patch
@@ -0,0 +1,41 @@
+From d6d86dcc914f6f8a054d24a8d033f645a51509a9 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Amadeusz=20=C5=BBo=C5=82nowski?= <aidecoe@aidecoe.name>
+Date: Sun, 6 Jan 2013 13:35:01 +0100
+Subject: [PATCH 1/5] dracut-functions.sh: support for alternative udev dirs -
+ udevaltdirs
+
+It is required for Gentoo which moves udev from / to /usr and supports
+both /lib/udev and /usr/lib/udev for compatibility with other packages.
+
+Credits go to Alexander Tsoy <alexander@tsoy.me>.
+
+Conflicts:
+ dracut-functions.sh
+---
+ dracut-functions.sh | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/dracut-functions.sh b/dracut-functions.sh
+index 37ddca2..0eb36da 100755
+--- a/dracut-functions.sh
++++ b/dracut-functions.sh
+@@ -937,6 +937,16 @@ inst_rules() {
+ inst_dir "$_target"
+ for _rule in "$@"; do
+ if [ "${_rule#/}" = "$_rule" ]; then
++ for r in ${udevaltdirs}; do
++ [[ "$r" = "${udevdir}" ]] && continue
++ if [[ -e $r/rules.d/$_rule ]]; then
++ _found="$r/rules.d/$_rule"
++ inst_rule_programs "$_found"
++ inst_rule_group_owner "$_found"
++ inst_rule_initqueue "$_found"
++ inst_simple "$_found" "${udevdir}/rules.d/${_found##*/}"
++ fi
++ done
+ for r in ${udevdir}/rules.d ${hostonly:+/etc/udev/rules.d}; do
+ if [[ -e $r/$_rule ]]; then
+ _found="$r/$_rule"
+--
+2.3.0
+
diff --git a/sys-kernel/dracut/files/041-0002-gentoo.conf-let-udevdir-be-handled-by-.patch b/sys-kernel/dracut/files/041-0002-gentoo.conf-let-udevdir-be-handled-by-.patch
new file mode 100644
index 000000000000..a1d41c72de1c
--- /dev/null
+++ b/sys-kernel/dracut/files/041-0002-gentoo.conf-let-udevdir-be-handled-by-.patch
@@ -0,0 +1,30 @@
+From 86857645052ec06cebc5f57bf81bed3bf142543c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Amadeusz=20=C5=BBo=C5=82nowski?= <aidecoe@aidecoe.name>
+Date: Sun, 16 Dec 2012 20:02:48 +0100
+Subject: [PATCH 2/5] gentoo.conf: let udevdir= be handled by pkg-config and
+ use udevaltdirs
+
+To avoid need of rebuild after udev update/downgrade let udevdir= be set
+dynamically with pkg-config. Use udevaltdirs to search for rules both
+in old and new locations.
+---
+ dracut.conf.d/gentoo.conf.example | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/dracut.conf.d/gentoo.conf.example b/dracut.conf.d/gentoo.conf.example
+index 26e7314..f9617f0 100644
+--- a/dracut.conf.d/gentoo.conf.example
++++ b/dracut.conf.d/gentoo.conf.example
+@@ -1,7 +1,8 @@
+ # /etc/dracut.conf.d/gentoo.conf
+ # dracut config file customized for Gentoo Base System release 2
+
+-udevdir=/lib/udev
++udevdir=
++udevaltdirs="/lib/udev /usr/lib/udev"
+ ro_mnt=yes
+
+ #
+--
+2.3.0
+
diff --git a/sys-kernel/dracut/files/041-0003-Use-the-same-paths-in-dracut.sh-as-tho.patch b/sys-kernel/dracut/files/041-0003-Use-the-same-paths-in-dracut.sh-as-tho.patch
new file mode 100644
index 000000000000..43436a2eb450
--- /dev/null
+++ b/sys-kernel/dracut/files/041-0003-Use-the-same-paths-in-dracut.sh-as-tho.patch
@@ -0,0 +1,74 @@
+From 32c439ed3f62a821827e9b3e7de45789dccbf897 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Amadeusz=20=C5=BBo=C5=82nowski?= <aidecoe@aidecoe.name>
+Date: Wed, 2 Oct 2013 22:37:09 +0200
+Subject: [PATCH 3/5] Use the same paths in dracut.sh as those set with
+ configure script
+
+Makefile alters destination main dracut script and sets dracutbasedir to
+the value of pkglibdir set in configure.
+---
+ Makefile | 3 +++
+ dracut.sh | 9 ++++-----
+ 2 files changed, 7 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 41ae274..41968b0 100644
+--- a/Makefile
++++ b/Makefile
+@@ -103,6 +103,9 @@ install: dracut-version.sh
+ mkdir -p $(DESTDIR)$(pkglibdir)/modules.d
+ mkdir -p $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(mandir)/man5 $(DESTDIR)$(mandir)/man7 $(DESTDIR)$(mandir)/man8
+ install -m 0755 dracut.sh $(DESTDIR)$(bindir)/dracut
++ sed -r \
++ -e "s|^(pkglibdir)=.*|\1=$(pkglibdir)|" \
++ -i $(DESTDIR)$(bindir)/dracut
+ install -m 0755 dracut-catimages.sh $(DESTDIR)$(bindir)/dracut-catimages
+ install -m 0755 mkinitrd-dracut.sh $(DESTDIR)$(bindir)/mkinitrd
+ install -m 0755 lsinitrd.sh $(DESTDIR)$(bindir)/lsinitrd
+diff --git a/dracut.sh b/dracut.sh
+index 5e2feba..89a711e 100755
+--- a/dracut.sh
++++ b/dracut.sh
+@@ -24,10 +24,13 @@
+ # store for logging
+ dracut_args=( "$@" )
+
++# base dirs
++pkglibdir=/usr/lib/dracut
++dracutbasedir="$pkglibdir"
++
+ set -o pipefail
+
+ usage() {
+- [[ $dracutbasedir ]] || dracutbasedir=/usr/lib/dracut
+ if [[ -f $dracutbasedir/dracut-version.sh ]]; then
+ . $dracutbasedir/dracut-version.sh
+ fi
+@@ -52,7 +55,6 @@ EOF
+ }
+
+ long_usage() {
+- [[ $dracutbasedir ]] || dracutbasedir=/usr/lib/dracut
+ if [[ -f $dracutbasedir/dracut-version.sh ]]; then
+ . $dracutbasedir/dracut-version.sh
+ fi
+@@ -666,8 +668,6 @@ export DRACUT_LOG_LEVEL=warning
+ debug=yes
+ }
+
+-[[ $dracutbasedir ]] || dracutbasedir=/usr/lib/dracut
+-
+ # if we were not passed a config file, try the default one
+ if [[ ! -f $conffile ]]; then
+ if [[ $allowlocal ]]; then
+@@ -808,7 +808,6 @@ stdloglvl=$((stdloglvl + verbosity_mod_l))
+ [[ $use_fstab_l ]] && use_fstab=$use_fstab_l
+ [[ $mdadmconf_l ]] && mdadmconf=$mdadmconf_l
+ [[ $lvmconf_l ]] && lvmconf=$lvmconf_l
+-[[ $dracutbasedir ]] || dracutbasedir=/usr/lib/dracut
+ [[ $fw_dir ]] || fw_dir="/lib/firmware/updates /lib/firmware"
+ [[ $tmpdir_l ]] && tmpdir="$tmpdir_l"
+ [[ $tmpdir ]] || tmpdir=/var/tmp
+--
+2.3.0
+
diff --git a/sys-kernel/dracut/files/041-0004-Install-dracut-install-into-libexec-di.patch b/sys-kernel/dracut/files/041-0004-Install-dracut-install-into-libexec-di.patch
new file mode 100644
index 000000000000..637b560ddb8f
--- /dev/null
+++ b/sys-kernel/dracut/files/041-0004-Install-dracut-install-into-libexec-di.patch
@@ -0,0 +1,81 @@
+From 7498b3128103cf77fdef5ccd97205dfd0338fb82 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Amadeusz=20=C5=BBo=C5=82nowski?= <aidecoe@aidecoe.name>
+Date: Wed, 2 Oct 2013 22:40:43 +0200
+Subject: [PATCH 4/5] Install dracut-install into libexec dir instead of lib
+ dir
+
+dracut-install script is the only thing ABI specific atm.
+
+See https://bugs.gentoo.org/show_bug.cgi?id=485218 for details on the
+problem.
+---
+ Makefile | 4 +++-
+ configure | 1 +
+ dracut-functions.sh | 4 ++++
+ dracut.sh | 1 +
+ 4 files changed, 9 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 41968b0..b072a23 100644
+--- a/Makefile
++++ b/Makefile
+@@ -104,6 +104,7 @@ install: dracut-version.sh
+ mkdir -p $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(mandir)/man5 $(DESTDIR)$(mandir)/man7 $(DESTDIR)$(mandir)/man8
+ install -m 0755 dracut.sh $(DESTDIR)$(bindir)/dracut
+ sed -r \
++ -e "s|^(libexecdir)=.*|\1=$(libexecdir)|" \
+ -e "s|^(pkglibdir)=.*|\1=$(pkglibdir)|" \
+ -i $(DESTDIR)$(bindir)/dracut
+ install -m 0755 dracut-catimages.sh $(DESTDIR)$(bindir)/dracut-catimages
+@@ -147,7 +148,8 @@ endif
+ done \
+ fi
+ if [ -f install/dracut-install ]; then \
+- install -m 0755 install/dracut-install $(DESTDIR)$(pkglibdir)/dracut-install; \
++ mkdir -p $(DESTDIR)$(libexecdir); \
++ install -m 0755 install/dracut-install $(DESTDIR)$(libexecdir)/dracut-install; \
+ fi
+ if [ -f skipcpio/skipcpio ]; then \
+ install -m 0755 skipcpio/skipcpio $(DESTDIR)$(pkglibdir)/skipcpio; \
+diff --git a/configure b/configure
+index 0bd3d2d..17370de 100755
+--- a/configure
++++ b/configure
+@@ -59,6 +59,7 @@ sbindir ?= ${sbindir:-${prefix}/sbin}
+ mandir ?= ${mandir:-${prefix}/share/man}
+ enable_documentation ?= ${enable_documentation:-yes}
+ bindir ?= ${bindir:-${prefix}/bin}
++libexecdir ?= ${libexecdir:-${prefix}/libexec}
+ EOF
+
+ {
+diff --git a/dracut-functions.sh b/dracut-functions.sh
+index 0eb36da..4484e71 100755
+--- a/dracut-functions.sh
++++ b/dracut-functions.sh
+@@ -733,6 +733,10 @@ if ! [[ $DRACUT_INSTALL ]]; then
+ DRACUT_INSTALL=$(find_binary dracut-install)
+ fi
+
++if ! [[ $DRACUT_INSTALL ]] && [[ -x $libexecdir/dracut-install ]]; then
++ DRACUT_INSTALL=$libexecdir/dracut-install
++fi
++
+ if ! [[ $DRACUT_INSTALL ]] && [[ -x $dracutbasedir/dracut-install ]]; then
+ DRACUT_INSTALL=$dracutbasedir/dracut-install
+ elif ! [[ $DRACUT_INSTALL ]] && [[ -x $dracutbasedir/install/dracut-install ]]; then
+diff --git a/dracut.sh b/dracut.sh
+index 89a711e..527b32e 100755
+--- a/dracut.sh
++++ b/dracut.sh
+@@ -25,6 +25,7 @@
+ dracut_args=( "$@" )
+
+ # base dirs
++libexecdir=/usr/libexec
+ pkglibdir=/usr/lib/dracut
+ dracutbasedir="$pkglibdir"
+
+--
+2.3.0
+
diff --git a/sys-kernel/dracut/files/041-0005-Take-into-account-lib64-dirs-when-dete.patch b/sys-kernel/dracut/files/041-0005-Take-into-account-lib64-dirs-when-dete.patch
new file mode 100644
index 000000000000..da9be91265bc
--- /dev/null
+++ b/sys-kernel/dracut/files/041-0005-Take-into-account-lib64-dirs-when-dete.patch
@@ -0,0 +1,44 @@
+From e776f28b742ed829f5b53ca2079562c9c6c28c8c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Amadeusz=20=C5=BBo=C5=82nowski?= <aidecoe@aidecoe.name>
+Date: Sun, 11 Jan 2015 15:10:39 +0100
+Subject: [PATCH 5/5] Take into account lib64 dirs when detecting version,
+ modules and params
+
+---
+ lsinitrd.sh | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/lsinitrd.sh b/lsinitrd.sh
+index 4f12c2c..dc1f88f 100755
+--- a/lsinitrd.sh
++++ b/lsinitrd.sh
+@@ -124,7 +124,7 @@ extract_files()
+ list_modules()
+ {
+ echo "dracut modules:"
+- $CAT "$image" | cpio --extract --verbose --quiet --to-stdout -- 'lib/dracut/modules.txt' 'usr/lib/dracut/modules.txt' 2>/dev/null
++ $CAT "$image" | cpio --extract --verbose --quiet --to-stdout -- 'lib64/dracut/modules.txt' 'lib/dracut/modules.txt' 'usr/lib/dracut/modules.txt' 2>/dev/null
+ ((ret+=$?))
+ }
+
+@@ -217,7 +217,7 @@ ret=0
+ if (( ${#filenames[@]} > 0 )); then
+ extract_files
+ else
+- version=$($CAT "$image" | cpio --extract --verbose --quiet --to-stdout -- 'lib/dracut/dracut-*' 'usr/lib/dracut/dracut-*' 2>/dev/null)
++ version=$($CAT "$image" | cpio --extract --verbose --quiet --to-stdout -- 'lib64/dracut/dracut-*' 'lib/dracut/dracut-*' 'usr/lib/dracut/dracut-*' 2>/dev/null)
+ ((ret+=$?))
+ echo "Version: $version"
+ echo
+@@ -226,7 +226,7 @@ else
+ echo "========================================================================"
+ else
+ echo -n "Arguments: "
+- $CAT "$image" | cpio --extract --verbose --quiet --to-stdout -- 'lib/dracut/build-parameter.txt' 'usr/lib/dracut/build-parameter.txt' 2>/dev/null
++ $CAT "$image" | cpio --extract --verbose --quiet --to-stdout -- 'lib64/dracut/build-parameter.txt' 'lib/dracut/build-parameter.txt' 'usr/lib/dracut/build-parameter.txt' 2>/dev/null
+ echo
+ list_modules
+ list_files
+--
+2.3.0
+