summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2012-01-27 22:08:23 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2012-01-27 22:08:23 +0000
commit0dc160b6d19f315e6e71b58cedcfd49aaab1020e (patch)
treebb35d5e94b841e12bd166823b67e518492e65d7a /sys-kernel
parentAdd missing gconf-python dep (bug #401083, thanks to Ben Kohler for reporting... (diff)
downloadgentoo-2-0dc160b6d19f315e6e71b58cedcfd49aaab1020e.tar.gz
gentoo-2-0dc160b6d19f315e6e71b58cedcfd49aaab1020e.tar.bz2
gentoo-2-0dc160b6d19f315e6e71b58cedcfd49aaab1020e.zip
Version bump.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ck-sources/ChangeLog9
-rw-r--r--sys-kernel/ck-sources/ck-sources-3.2.2.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index 31bde46ded9a..2782fee55225 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/ck-sources
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.200 2011/11/30 19:09:09 nelchael Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.201 2012/01/27 22:08:23 nelchael Exp $
+
+*ck-sources-3.2.2 (27 Jan 2012)
+
+ 27 Jan 2012; Krzysztof Pawlik <nelchael@gentoo.org> +ck-sources-3.2.2.ebuild:
+ Version bump.
*ck-sources-3.1.4 (30 Nov 2011)
diff --git a/sys-kernel/ck-sources/ck-sources-3.2.2.ebuild b/sys-kernel/ck-sources/ck-sources-3.2.2.ebuild
new file mode 100644
index 000000000000..48f4dfd1deb2
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-3.2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-3.2.2.ebuild,v 1.1 2012/01/27 22:08:23 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="5"
+K_SECURITY_UNSUPPORTED="1"
+
+inherit kernel-2 versionator
+detect_version
+detect_arch
+
+DESCRIPTION="Con Kolivas' high performance patchset + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://users.on.net/~ckolivas/kernel/"
+
+BASE_VERSION="$(get_version_component_range 1-2)"
+CK_VERSION="1"
+
+CK_URI="http://ck.kolivas.org/patches/3.0/${BASE_VERSION}/${BASE_VERSION}-ck${CK_VERSION}/patch-${BASE_VERSION}-ck${CK_VERSION}.bz2"
+UNIPATCH_LIST="${DISTDIR}/patch-${BASE_VERSION}-ck${CK_VERSION}.bz2"
+
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ kernel-2_src_unpack
+
+ # Comment out EXTRAVERSION added by CK patch:
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}