summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-05-10 15:17:37 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-05-10 15:17:37 +0000
commit69d8e1f5f21ab8d05ed49c838396f26aa22efcd7 (patch)
treee8bea4a9442df2e7acb8fb6f45089ee741be2e24 /sys-kernel/zen-sources
parentremove old (diff)
downloadgentoo-2-69d8e1f5f21ab8d05ed49c838396f26aa22efcd7.tar.gz
gentoo-2-69d8e1f5f21ab8d05ed49c838396f26aa22efcd7.tar.bz2
gentoo-2-69d8e1f5f21ab8d05ed49c838396f26aa22efcd7.zip
New snapshot
(Portage version: 2.1.9.47/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/zen-sources')
-rw-r--r--sys-kernel/zen-sources/ChangeLog8
-rw-r--r--sys-kernel/zen-sources/metadata.xml2
-rw-r--r--sys-kernel/zen-sources/zen-sources-2.6.38_p20110510.ebuild55
3 files changed, 64 insertions, 1 deletions
diff --git a/sys-kernel/zen-sources/ChangeLog b/sys-kernel/zen-sources/ChangeLog
index 404d36bbf4ea..0a79cef190d4 100644
--- a/sys-kernel/zen-sources/ChangeLog
+++ b/sys-kernel/zen-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/zen-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/zen-sources/ChangeLog,v 1.50 2011/05/01 19:38:57 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/zen-sources/ChangeLog,v 1.51 2011/05/10 15:17:37 hwoarang Exp $
+
+*zen-sources-2.6.38_p20110510 (10 May 2011)
+
+ 10 May 2011; Markos Chandras <hwoarang@gentoo.org>
+ +zen-sources-2.6.38_p20110510.ebuild:
+ New snapshot
*zen-sources-2.6.38_p20110501 (01 May 2011)
diff --git a/sys-kernel/zen-sources/metadata.xml b/sys-kernel/zen-sources/metadata.xml
index 42265cf31942..890331c90a35 100644
--- a/sys-kernel/zen-sources/metadata.xml
+++ b/sys-kernel/zen-sources/metadata.xml
@@ -13,6 +13,8 @@
<use>
<flag name="bfq">Make the BFQ IO Scheduler available by applying upstream patches</flag>
<flag name="stable">Clone stable git tree</flag>
+ <flag name="tuxonice">Apply TuxOnIce kernel patches advanced hibernation
+ support</flag>
<flag name='deblob'>Remove binary blobs from kernel sources to provide libre license compliance.</flag>
</use>
</pkgmetadata>
diff --git a/sys-kernel/zen-sources/zen-sources-2.6.38_p20110510.ebuild b/sys-kernel/zen-sources/zen-sources-2.6.38_p20110510.ebuild
new file mode 100644
index 000000000000..b18cd1b57bd9
--- /dev/null
+++ b/sys-kernel/zen-sources/zen-sources-2.6.38_p20110510.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/zen-sources/zen-sources-2.6.38_p20110510.ebuild,v 1.1 2011/05/10 15:17:36 hwoarang Exp $
+
+EAPI="2"
+
+COMPRESSTYPE=".lzma"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="${PV/_p[0-9]*}"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="The Zen Kernel Sources v2.6"
+HOMEPAGE="http://zen-kernel.org"
+
+ZEN_FILE="zen-patch-${PV}.diff.gz"
+ZEN_URI="http://dev.gentoo.org/~hwoarang/distfiles/${ZEN_FILE}"
+TUXONICE_FILE="tuxonice-3.2-for-$(get_version_component_range 1-3).patch.bz2"
+TUXONICE_URI="tuxonice? ( http://tuxonice.net/files/${TUXONICE_FILE} )"
+SRC_URI="${KERNEL_URI} ${ZEN_URI} ${TUXONICE_URI}"
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="tuxonice"
+
+DEPEND="|| ( app-arch/xz-utils app-arch/lzma-utils )"
+RDEPEND=""
+
+KV_FULL="${PVR/_p/-zen}"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the Zen developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ ebeep 8
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${ZEN_FILE}"
+ if use tuxonice; then
+ epatch "${DISTDIR}"/${TUXONICE_FILE}
+ fi
+}
+
+K_EXTRAEINFO="For more info on zen-sources and details on how to report problems, see: \
+${HOMEPAGE}. You may also visit #zen-sources on irc.rizon.net"