summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-10-12 21:26:48 +0000
committerPacho Ramos <pacho@gentoo.org>2011-10-12 21:26:48 +0000
commit7579783edf542aef7f8deefe61f1abc9958dac93 (patch)
tree3188b8d0604f29c8984e8944a79b08860a610fe0 /sys-kernel/tuxonice-sources
parentFix underlinking, #367405 (diff)
downloadgentoo-2-7579783edf542aef7f8deefe61f1abc9958dac93.tar.gz
gentoo-2-7579783edf542aef7f8deefe61f1abc9958dac93.tar.bz2
gentoo-2-7579783edf542aef7f8deefe61f1abc9958dac93.zip
Version bump and add myself as co-maintainer.
(Portage version: 2.1.10.27/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/tuxonice-sources')
-rw-r--r--sys-kernel/tuxonice-sources/ChangeLog8
-rw-r--r--sys-kernel/tuxonice-sources/metadata.xml3
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-3.0.6.ebuild52
3 files changed, 62 insertions, 1 deletions
diff --git a/sys-kernel/tuxonice-sources/ChangeLog b/sys-kernel/tuxonice-sources/ChangeLog
index b01773dcfcbe..ca7cafae5e98 100644
--- a/sys-kernel/tuxonice-sources/ChangeLog
+++ b/sys-kernel/tuxonice-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/tuxonice-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.122 2011/07/02 15:32:00 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.123 2011/10/12 21:26:48 pacho Exp $
+
+*tuxonice-sources-3.0.6 (12 Oct 2011)
+
+ 12 Oct 2011; Pacho Ramos <pacho@gentoo.org> +tuxonice-sources-3.0.6.ebuild,
+ metadata.xml:
+ Version bump and add myself as co-maintainer.
02 Jul 2011; Markos Chandras <hwoarang@gentoo.org>
tuxonice-sources-2.6.38-r1.ebuild:
diff --git a/sys-kernel/tuxonice-sources/metadata.xml b/sys-kernel/tuxonice-sources/metadata.xml
index 9b76c5e56951..1d2e891c5fea 100644
--- a/sys-kernel/tuxonice-sources/metadata.xml
+++ b/sys-kernel/tuxonice-sources/metadata.xml
@@ -7,6 +7,9 @@
<email>nelchael@gentoo.org</email>
<name>Krzysztof Pawlik</name>
</maintainer>
+ <maintainer>
+ <email>pacho@gentoo.org</email>
+ </maintainer>
<use>
<flag name='deblob'>Remove binary blobs from kernel sources to provide libre license compliance.</flag>
</use>
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.6.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.6.ebuild
new file mode 100644
index 000000000000..0acd5a26f13b
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.6.ebuild,v 1.1 2011/10/12 21:26:48 pacho Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="8"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/ http://www.tuxonice.net"
+IUSE=""
+
+TUXONICE_SNAPSHOT="20111012"
+TUXONICE_VERSION=""
+TUXONICE_TARGET="3.0"
+
+# Because "current" patches can change without notifying, we need to supply them
+if [[ -n "${TUXONICE_SNAPSHOT}" ]]; then
+ TUXONICE_SRC="http://dev.gentoo.org/~pacho/tuxonice/current-tuxonice-for-${TUXONICE_TARGET}_${TUXONICE_SNAPSHOT}.patch"
+ UNIPATCH_LIST="${DISTDIR}/current-tuxonice-for-${TUXONICE_TARGET}_${TUXONICE_SNAPSHOT}.patch.bz2"
+else
+ TUXONICE_SRC="http://www.tuxonice.net/files/tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}.patch"
+ UNIPATCH_LIST="${DISTDIR}/tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}.patch.bz2"
+fi
+
+TUXONICE_URI="${TUXONICE_SRC}.bz2"
+
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ || ( >=sys-power/hibernate-script-2.0 sys-power/pm-utils )"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}