summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-03-09 13:38:59 +0000
committerPeter Volkov <pva@gentoo.org>2011-03-09 13:38:59 +0000
commit870186dc989ed4ed1cd276dc1b53c299666b8c0f (patch)
tree99100e496199c5dbd310494005ec742178ab0c32 /sys-kernel/openvz-sources/openvz-sources-2.6.32.11.1.ebuild
parentInitial commit - unbundled from libwww-perl (diff)
downloadgentoo-2-870186dc989ed4ed1cd276dc1b53c299666b8c0f.tar.gz
gentoo-2-870186dc989ed4ed1cd276dc1b53c299666b8c0f.tar.bz2
gentoo-2-870186dc989ed4ed1cd276dc1b53c299666b8c0f.zip
Version bump, bug #357663, thank Paul Freeman for report. 2.6.27.9.1 amd64/x86 stable, bug #198632. Drop old.
(Portage version: 2.1.9.38/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/openvz-sources/openvz-sources-2.6.32.11.1.ebuild')
-rw-r--r--sys-kernel/openvz-sources/openvz-sources-2.6.32.11.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-kernel/openvz-sources/openvz-sources-2.6.32.11.1.ebuild b/sys-kernel/openvz-sources/openvz-sources-2.6.32.11.1.ebuild
new file mode 100644
index 000000000000..618d39497505
--- /dev/null
+++ b/sys-kernel/openvz-sources/openvz-sources-2.6.32.11.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openvz-sources/openvz-sources-2.6.32.11.1.ebuild,v 1.1 2011/03/09 13:38:59 pva Exp $
+
+inherit versionator
+
+# Upstream uses string to version their releases. To make portage version
+# comparisment working we have to use numbers instead of strings, that is 4th
+# component of our version. So we have aivazovsky - 1, briullov - 2 and so on.
+# Keep this string on top since we have to modify it each new release.
+OVZ_CODENAME="feoktistov"
+OVZ_CODENAME_SUBRELEASE=$(get_version_component_range 5)
+
+OVZ_KV="${OVZ_CODENAME}.${OVZ_CODENAME_SUBRELEASE}"
+
+ETYPE="sources"
+
+CKV=$(get_version_component_range 1-3)
+OKV=${OKV:-${CKV}}
+EXTRAVERSION=-${PN/-*}-${OVZ_KV}
+KV_FULL=${CKV}${EXTRAVERSION}
+if [[ ${PR} != r0 ]]; then
+ KV_FULL+=-${PR}
+ EXTRAVERSION+=-${PR}
+fi
+
+# ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH} should succeed.
+KV_MAJOR=$(get_version_component_range 1 ${OKV})
+KV_MINOR=$(get_version_component_range 2 ${OKV})
+KV_PATCH=$(get_version_component_range 3 ${OKV})
+
+KERNEL_URI="mirror://kernel/linux/kernel/v${KV_MAJOR}.${KV_MINOR}/linux-${OKV}.tar.bz2"
+
+inherit kernel-2
+detect_version
+
+SLOT=${CKV}-${OVZ_KV}
+if [[ ${PR} != r0 ]]; then
+ SLOT+=-${PR}
+fi
+
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DESCRIPTION="Kernel sources with OpenVZ patchset"
+HOMEPAGE="http://www.openvz.org"
+SRC_URI="${KERNEL_URI} ${ARCH_URI}
+ http://download.openvz.org/kernel/branches/${CKV}/${CKV}-${OVZ_KV}/patches/patch-${OVZ_KV}-combined.gz"
+
+UNIPATCH_STRICTORDER=1
+UNIPATCH_LIST="${DISTDIR}/patch-${OVZ_KV}-combined.gz
+${FILESDIR}/${PN}-2.6.32.10.1-cpt_process.c-build.patch
+"
+
+K_EXTRAEINFO="For more information about this kernel take a look at:
+http://wiki.openvz.org/Download/kernel/${CKV}/${CKV}-${OVZ_KV}"