summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2010-08-14 19:18:30 +0000
committerAnthony G. Basile <blueness@gentoo.org>2010-08-14 19:18:30 +0000
commit6ac77b9738cca65ad4c549102581a74fbab3a5a8 (patch)
tree9948af9e5ec1afbce386742da89b6a9c5bfec9b6 /sys-kernel/hardened-sources
parentalpha/ia64/sparc stable (diff)
downloadgentoo-2-6ac77b9738cca65ad4c549102581a74fbab3a5a8.tar.gz
gentoo-2-6ac77b9738cca65ad4c549102581a74fbab3a5a8.tar.bz2
gentoo-2-6ac77b9738cca65ad4c549102581a74fbab3a5a8.zip
Based on vanilla 2.6.32.18 + genpatches + grsecurity-2.2.0-2.6.32.18-201008112233
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/hardened-sources')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog9
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.32-r13.ebuild46
2 files changed, 54 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index ea9365889a09..5d708f3edf93 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.330 2010/08/03 17:19:29 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.331 2010/08/14 19:18:30 blueness Exp $
+
+*hardened-sources-2.6.32-r13 (14 Aug 2010)
+
+ 14 Aug 2010; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-2.6.32-r13.ebuild:
+ Based on vanilla 2.6.32.18 + genpatches +
+ grsecurity-2.2.0-2.6.32.18-201008112233
03 Aug 2010; Robin H. Johnson <robbat2@gentoo.org> Manifest:
kernel-2 deblob support for 2.6.35; bug #324505: deblob-check usage.
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.32-r13.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r13.ebuild
new file mode 100644
index 000000000000..94c39fa9c880
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r13.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.32-r13.ebuild,v 1.1 2010/08/14 19:18:30 blueness Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="16"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-16"
+HGPV_URI="mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="1018_linux-2.6.32.19.patch 4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.0*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides four different predefined grsecurity level:"
+ ewarn "[server], [server no rbac] [workstation] [workstation no rbac]"
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}