summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2012-12-23 05:44:22 +0000
committerRichard Yao <ryao@gentoo.org>2012-12-23 05:44:22 +0000
commitf0829eb32a189823da4591b5d7b6d83ff1c15b2c (patch)
treeb731f7d34d5d2b535463807ad1e8dcacb94bcfd6 /sys-fs
parentBump sys-kernel/spl to 0.6.0_rc13 (diff)
downloadgentoo-2-f0829eb32a189823da4591b5d7b6d83ff1c15b2c.tar.gz
gentoo-2-f0829eb32a189823da4591b5d7b6d83ff1c15b2c.tar.bz2
gentoo-2-f0829eb32a189823da4591b5d7b6d83ff1c15b2c.zip
Bump sys-fs/zfs-kmod to 0.6.0_rc13
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/zfs-kmod/ChangeLog7
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-0.6.0_rc13.ebuild94
2 files changed, 100 insertions, 1 deletions
diff --git a/sys-fs/zfs-kmod/ChangeLog b/sys-fs/zfs-kmod/ChangeLog
index 9bad6db03435..45e8acb6902e 100644
--- a/sys-fs/zfs-kmod/ChangeLog
+++ b/sys-fs/zfs-kmod/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/zfs-kmod
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/ChangeLog,v 1.10 2012/12/11 19:43:44 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/ChangeLog,v 1.11 2012/12/23 05:44:22 ryao Exp $
+
+*zfs-kmod-0.6.0_rc13 (23 Dec 2012)
+
+ 23 Dec 2012; Richard Yao <ryao@gentoo.org> +zfs-kmod-0.6.0_rc13.ebuild:
+ Bump sys-fs/zfs-kmod to 0.6.0_rc13
*zfs-kmod-0.6.0_rc12-r1 (11 Dec 2012)
diff --git a/sys-fs/zfs-kmod/zfs-kmod-0.6.0_rc13.ebuild b/sys-fs/zfs-kmod/zfs-kmod-0.6.0_rc13.ebuild
new file mode 100644
index 000000000000..f39156fcf50d
--- /dev/null
+++ b/sys-fs/zfs-kmod/zfs-kmod-0.6.0_rc13.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/zfs-kmod-0.6.0_rc13.ebuild,v 1.1 2012/12/23 05:44:22 ryao Exp $
+
+EAPI="4"
+
+AT_M4DIR="config"
+AUTOTOOLS_AUTORECONF="1"
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+
+inherit bash-completion-r1 flag-o-matic linux-mod toolchain-funcs autotools-utils
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/zfsonlinux/zfs.git"
+else
+ inherit eutils versionator
+ MY_PV=$(replace_version_separator 3 '-')
+ SRC_URI="https://github.com/zfsonlinux/zfs/archive/zfs-${MY_PV}.tar.gz"
+ S="${WORKDIR}/zfs-zfs-${MY_PV}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Linux ZFS kernel module for sys-fs/zfs"
+HOMEPAGE="http://zfsonlinux.org/"
+
+LICENSE="CDDL"
+SLOT="0"
+IUSE="custom-cflags debug +rootfs"
+RESTRICT="test"
+
+DEPEND="
+ =sys-kernel/spl-${PV}*
+"
+
+RDEPEND="${DEPEND}
+ !sys-fs/zfs-fuse
+"
+
+pkg_setup() {
+ CONFIG_CHECK="!DEBUG_LOCK_ALLOC
+ BLK_DEV_LOOP
+ EFI_PARTITION
+ IOSCHED_NOOP
+ MODULES
+ !PAX_KERNEXEC_PLUGIN_METHOD_OR
+ ZLIB_DEFLATE
+ ZLIB_INFLATE
+ "
+
+ use rootfs && \
+ CONFIG_CHECK="${CONFIG_CHECK} BLK_DEV_INITRD
+ DEVTMPFS"
+
+ kernel_is ge 2 6 26 || die "Linux 2.6.26 or newer required"
+
+ [ ${PV} != "9999" ] && \
+ { kernel_is le 3 7 || die "Linux 3.7 is the latest supported version."; }
+
+ check_extra_config
+}
+
+src_prepare() {
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ use custom-cflags || strip-flags
+ set_arch_to_kernel
+ local myeconfargs=(
+ --bindir="${EPREFIX}/bin"
+ --sbindir="${EPREFIX}/sbin"
+ --with-config=kernel
+ --with-linux="${KV_DIR}"
+ --with-linux-obj="${KV_OUT_DIR}"
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ if use x86 || use arm
+ then
+ ewarn "32-bit kernels will likely require increasing vmalloc to"
+ ewarn "at least 256M and decreasing zfs_arc_max to some value less than that."
+ fi
+
+}