summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-12-25 10:28:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-12-25 10:28:30 +0000
commite2a84b1a270897ec6c292afe4ba9df189999cbdb (patch)
treea793d0ab2ffe15a437fcda5ce426eda27e9af713 /sys-fs
parentAdd ruby20 to this slot as well for Rails 4. (diff)
downloadgentoo-2-e2a84b1a270897ec6c292afe4ba9df189999cbdb.tar.gz
gentoo-2-e2a84b1a270897ec6c292afe4ba9df189999cbdb.tar.bz2
gentoo-2-e2a84b1a270897ec6c292afe4ba9df189999cbdb.zip
Rename USE="crypt" to USE="ntfsdecrypt" which /most/ people don't need.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ntfs3g/ChangeLog6
-rw-r--r--sys-fs/ntfs3g/metadata.xml1
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2013.1.13.ebuild8
3 files changed, 10 insertions, 5 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index bd7f127f8be7..a08cdc084e60 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.148 2013/08/09 17:47:34 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.149 2013/12/25 10:28:30 ssuominen Exp $
+
+ 25 Dec 2013; Samuli Suominen <ssuominen@gentoo.org> metadata.xml,
+ ntfs3g-2013.1.13.ebuild:
+ Rename USE="crypt" to USE="ntfsdecrypt" which /most/ people don't need.
09 Aug 2013; Patrick McLean <chutzpah@gentoo.org> ntfs3g-2013.1.13.ebuild:
Add die in pkg_pretend when attempting to build with gold (bug #450024),
diff --git a/sys-fs/ntfs3g/metadata.xml b/sys-fs/ntfs3g/metadata.xml
index 12afe5484ff2..d9353d45cfb3 100644
--- a/sys-fs/ntfs3g/metadata.xml
+++ b/sys-fs/ntfs3g/metadata.xml
@@ -24,6 +24,7 @@ file ownership, access right.
<flag name='udev'>Install udev rule to make udisks use ntfs-3g instead
of the kernel NTFS driver.</flag>
<flag name='crypt'>Add support for encrypted NTFS drives/partitions.</flag>
+ <flag name='ntfsdecrypt'>Build and install the ntfsdecrypt application.</flag>
<flag name='ntfsprogs'>Include internal version of ntfsprogs. This will
block sys-fs/ntfsprogs.</flag>
</use>
diff --git a/sys-fs/ntfs3g/ntfs3g-2013.1.13.ebuild b/sys-fs/ntfs3g/ntfs3g-2013.1.13.ebuild
index 24ecb45efeae..c96749c95b3f 100644
--- a/sys-fs/ntfs3g/ntfs3g-2013.1.13.ebuild
+++ b/sys-fs/ntfs3g/ntfs3g-2013.1.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2013.1.13.ebuild,v 1.4 2013/08/09 17:47:34 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2013.1.13.ebuild,v 1.5 2013/12/25 10:28:30 ssuominen Exp $
EAPI=5
inherit eutils linux-info udev
@@ -15,11 +15,11 @@ SRC_URI="http://tuxera.com/opensource/${MY_P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="acl crypt debug +external-fuse +ntfsprogs static-libs suid xattr"
+IUSE="acl debug +external-fuse ntfsdecrypt +ntfsprogs static-libs suid xattr"
RDEPEND="!<sys-apps/util-linux-2.20.1-r2
!sys-fs/ntfsprogs
- crypt? (
+ ntfsdecrypt? (
>=dev-libs/libgcrypt-1.2.2
>=net-libs/gnutls-1.4.4
)
@@ -59,7 +59,7 @@ src_configure() {
--disable-ldconfig \
$(use_enable acl posix-acls) \
$(use_enable xattr xattr-mappings) \
- $(use_enable crypt crypto) \
+ $(use_enable ntfsdecrypt crypto) \
$(use_enable ntfsprogs) \
--without-uuid \
--enable-extras \