summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2013-08-07 20:18:37 +0000
committerIan Stakenvicius <axs@gentoo.org>2013-08-07 20:18:37 +0000
commite0a5792e7857a1b32b45454d745875adb9836fa3 (patch)
tree2e5ebd525b980ad1f0d183b1b0118ecd1c2399ef /sys-fs
parentBump eudev to satisfy the multilib version of the udev virtual (diff)
downloadgentoo-2-e0a5792e7857a1b32b45454d745875adb9836fa3.tar.gz
gentoo-2-e0a5792e7857a1b32b45454d745875adb9836fa3.tar.bz2
gentoo-2-e0a5792e7857a1b32b45454d745875adb9836fa3.zip
Initial multilib-minimal.eclass conversion (to build libudev.so.1)
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/eudev/ChangeLog5
-rw-r--r--sys-fs/eudev/eudev-9999.ebuild49
2 files changed, 38 insertions, 16 deletions
diff --git a/sys-fs/eudev/ChangeLog b/sys-fs/eudev/ChangeLog
index 2cda2978623a..4deef928a97f 100644
--- a/sys-fs/eudev/ChangeLog
+++ b/sys-fs/eudev/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/eudev
# Copyright 1999- Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/ChangeLog,v 1.56 2013/08/07 20:11:25 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/ChangeLog,v 1.57 2013/08/07 20:18:37 axs Exp $
+
+ 07 Aug 2013; Ian Stakenvicius <axs@gentoo.org> eudev-9999.ebuild:
+ Initial multilib-minimal.eclass conversion (to build libudev.so.1)
*eudev-1.2-r1 (07 Aug 2013)
diff --git a/sys-fs/eudev/eudev-9999.ebuild b/sys-fs/eudev/eudev-9999.ebuild
index ee88c2627c97..e1e0aa14e7f2 100644
--- a/sys-fs/eudev/eudev-9999.ebuild
+++ b/sys-fs/eudev/eudev-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-9999.ebuild,v 1.34 2013/07/25 15:31:49 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-9999.ebuild,v 1.35 2013/08/07 20:18:37 axs Exp $
EAPI="5"
KV_min=2.6.31
-inherit autotools eutils linux-info
+inherit autotools eutils multilib linux-info multilib-minimal
if [[ ${PV} = 9999* ]]
then
@@ -56,6 +56,7 @@ PDEPEND=">=virtual/udev-180
openrc? ( >=sys-fs/udev-init-scripts-18 )"
REQUIRED_USE="keymap? ( hwdb )"
+DOCS=""
pkg_pretend()
{
@@ -115,7 +116,7 @@ src_prepare()
fi
}
-src_configure()
+multilib_src_configure()
{
local econf_args
@@ -129,37 +130,55 @@ src_configure()
--libdir=/usr/$(get_libdir)
--with-firmware-path="${EPREFIX}usr/lib/firmware/updates:${EPREFIX}usr/lib/firmware:${EPREFIX}lib/firmware/updates:${EPREFIX}lib/firmware"
--with-html-dir="/usr/share/doc/${PF}/html"
- --with-rootlibdir=/$(get_libdir)
--enable-split-usr
--exec-prefix=/
$(use_enable doc gtk-doc)
- $(use_enable gudev)
- $(use_enable introspection)
$(use_enable keymap)
$(use_enable kmod libkmod)
$(use_enable modutils modules)
$(use_enable selinux)
- $(use_enable static-libs static)
$(use_enable rule-generator)
)
- econf "${econf_args[@]}"
+ # only install libs to /lib and build gudev for native abi
+ # also non-native-abi only need dynamic libs, so skip static
+ if multilib_is_native_abi; then econf_args+=(
+ --with-rootlibdir=/$(get_libdir)
+ $(use_enable gudev)
+ $(use_enable introspection)
+ $(use_enable static-libs static)
+ )
+ else econf_args+=(
+ --disable-gudev
+ --disable-introspection
+ --disable-static
+ )
+ fi
+ ECONF_SOURCE="${S}" econf "${econf_args[@]}"
}
-src_test() {
+multilib_src_test()
+{
# make sandbox get out of the way
# these are safe because there is a fake root filesystem put in place,
# but sandbox seems to evaluate the paths of the test i/o instead of the
# paths of the actual i/o that results.
- addread /sys
- addwrite /dev
- addwrite /run
- default_src_test
+ # also only test for native abi
+ if multilib_is_native_abi; then
+ addread /sys
+ addwrite /dev
+ addwrite /run
+ default_src_test
+ fi
}
-src_install()
+# disable header checks because we only install libudev headers for non-native abi
+multilib_check_headers()
{
- emake DESTDIR="${D}" install
+ :
+}
+multilib_src_install_all()
+{
prune_libtool_files --all
rm -rf "${ED}"/usr/share/doc/${PF}/LICENSE.*