summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-04-23 19:35:04 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-04-23 19:35:04 +0000
commita27f05a6675639ad8fc7ded5dce1adee2986ea08 (patch)
treec178bc23df5fd98597244c805ce061236128916c /sys-fs
parentVersion bump. (diff)
downloadgentoo-2-a27f05a6675639ad8fc7ded5dce1adee2986ea08.tar.gz
gentoo-2-a27f05a6675639ad8fc7ded5dce1adee2986ea08.tar.bz2
gentoo-2-a27f05a6675639ad8fc7ded5dce1adee2986ea08.zip
Bug #316571: Bring in libudev for devmapper.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cryptsetup/ChangeLog6
-rw-r--r--sys-fs/cryptsetup/cryptsetup-1.1.0.ebuild3
-rw-r--r--sys-fs/cryptsetup/files/1.1.0-libudev.patch26
3 files changed, 33 insertions, 2 deletions
diff --git a/sys-fs/cryptsetup/ChangeLog b/sys-fs/cryptsetup/ChangeLog
index ce05b3918d72..4d2ea18e26a8 100644
--- a/sys-fs/cryptsetup/ChangeLog
+++ b/sys-fs/cryptsetup/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/cryptsetup
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/ChangeLog,v 1.79 2010/02/14 00:10:59 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/ChangeLog,v 1.80 2010/04/23 19:35:04 robbat2 Exp $
+
+ 23 Apr 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +files/1.1.0-libudev.patch, cryptsetup-1.1.0.ebuild:
+ Bug #316571: Bring in libudev for devmapper.
*cryptsetup-1.1.0 (14 Feb 2010)
diff --git a/sys-fs/cryptsetup/cryptsetup-1.1.0.ebuild b/sys-fs/cryptsetup/cryptsetup-1.1.0.ebuild
index 04d0c52672b2..4744e5b10903 100644
--- a/sys-fs/cryptsetup/cryptsetup-1.1.0.ebuild
+++ b/sys-fs/cryptsetup/cryptsetup-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.1.0.ebuild,v 1.1 2010/02/14 00:10:59 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.1.0.ebuild,v 1.2 2010/04/23 19:35:04 robbat2 Exp $
EAPI=2
@@ -43,6 +43,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/1.1.0_rc3-static-no-selinux.patch
+ epatch "${FILESDIR}"/1.1.0-libudev.patch
eautoreconf
}
diff --git a/sys-fs/cryptsetup/files/1.1.0-libudev.patch b/sys-fs/cryptsetup/files/1.1.0-libudev.patch
new file mode 100644
index 000000000000..12d589e4eb06
--- /dev/null
+++ b/sys-fs/cryptsetup/files/1.1.0-libudev.patch
@@ -0,0 +1,26 @@
+diff -ur cryptsetup-1.1.0.orig/configure.in cryptsetup-1.1.0/configure.in
+--- cryptsetup-1.1.0.orig/configure.in 2010-04-23 21:39:29.000000000 +0300
++++ cryptsetup-1.1.0/configure.in 2010-04-23 21:38:18.000000000 +0300
+@@ -62,6 +62,11 @@
+
+ dnl ==========================================================================
+
++saved_LIBS=$LIBS
++AC_CHECK_LIB([udev], [udev_queue_get_udev_is_active])
++AC_SUBST(UDEV_LIBS, $LIBS)
++LIBS=$saved_LIBS
++
+ AC_ARG_ENABLE(shared-library,
+ [ --disable-shared-library
+ disable building of shared cryptsetup library],,
+diff -ur cryptsetup-1.1.0.orig/lib/Makefile.am cryptsetup-1.1.0/lib/Makefile.am
+--- cryptsetup-1.1.0.orig/lib/Makefile.am 2009-12-30 18:29:28.000000000 +0200
++++ cryptsetup-1.1.0/lib/Makefile.am 2010-04-23 21:41:34.000000000 +0300
+@@ -33,6 +33,7 @@
+ libcryptsetup_la_LIBADD = \
+ @UUID_LIBS@ \
+ @DEVMAPPER_LIBS@ \
++ @UDEV_LIBS@ \
+ @LIBGCRYPT_LIBS@ \
+ ../luks/libluks.la
+