summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2013-02-02 16:44:30 +0000
committerRichard Yao <ryao@gentoo.org>2013-02-02 16:44:30 +0000
commit82e0283a6b56e81e3cb8837cddf5431c928ca620 (patch)
tree62c05ead5c8900ae6163602a79266575ffe60cb5 /sys-fs
parentBump sys-kernel/spl to 0.6.0_rc14 (diff)
downloadgentoo-2-82e0283a6b56e81e3cb8837cddf5431c928ca620.tar.gz
gentoo-2-82e0283a6b56e81e3cb8837cddf5431c928ca620.tar.bz2
gentoo-2-82e0283a6b56e81e3cb8837cddf5431c928ca620.zip
Bump sys-fs/zfs-kmod to 0.6.0_rc14
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/zfs-kmod/ChangeLog7
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-0.6.0_rc14.ebuild102
2 files changed, 108 insertions, 1 deletions
diff --git a/sys-fs/zfs-kmod/ChangeLog b/sys-fs/zfs-kmod/ChangeLog
index ab901f38f39c..07fb9bd51e3a 100644
--- a/sys-fs/zfs-kmod/ChangeLog
+++ b/sys-fs/zfs-kmod/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/zfs-kmod
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/ChangeLog,v 1.15 2013/01/16 09:01:09 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/ChangeLog,v 1.16 2013/02/02 16:44:30 ryao Exp $
+
+*zfs-kmod-0.6.0_rc14 (02 Feb 2013)
+
+ 02 Feb 2013; Richard Yao <ryao@gentoo.org> +zfs-kmod-0.6.0_rc14.ebuild:
+ Bump sys-fs/zfs-kmod to 0.6.0_rc14
16 Jan 2013; Richard Yao <ryao@gentoo.org> zfs-kmod-9999.ebuild:
Filter -Wl,* from LDFLAGS to prevent build failures on ARM
diff --git a/sys-fs/zfs-kmod/zfs-kmod-0.6.0_rc14.ebuild b/sys-fs/zfs-kmod/zfs-kmod-0.6.0_rc14.ebuild
new file mode 100644
index 000000000000..2d67c88ea099
--- /dev/null
+++ b/sys-fs/zfs-kmod/zfs-kmod-0.6.0_rc14.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/zfs-kmod-0.6.0_rc14.ebuild,v 1.1 2013/02/02 16:44:30 ryao Exp $
+
+EAPI="4"
+
+AT_M4DIR="config"
+AUTOTOOLS_AUTORECONF="1"
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+
+inherit bash-completion-r1 flag-o-matic linux-mod toolchain-funcs autotools-utils
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/zfsonlinux/zfs.git"
+else
+ inherit eutils versionator
+ MY_PV=$(replace_version_separator 3 '-')
+ SRC_URI="https://github.com/zfsonlinux/zfs/archive/zfs-${MY_PV}.tar.gz"
+ S="${WORKDIR}/zfs-zfs-${MY_PV}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Linux ZFS kernel module for sys-fs/zfs"
+HOMEPAGE="http://zfsonlinux.org/"
+
+LICENSE="CDDL"
+SLOT="0"
+IUSE="custom-cflags debug +rootfs"
+RESTRICT="test"
+
+DEPEND="
+ =sys-kernel/spl-${PV}*
+"
+
+RDEPEND="${DEPEND}
+ !sys-fs/zfs-fuse
+"
+
+pkg_setup() {
+ CONFIG_CHECK="!DEBUG_LOCK_ALLOC
+ BLK_DEV_LOOP
+ EFI_PARTITION
+ IOSCHED_NOOP
+ MODULES
+ !PAX_KERNEXEC_PLUGIN_METHOD_OR
+ ZLIB_DEFLATE
+ ZLIB_INFLATE
+ "
+
+ use rootfs && \
+ CONFIG_CHECK="${CONFIG_CHECK} BLK_DEV_INITRD
+ DEVTMPFS"
+
+ kernel_is ge 2 6 26 || die "Linux 2.6.26 or newer required"
+
+ [ ${PV} != "9999" ] && \
+ { kernel_is le 3 8 || die "Linux 3.8 is the latest supported version."; }
+
+ check_extra_config
+}
+
+src_prepare() {
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ use custom-cflags || strip-flags
+ filter-ldflags -Wl,*
+
+ set_arch_to_kernel
+ local myeconfargs=(
+ --bindir="${EPREFIX}/bin"
+ --sbindir="${EPREFIX}/sbin"
+ --with-config=kernel
+ --with-linux="${KV_DIR}"
+ --with-linux-obj="${KV_OUT_DIR}"
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ if use x86 || use arm
+ then
+ ewarn "32-bit kernels will likely require increasing vmalloc to"
+ ewarn "at least 256M and decreasing zfs_arc_max to some value less than that."
+ fi
+
+ ewarn "This version of ZFSOnLinux introduces support for features flags."
+ ewarn "If you upgrade your pools to make use of feature flags, you will lose"
+ ewarn "the ability to import them using older versions of ZFSOnLinux."
+ ewarn "Any new pools will be created with feature flag support and will"
+ ewarn "not be compatible with older versions of ZFSOnLinux. To create a new"
+ ewarn "pool that is backward compatible, use zpool create -o version=22 ..."
+}