summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-08-07 11:31:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-08-07 11:31:59 +0000
commit6c767f8314f85c73cb5add0a4b99465e230e8bfe (patch)
tree045b6da5de8fea7e97a613f60fdfcd9651f2a197 /sys-fs
parentDrop removed Python implementations from PYTHON_COMPAT. (diff)
downloadgentoo-2-6c767f8314f85c73cb5add0a4b99465e230e8bfe.tar.gz
gentoo-2-6c767f8314f85c73cb5add0a4b99465e230e8bfe.tar.bz2
gentoo-2-6c767f8314f85c73cb5add0a4b99465e230e8bfe.zip
Include check for value of UEVENT_HELPER_PATH wrt #479756 by Alexander Tsoy. Remove useless warning about USE="-static" and sys-kernel/genkernel which now works with dynamic libraries since version 3.4.30.
(Portage version: 2.2.0_alpha191/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/lvm2/ChangeLog7
-rw-r--r--sys-fs/lvm2/lvm2-2.02.99-r1.ebuild25
2 files changed, 20 insertions, 12 deletions
diff --git a/sys-fs/lvm2/ChangeLog b/sys-fs/lvm2/ChangeLog
index 7c06882570c5..3826f8e3e109 100644
--- a/sys-fs/lvm2/ChangeLog
+++ b/sys-fs/lvm2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/lvm2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.312 2013/08/06 18:08:30 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.313 2013/08/07 11:31:59 ssuominen Exp $
+
+ 07 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> lvm2-2.02.99-r1.ebuild:
+ Include check for value of UEVENT_HELPER_PATH wrt #479756 by Alexander Tsoy.
+ Remove useless warning about USE="-static" and sys-kernel/genkernel which now
+ works with dynamic libraries since version 3.4.30.
06 Aug 2013; Ian Stakenvicius <axs@gentoo.org>
+files/lvm2-2.02.97-selinux-static.patch,
diff --git a/sys-fs/lvm2/lvm2-2.02.99-r1.ebuild b/sys-fs/lvm2/lvm2-2.02.99-r1.ebuild
index ae375454b55d..4dd6cd59b446 100644
--- a/sys-fs/lvm2/lvm2-2.02.99-r1.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.99-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.99-r1.ebuild,v 1.2 2013/08/06 18:08:30 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.99-r1.ebuild,v 1.3 2013/08/07 11:31:59 ssuominen Exp $
EAPI=5
inherit eutils multilib toolchain-funcs autotools linux-info udev systemd
@@ -42,12 +42,22 @@ DEPEND="${DEPEND_COMMON}
S=${WORKDIR}/${PN/lvm/LVM}.${PV}
-#QA_MULTILIB_PATHS="usr/lib/systemd/system-generators/.*" #479520
-
pkg_setup() {
local CONFIG_CHECK="~SYSVIPC"
- use udev && local WARNING_SYSVIPC="CONFIG_SYSVIPC:\tis not set (required for udev sync)\n"
+
+ if use udev; then
+ local WARNING_SYSVIPC="CONFIG_SYSVIPC:\tis not set (required for udev sync)\n"
+ if linux_config_exists; then
+ local uevent_helper_path=$(linux_chkconfig_string UEVENT_HELPER_PATH)
+ if [ -n "${uevent_helper_path}" ] && [ "${uevent_helper_path}" != '""' ]; then
+ ewarn "It's recommended to set an empty value to the following kernel config option:"
+ ewarn "CONFIG_UEVENT_HELPER_PATH=${uevent_helper_path}"
+ fi
+ fi
+ fi
+
check_extra_config
+
# 1. Genkernel no longer copies /sbin/lvm blindly.
if use static; then
elog "Warning, we no longer overwrite /sbin/lvm and /sbin/dmsetup with"
@@ -97,14 +107,10 @@ src_configure() {
# The build options are tristate, and --without is NOT supported
# options: 'none', 'internal', 'shared'
if use static ; then
- einfo "Building static LVM, for usage inside genkernel"
buildmode="internal"
# This only causes the .static versions to become available
- # We explicitly provide the .static versions so that they can be included in
- # initramfs environments.
myconf="${myconf} --enable-static_link"
else
- ewarn "Building shared LVM, it will not work inside genkernel!"
buildmode="shared"
fi
@@ -225,9 +231,6 @@ src_install() {
use static-libs || \
rm -f "${D}"/usr/$(get_libdir)/{libdevmapper-event,liblvm2cmd,liblvm2app,libdevmapper}.a
- #insinto /etc/udev/rules.d/
- #newins "${FILESDIR}"/64-device-mapper.rules-2.02.56-r3 64-device-mapper.rules
-
# do not rely on /lib -> /libXX link
sed -i \
-e "s|/lib/rcscripts/|/$(get_libdir)/rcscripts/|" \