summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-05-31 06:06:11 +0000
committerMike Frysinger <vapier@gentoo.org>2007-05-31 06:06:11 +0000
commit64e85174083967ec35608353bbdbabc98fcb4766 (patch)
tree108ab1e4ecfce498abb6dfd31f82a01b11b9e7e8 /sys-fs
parentVersion bump. (diff)
downloadgentoo-2-64e85174083967ec35608353bbdbabc98fcb4766.tar.gz
gentoo-2-64e85174083967ec35608353bbdbabc98fcb4766.tar.bz2
gentoo-2-64e85174083967ec35608353bbdbabc98fcb4766.zip
Version bump #180367.
(Portage version: 2.1.2.8)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/xfsdump/ChangeLog7
-rw-r--r--sys-fs/xfsdump/files/digest-xfsdump-2.2.453
-rw-r--r--sys-fs/xfsdump/xfsdump-2.2.45.ebuild50
3 files changed, 59 insertions, 1 deletions
diff --git a/sys-fs/xfsdump/ChangeLog b/sys-fs/xfsdump/ChangeLog
index 54a18422d93e..13c05397d2e4 100644
--- a/sys-fs/xfsdump/ChangeLog
+++ b/sys-fs/xfsdump/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/xfsdump
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.46 2007/01/07 18:56:55 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.47 2007/05/31 06:06:11 vapier Exp $
+
+*xfsdump-2.2.45 (31 May 2007)
+
+ 31 May 2007; Mike Frysinger <vapier@gentoo.org> +xfsdump-2.2.45.ebuild:
+ Version bump #180367.
07 Jan 2007; Tobias Scherbaum <dertobi123@gentoo.org>
xfsdump-2.2.42.ebuild:
diff --git a/sys-fs/xfsdump/files/digest-xfsdump-2.2.45 b/sys-fs/xfsdump/files/digest-xfsdump-2.2.45
new file mode 100644
index 000000000000..c6b58a8b1077
--- /dev/null
+++ b/sys-fs/xfsdump/files/digest-xfsdump-2.2.45
@@ -0,0 +1,3 @@
+MD5 9f4f6da94d14e638639a542b0fa8a722 xfsdump_2.2.45-1.tar.gz 581050
+RMD160 ef9081cc1a36ce42d8d6f923d9920a956e4511a7 xfsdump_2.2.45-1.tar.gz 581050
+SHA256 bc03ebad13268f554f037496d6965bff4ba761de73d338a4c21a9fd2ca2a3693 xfsdump_2.2.45-1.tar.gz 581050
diff --git a/sys-fs/xfsdump/xfsdump-2.2.45.ebuild b/sys-fs/xfsdump/xfsdump-2.2.45.ebuild
new file mode 100644
index 000000000000..09f7a134dc9b
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-2.2.45.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-2.2.45.ebuild,v 1.1 2007/05/31 06:06:11 vapier Exp $
+
+inherit eutils autotools
+
+MY_P="${PN}_${PV}-1"
+DESCRIPTION="xfs dump/restore utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86"
+IUSE=""
+
+DEPEND="sys-fs/e2fsprogs
+ sys-fs/xfsprogs
+ sys-apps/dmapi
+ >=sys-apps/attr-2.4.19"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.2.33-no-compress-docs.patch
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ -e '/^GCFLAGS/s:-O1::' \
+ include/builddefs.in \
+ || die
+ epatch "${FILESDIR}"/${PN}-2.2.42-Makefile-deps.patch
+ eautoconf
+}
+
+src_compile() {
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ --libdir=/$(get_libdir) \
+ --libexecdir=/usr/$(get_libdir) \
+ --sbindir=/sbin \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake DIST_ROOT="${D}" install || die
+ prepalldocs
+}