summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-06-11 12:19:57 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-06-11 12:19:57 +0000
commit3293fba08e8849f09455a9fc40680575653a654c (patch)
tree4b34293336943380efc7cb64111057284e4e7095 /sys-fs
parentBug #123728, fix python module linking brokenness. Also fix QA issue of missi... (diff)
downloadgentoo-2-3293fba08e8849f09455a9fc40680575653a654c.tar.gz
gentoo-2-3293fba08e8849f09455a9fc40680575653a654c.tar.bz2
gentoo-2-3293fba08e8849f09455a9fc40680575653a654c.zip
Bug #136373 - parallel compile fixes.
(Portage version: 2.1)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/xfsdump/ChangeLog8
-rw-r--r--sys-fs/xfsdump/files/digest-xfsdump-2.2.33-r13
-rw-r--r--sys-fs/xfsdump/files/xfsdump-2.2.33-Makefile-deps.patch27
-rw-r--r--sys-fs/xfsdump/xfsdump-2.2.33-r1.ebuild54
4 files changed, 91 insertions, 1 deletions
diff --git a/sys-fs/xfsdump/ChangeLog b/sys-fs/xfsdump/ChangeLog
index cbfe78a25598..847392080db0 100644
--- a/sys-fs/xfsdump/ChangeLog
+++ b/sys-fs/xfsdump/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/xfsdump
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.31 2006/06/07 17:31:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.32 2006/06/11 12:19:57 robbat2 Exp $
+
+*xfsdump-2.2.33-r1 (11 Jun 2006)
+
+ 11 Jun 2006; Robin H. Johnson <robbat2@gentoo.org>
+ +files/xfsdump-2.2.33-Makefile-deps.patch, +xfsdump-2.2.33-r1.ebuild:
+ Bug #136373 - parallel compile fixes.
07 Jun 2006; Mike Frysinger <vapier@gentoo.org>
+files/xfsdump-2.2.33-no-compress-docs.patch, xfsdump-2.2.33.ebuild:
diff --git a/sys-fs/xfsdump/files/digest-xfsdump-2.2.33-r1 b/sys-fs/xfsdump/files/digest-xfsdump-2.2.33-r1
new file mode 100644
index 000000000000..461b64880e81
--- /dev/null
+++ b/sys-fs/xfsdump/files/digest-xfsdump-2.2.33-r1
@@ -0,0 +1,3 @@
+MD5 d891a6f0215f4ad33840ddf60a295ec7 xfsdump-2.2.33.src.tar.gz 576941
+RMD160 d192bd114a07ea532ebc64d4474be4ce206ae51e xfsdump-2.2.33.src.tar.gz 576941
+SHA256 444ace415cacaf79b0329d53df9ed3949072adc8363b28ce1fa14892c7d5296d xfsdump-2.2.33.src.tar.gz 576941
diff --git a/sys-fs/xfsdump/files/xfsdump-2.2.33-Makefile-deps.patch b/sys-fs/xfsdump/files/xfsdump-2.2.33-Makefile-deps.patch
new file mode 100644
index 000000000000..ce5b2af53d02
--- /dev/null
+++ b/sys-fs/xfsdump/files/xfsdump-2.2.33-Makefile-deps.patch
@@ -0,0 +1,27 @@
+diff -Nuar --exclude '*~' xfsdump-2.2.33.orig/dump/Makefile xfsdump-2.2.33/dump/Makefile
+--- xfsdump-2.2.33.orig/dump/Makefile 2006-01-11 21:06:47.000000000 -0800
++++ xfsdump-2.2.33/dump/Makefile 2006-06-11 05:08:10.187705660 -0700
+@@ -106,3 +106,5 @@
+
+ $(INVINCL) $(INVCOMMON):
+ @$(RM) $@; $(LN_S) ../inventory/$@ $@
++
++$(LOCALS): $(LINKS)
+diff -Nuar --exclude '*~' xfsdump-2.2.33.orig/invutil/Makefile xfsdump-2.2.33/invutil/Makefile
+--- xfsdump-2.2.33.orig/invutil/Makefile 2006-01-11 21:06:48.000000000 -0800
++++ xfsdump-2.2.33/invutil/Makefile 2006-06-11 05:05:17.077263668 -0700
+@@ -70,3 +70,5 @@
+
+ $(INVINCL) $(INVCOMMON):
+ @$(RM) $@; $(LN_S) ../inventory/$@ $@
++
++$(LOCALS): $(LINKS)
+diff -Nuar --exclude '*~' xfsdump-2.2.33.orig/restore/Makefile xfsdump-2.2.33/restore/Makefile
+--- xfsdump-2.2.33.orig/restore/Makefile 2006-01-11 21:06:49.000000000 -0800
++++ xfsdump-2.2.33/restore/Makefile 2006-06-11 05:07:04.512296744 -0700
+@@ -116,3 +116,5 @@
+
+ $(INVINCL) $(INVCOMMON):
+ @$(RM) $@; $(LN_S) ../inventory/$@ $@
++
++$(LOCALS): $(LINKS)
diff --git a/sys-fs/xfsdump/xfsdump-2.2.33-r1.ebuild b/sys-fs/xfsdump/xfsdump-2.2.33-r1.ebuild
new file mode 100644
index 000000000000..282312ff21f4
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-2.2.33-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-2.2.33-r1.ebuild,v 1.1 2006/06/11 12:19:57 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="xfs dump/restore utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc -sparc ~x86"
+IUSE=""
+
+DEPEND="sys-fs/e2fsprogs
+ sys-fs/xfsprogs
+ sys-apps/dmapi
+ >=sys-apps/attr-2.4.19"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-no-compress-docs.patch
+ epatch "${FILESDIR}"/${P}-LDFLAGS.patch #126825
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
+ -e '/^GCFLAGS/s:-O1::' \
+ include/builddefs.in \
+ || die
+ epatch "${FILESDIR}"/${P}-Makefile-deps.patch
+ for i in restore dump invutil ; do
+ sed -i.orig \
+ -e 's|@$(RM) $@; $(LN_S)|$(RM) $@; $(LN_S)|g' \
+ ${S}/${i}/Makefile || die
+ done
+}
+
+src_compile() {
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+
+ econf \
+ --libdir=/$(get_libdir) \
+ --libexecdir=/usr/$(get_libdir) \
+ --sbindir=/sbin \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DIST_ROOT="${D}" install || die
+ prepalldocs
+}