summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-02 23:01:39 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-02 23:01:39 +0000
commit57e028e4c58d024f0fae4df2ad950d4d7a656e49 (patch)
treee6930a9976111c34f8ed9e06ce0d738a7273f71f /sys-fs/xfsdump
parentold (diff)
downloadgentoo-2-57e028e4c58d024f0fae4df2ad950d4d7a656e49.tar.gz
gentoo-2-57e028e4c58d024f0fae4df2ad950d4d7a656e49.tar.bz2
gentoo-2-57e028e4c58d024f0fae4df2ad950d4d7a656e49.zip
Version bump.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-fs/xfsdump')
-rw-r--r--sys-fs/xfsdump/ChangeLog9
-rw-r--r--sys-fs/xfsdump/files/digest-xfsdump-2.2.301
-rw-r--r--sys-fs/xfsdump/xfsdump-2.2.30.ebuild51
3 files changed, 59 insertions, 2 deletions
diff --git a/sys-fs/xfsdump/ChangeLog b/sys-fs/xfsdump/ChangeLog
index bb90a289e650..7408db1510ee 100644
--- a/sys-fs/xfsdump/ChangeLog
+++ b/sys-fs/xfsdump/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/xfsdump
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.20 2005/04/28 16:00:30 agriffis Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.21 2005/09/02 23:01:38 vapier Exp $
+
+*xfsdump-2.2.30 (02 Sep 2005)
+
+ 02 Sep 2005; Mike Frysinger <vapier@gentoo.org> +xfsdump-2.2.30.ebuild:
+ Version bump.
28 Apr 2005; Aron Griffis <agriffis@gentoo.org> -xfsdump-2.2.21.ebuild,
xfsdump-2.2.25.ebuild:
diff --git a/sys-fs/xfsdump/files/digest-xfsdump-2.2.30 b/sys-fs/xfsdump/files/digest-xfsdump-2.2.30
new file mode 100644
index 000000000000..dc54103f085a
--- /dev/null
+++ b/sys-fs/xfsdump/files/digest-xfsdump-2.2.30
@@ -0,0 +1 @@
+MD5 f9ae54ddebf9f158bef0b15049d26dfa xfsdump-2.2.30.src.tar.gz 589913
diff --git a/sys-fs/xfsdump/xfsdump-2.2.30.ebuild b/sys-fs/xfsdump/xfsdump-2.2.30.ebuild
new file mode 100644
index 000000000000..537b9d2f0ccf
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-2.2.30.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-2.2.30.ebuild,v 1.1 2005/09/02 23:01:38 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="xfs dump/restore utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc -sparc ~x86"
+IUSE="debug"
+
+DEPEND="sys-fs/e2fsprogs
+ sys-fs/xfsprogs
+ sys-apps/dmapi
+ >=sys-apps/attr-2.4.19"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:=.*:= /usr/share/doc/${PF}:" \
+ -e '/^GCFLAGS/s:-O1::' \
+ include/builddefs.in \
+ || die
+}
+
+src_compile() {
+ if use debug; then
+ export DEBUG=-DDEBUG
+ else
+ export DEBUG=-DNDEBUG
+ fi
+ export OPTIMIZER="${CFLAGS}"
+
+ econf \
+ --libdir=/$(get_libdir) \
+ --libexecdir=/usr/$(get_libdir) \
+ --sbindir=/sbin \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DIST_ROOT="${D}" install || die
+ dosym /sbin/xfsrestore /usr/bin/xfsrestore
+ dosym /sbin/xfsdump /usr/bin/xfsdump
+}