summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-23 09:40:00 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-23 09:40:00 +0000
commitb8fd65d7d053331ba9bc7a7c929ed247d3951871 (patch)
tree705536f134e72ae9cefb602c6e50ac6d5fba624e /sys-fs/vhba
parentRemove old. (diff)
downloadgentoo-2-b8fd65d7d053331ba9bc7a7c929ed247d3951871.tar.gz
gentoo-2-b8fd65d7d053331ba9bc7a7c929ed247d3951871.tar.bz2
gentoo-2-b8fd65d7d053331ba9bc7a7c929ed247d3951871.zip
Bump, port to EAPI4, install udev rules in /lib/udev, and update description. (bug #369063)
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/vhba')
-rw-r--r--sys-fs/vhba/ChangeLog9
-rw-r--r--sys-fs/vhba/vhba-1.2.1.ebuild4
-rw-r--r--sys-fs/vhba/vhba-20101015-r1.ebuild4
-rw-r--r--sys-fs/vhba/vhba-20110915.ebuild83
4 files changed, 95 insertions, 5 deletions
diff --git a/sys-fs/vhba/ChangeLog b/sys-fs/vhba/ChangeLog
index 6758f2f1cf21..38e0fd08d0ab 100644
--- a/sys-fs/vhba/ChangeLog
+++ b/sys-fs/vhba/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/vhba
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/ChangeLog,v 1.24 2011/11/22 20:39:51 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/ChangeLog,v 1.25 2011/11/23 09:40:00 tetromino Exp $
+
+*vhba-20110915 (23 Nov 2011)
+
+ 23 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org> vhba-1.2.1.ebuild,
+ vhba-20101015-r1.ebuild, +vhba-20110915.ebuild:
+ Bump, port to EAPI4, install udev rules in /lib/udev, and update description.
+ (bug #369063)
22 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org> metadata.xml:
Add myself as maintainer.
diff --git a/sys-fs/vhba/vhba-1.2.1.ebuild b/sys-fs/vhba/vhba-1.2.1.ebuild
index eaa90b7e1ecb..9d43fda24581 100644
--- a/sys-fs/vhba/vhba-1.2.1.ebuild
+++ b/sys-fs/vhba/vhba-1.2.1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/vhba-1.2.1.ebuild,v 1.8 2011/04/28 19:01:45 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/vhba-1.2.1.ebuild,v 1.9 2011/11/23 09:40:00 tetromino Exp $
EAPI="2"
inherit linux-mod eutils
-DESCRIPTION="VHBA module provides Virtual (SCSI) Host Bus Adapter for the cdemu suite"
+DESCRIPTION="Virtual (SCSI) Host Bus Adapter kernel module for the CDEmu suite"
HOMEPAGE="http://cdemu.org"
SRC_URI="mirror://sourceforge/cdemu/vhba-module-${PV}.tar.bz2"
diff --git a/sys-fs/vhba/vhba-20101015-r1.ebuild b/sys-fs/vhba/vhba-20101015-r1.ebuild
index 19c2ca58d79c..af40630cb3ff 100644
--- a/sys-fs/vhba/vhba-20101015-r1.ebuild
+++ b/sys-fs/vhba/vhba-20101015-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/vhba-20101015-r1.ebuild,v 1.2 2011/04/28 19:01:45 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/vhba-20101015-r1.ebuild,v 1.3 2011/11/23 09:40:00 tetromino Exp $
# Use svn snapshots:
# https://sourceforge.net/tracker/?func=detail&atid=603423&aid=3041832&group_id=93175
@@ -12,7 +12,7 @@ EAPI="2"
inherit linux-mod eutils
MY_P=vhba-module-${PV}
-DESCRIPTION="VHBA module provides Virtual (SCSI) Host Bus Adapter for the cdemu suite"
+DESCRIPTION="Virtual (SCSI) Host Bus Adapter kernel module for the CDEmu suite"
HOMEPAGE="http://cdemu.org"
SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
diff --git a/sys-fs/vhba/vhba-20110915.ebuild b/sys-fs/vhba/vhba-20110915.ebuild
new file mode 100644
index 000000000000..9c5c150949ac
--- /dev/null
+++ b/sys-fs/vhba/vhba-20110915.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/vhba-20110915.ebuild,v 1.1 2011/11/23 09:40:00 tetromino Exp $
+
+EAPI="4"
+
+inherit eutils linux-mod
+
+MY_P=vhba-module-${PV}
+DESCRIPTION="Virtual (SCSI) Host Bus Adapter kernel module for the CDEmu suite"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-fs/udev-125"
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+MODULE_NAMES="vhba(block:${S})"
+BUILD_TARGETS=all
+
+pkg_setup() {
+ CONFIG_CHECK="~BLK_DEV_SR ~CHR_DEV_SG"
+ check_extra_config
+ BUILD_PARAMS="KDIR=${KV_DIR}"
+ linux-mod_pkg_setup
+
+ enewgroup cdemu
+}
+
+src_prepare() {
+ # Avoid "make jobserver unavailable" warning
+ sed -e 's:\t$(KMAKE):\t+$(KMAKE):g' -i Makefile || die "sed failed"
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog README
+ linux-mod_src_install
+
+ einfo "Generating udev rules ..."
+ dodir /lib/udev/rules.d/
+ cat > "${D}"/lib/udev/rules.d/70-vhba.rules <<-EOF || die
+ # do not edit this file, it will be overwritten on update
+ #
+ KERNEL=="vhba_ctl", MODE="0660", OWNER="root", GROUP="cdemu"
+ EOF
+}
+
+pkg_postinst() {
+ elog "Don't forget to add your user to the cdemu group if you want to"
+ elog "be able to use virtual cdemu devices."
+
+ # Older versions of vhba installed their rule file in /etc/udev/rules.d,
+ # which overrides rules in /lib/udev/rules.d. We remove the old file
+ # automatically if it is identical to the default one installed by
+ # vhba-1.2.1 or 20101015-r1. Note that the comment at the top of the rules
+ # file states that it can be automatically overwritten by the system.
+ old_rules="${ROOT}etc/udev/rules.d/70-vhba.rules"
+ if [[ -f "${old_rules}" ]]; then
+ case "$(md5sum ${old_rules})" in
+ 2959b3cf61cfe6e466cc3516a7bc19de* | 1e7a7e5d6d28c811eeec98ec26ed5d28* )
+ elog
+ elog "Removing old ${old_rules} ..."
+ rm -f "${old_rules}" ||
+ eerror "Failed, please remove ${old_rules} manually."
+ ;;
+ * )
+ ewarn
+ ewarn "The ${old_rules} file from a previous"
+ ewarn "installation of ${PN} is overriding ${P}'s"
+ ewarn "udev rules. Unless you had deliberately customized it,"
+ ewarn "you should remove it."
+ ewarn
+ ;;
+ esac
+ fi
+
+ linux-mod_pkg_postinst
+}