summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Andreetta <satya@gentoo.org>2005-02-08 13:44:50 +0000
committerChristian Andreetta <satya@gentoo.org>2005-02-08 13:44:50 +0000
commit70383a93cf4091cea1b434ef8e0722c0cedf9af8 (patch)
tree16fe85025bd9746317cc6cd08da5af5834bb3670 /sys-fs/unionfs
parentStable on sparc (diff)
downloadgentoo-2-70383a93cf4091cea1b434ef8e0722c0cedf9af8.tar.gz
gentoo-2-70383a93cf4091cea1b434ef8e0722c0cedf9af8.tar.bz2
gentoo-2-70383a93cf4091cea1b434ef8e0722c0cedf9af8.zip
vserver patch: for 2.4 kernels only
(Portage version: 2.0.51.16)
Diffstat (limited to 'sys-fs/unionfs')
-rw-r--r--sys-fs/unionfs/ChangeLog8
-rw-r--r--sys-fs/unionfs/Manifest2
-rw-r--r--sys-fs/unionfs/files/digest-unionfs-1.0.8-r11
-rw-r--r--sys-fs/unionfs/unionfs-1.0.8-r1.ebuild43
4 files changed, 53 insertions, 1 deletions
diff --git a/sys-fs/unionfs/ChangeLog b/sys-fs/unionfs/ChangeLog
index 367d7bea4589..0a68681a2fd5 100644
--- a/sys-fs/unionfs/ChangeLog
+++ b/sys-fs/unionfs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/unionfs
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/ChangeLog,v 1.2 2005/02/05 14:06:08 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/ChangeLog,v 1.3 2005/02/08 13:44:50 satya Exp $
+
+*unionfs-1.0.8-r1 (08 Feb 2005)
+
+ 08 Feb 2005; Christian Andreetta <satya@gentoo.org>
+ +unionfs-1.0.8-r1.ebuild:
+ vserver patch: for 2.4 kernels only
*unionfs-1.0.8 (05 Feb 2005)
diff --git a/sys-fs/unionfs/Manifest b/sys-fs/unionfs/Manifest
index eba496729b8a..e16e86b55e0a 100644
--- a/sys-fs/unionfs/Manifest
+++ b/sys-fs/unionfs/Manifest
@@ -1,7 +1,9 @@
MD5 4970b965d7183e3424b52abea83f54ad unionfs-1.0.8.ebuild 1205
+MD5 7a55292662cc2bfb367bf65637004ca5 unionfs-1.0.8-r1.ebuild 1500
MD5 a214d6d08824769a02032e937a434e57 ChangeLog 569
MD5 8959da33bd490fabac57869170fb5cd2 unionfs-1.0.5.ebuild 778
MD5 6e89ba8198764bfd079a0cfa18dca593 metadata.xml 264
MD5 3e8352aeb89adf9621000e68a01d1c42 files/digest-unionfs-1.0.5 64
MD5 ed43e0aa2c797f7089d0b5233c2f4a28 files/digest-unionfs-1.0.8 65
MD5 ca0c70650ac2ad10a83bc3255de16baa files/unionfs-1.0.8-vserver.patch 520
+MD5 ed43e0aa2c797f7089d0b5233c2f4a28 files/digest-unionfs-1.0.8-r1 65
diff --git a/sys-fs/unionfs/files/digest-unionfs-1.0.8-r1 b/sys-fs/unionfs/files/digest-unionfs-1.0.8-r1
new file mode 100644
index 000000000000..1782641b3989
--- /dev/null
+++ b/sys-fs/unionfs/files/digest-unionfs-1.0.8-r1
@@ -0,0 +1 @@
+MD5 c0c8ad1f7e2f0776bfe1ed41662120f9 unionfs-1.0.8.tar.gz 105819
diff --git a/sys-fs/unionfs/unionfs-1.0.8-r1.ebuild b/sys-fs/unionfs/unionfs-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..260317e6998c
--- /dev/null
+++ b/sys-fs/unionfs/unionfs-1.0.8-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/unionfs-1.0.8-r1.ebuild,v 1.1 2005/02/08 13:44:50 satya Exp $
+
+inherit eutils linux-mod check-kernel
+
+DESCRIPTION="Stackable unification file system, which can appear to merge the contents of several directories"
+HOMEPAGE="http://www.fsl.cs.sunysb.edu/project-unionfs.html"
+SRC_URI="ftp://ftp.fsl.cs.sunysb.edu/pub/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="${IUSE} acl debug vserver"
+
+MODULE_NAMES="unionfs(fs:)"
+BUILD_TARGETS="all"
+BUILD_PARAMS="LINUXSRC=${KV_DIR} KERNELVERSION=${KV_MAJOR}.${KV_MINOR}"
+
+#============================================================================
+src_unpack() {
+ local user_Makefile=fistdev.mk
+ local EXTRACFLAGS=""
+ #------------------------------------------------------------------------
+ unpack ${A}
+ cd ${S}
+ if is_2_4_kernel && use vserver; then
+ epatch ${FILESDIR}/${P}-vserver.patch || die
+ fi
+ if ! use debug; then
+ echo "UNIONFS_DEBUG_CFLAG=" >> ${user_Makefile}
+ EXTRACFLAGS="${EXTRACFLAGS} -DNODEBUG"
+ fi
+ use acl && EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_XATTR -DFIST_SETXATTR_CONSTVOID"
+ echo "EXTRACFLAGS=${EXTRACFLAGS}" >> ${user_Makefile} || die
+}
+#============================================================================
+src_install() {
+ dosbin unionctl uniondbg
+ doman man/unionfs.4 man/unionctl.8 man/uniondbg.8
+
+ linux-mod_src_install
+
+ dodoc INSTALL NEWS README
+}