summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-09-08 01:02:10 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-09-08 01:02:10 +0000
commit0c4ecd6a54ccd5f12bcacd3e317ac9bd0e1b619b (patch)
tree91320870e1ee0a6321f5ebd13a68ba5eeb92849e /sys-fs/mtd-utils
parent100 release (diff)
downloadgentoo-2-0c4ecd6a54ccd5f12bcacd3e317ac9bd0e1b619b.tar.gz
gentoo-2-0c4ecd6a54ccd5f12bcacd3e317ac9bd0e1b619b.tar.bz2
gentoo-2-0c4ecd6a54ccd5f12bcacd3e317ac9bd0e1b619b.zip
Fix bug #146362 and version bump.
(Portage version: 2.1.1_rc1-r4)
Diffstat (limited to 'sys-fs/mtd-utils')
-rw-r--r--sys-fs/mtd-utils/ChangeLog8
-rw-r--r--sys-fs/mtd-utils/files/digest-mtd-utils-200609073
-rw-r--r--sys-fs/mtd-utils/mtd-utils-20060606.ebuild5
-rw-r--r--sys-fs/mtd-utils/mtd-utils-20060907.ebuild38
4 files changed, 51 insertions, 3 deletions
diff --git a/sys-fs/mtd-utils/ChangeLog b/sys-fs/mtd-utils/ChangeLog
index c5ccaabbe8d5..43182bfe8ddd 100644
--- a/sys-fs/mtd-utils/ChangeLog
+++ b/sys-fs/mtd-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/mtd-utils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/ChangeLog,v 1.2 2006/06/08 03:41:36 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/ChangeLog,v 1.3 2006/09/08 01:02:10 robbat2 Exp $
+
+*mtd-utils-20060907 (08 Sep 2006)
+
+ 08 Sep 2006; Robin H. Johnson <robbat2@gentoo.org>
+ mtd-utils-20060606.ebuild, +mtd-utils-20060907.ebuild:
+ Fix bug #146362 and version bump.
08 Jun 2006; Robin H. Johnson <robbat2@gentoo.org>
mtd-utils-20060606.ebuild:
diff --git a/sys-fs/mtd-utils/files/digest-mtd-utils-20060907 b/sys-fs/mtd-utils/files/digest-mtd-utils-20060907
new file mode 100644
index 000000000000..297a03f819d8
--- /dev/null
+++ b/sys-fs/mtd-utils/files/digest-mtd-utils-20060907
@@ -0,0 +1,3 @@
+MD5 530dcd8e5377a021a1a57e8ed07bd27d mtd-utils-snapshot-20060907.tar.bz2 103302
+RMD160 0dadf7111b502ca508f81832ae56e8d2ea1b94f0 mtd-utils-snapshot-20060907.tar.bz2 103302
+SHA256 c2e0978318fc6c7da34f1368c97e06be04abbc40e3d9a893b33b281d8f113a6a mtd-utils-snapshot-20060907.tar.bz2 103302
diff --git a/sys-fs/mtd-utils/mtd-utils-20060606.ebuild b/sys-fs/mtd-utils/mtd-utils-20060606.ebuild
index 123ce542312a..8aa7fe77d47d 100644
--- a/sys-fs/mtd-utils/mtd-utils-20060606.ebuild
+++ b/sys-fs/mtd-utils/mtd-utils-20060606.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/mtd-utils-20060606.ebuild,v 1.3 2006/07/11 21:24:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/mtd-utils-20060606.ebuild,v 1.4 2006/09/08 01:02:10 robbat2 Exp $
inherit toolchain-funcs flag-o-matic
@@ -16,7 +16,8 @@ IUSE=""
S=${WORKDIR}/${PN}
DEPEND="sys-libs/zlib
- !sys-fs/mtd"
+ sys-apps/acl
+ !sys-fs/mtd"
src_unpack() {
unpack ${A}
diff --git a/sys-fs/mtd-utils/mtd-utils-20060907.ebuild b/sys-fs/mtd-utils/mtd-utils-20060907.ebuild
new file mode 100644
index 000000000000..09cda0840a5e
--- /dev/null
+++ b/sys-fs/mtd-utils/mtd-utils-20060907.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/mtd-utils-20060907.ebuild,v 1.1 2006/09/08 01:02:10 robbat2 Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="MTD userspace tools, based on GIT snapshot from upstream"
+HOMEPAGE="http://sources.redhat.com/jffs2/"
+SRC_URI="mirror://gentoo/${PN}-snapshot-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+DEPEND="sys-libs/zlib
+ sys-apps/acl
+ !sys-fs/mtd"
+
+src_unpack() {
+ unpack ${A}
+ sed -i.orig \
+ -e 's!^MANDIR.*!MANDIR = /usr/share/man!g' \
+ -e 's!-include.*!!g' \
+ "${S}"/Makefile
+}
+
+src_compile() {
+ append-flags -I./include -Wall
+ emake DESTDIR="${D}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc *.txt
+}