summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-07-05 22:02:51 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-07-05 22:02:51 +0000
commit88c1616684dbe2dd79818497bef8c136a820479e (patch)
tree9ad84ea29c60bba85370f8c2482040d5f0a28e9c /sys-fs/lvm2/files
parentSparc stable, bug #276640. (diff)
downloadgentoo-2-88c1616684dbe2dd79818497bef8c136a820479e.tar.gz
gentoo-2-88c1616684dbe2dd79818497bef8c136a820479e.tar.bz2
gentoo-2-88c1616684dbe2dd79818497bef8c136a820479e.zip
Version bump. Patch for bug #217644: as-needed fixes.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/lvm2/files')
-rw-r--r--sys-fs/lvm2/files/lvm2-2.02.48-as-needed.patch187
-rw-r--r--sys-fs/lvm2/files/lvm2-2.02.48-device-mapper-export-format.patch306
2 files changed, 493 insertions, 0 deletions
diff --git a/sys-fs/lvm2/files/lvm2-2.02.48-as-needed.patch b/sys-fs/lvm2/files/lvm2-2.02.48-as-needed.patch
new file mode 100644
index 000000000000..eb65548f97e3
--- /dev/null
+++ b/sys-fs/lvm2/files/lvm2-2.02.48-as-needed.patch
@@ -0,0 +1,187 @@
+Compile-fix with --as-needed.
+
+To ensure correct output when --as-needed are in the linker flags, the order of
+flags to the linker (directly or via the compiler) must explictly only include
+libraries and objects AFTER all compiler flags, linker flags and linker
+directory arguments.
+
+X-Gentoo-Bug: #217644
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+Signed-off-by: Christian Ruppert (idl0r) <idl0r@gentoo.org>
+
+diff -Nuarp --exclude '*.rej' --exclude '*.orig' LVM2.2.02.48.orig/daemons/clogd/Makefile LVM2.2.02.48/daemons/clogd/Makefile
+--- LVM2.2.02.48.orig/daemons/clogd/Makefile 2009-01-08 09:12:33.000000000 -0800
++++ LVM2.2.02.48/daemons/clogd/Makefile 2009-07-05 14:33:03.799446085 -0700
+@@ -45,12 +45,12 @@ LDFLAGS += $(shell if [ -e /usr/lib64/op
+ else \
+ echo '-L/usr/lib/openais -L/usr/lib'; \
+ fi)
+-LDFLAGS += -lcpg -lSaCkpt -lext2fs
++LIBS += -lcpg -lSaCkpt -lext2fs
+
+ all: ${TARGET}
+
+ clogd: ${SOURCES}
+- ${CC} ${CFLAGS} -o $@ $^ ${LDFLAGS}
++ ${CC} ${CFLAGS} ${LDFLAGS} -o $@ $^
+
+ no_clogd_kernel_headers:
+ echo "Unable to find clogd kernel headers"
+diff -Nuarp --exclude '*.rej' --exclude '*.orig' LVM2.2.02.48.orig/daemons/clvmd/Makefile.in LVM2.2.02.48/daemons/clvmd/Makefile.in
+--- LVM2.2.02.48.orig/daemons/clvmd/Makefile.in 2009-03-10 05:10:12.000000000 -0700
++++ LVM2.2.02.48/daemons/clvmd/Makefile.in 2009-07-05 14:41:22.633723993 -0700
+@@ -101,7 +101,7 @@ INSTALL_TARGETS = \
+ install_clvmd
+
+ clvmd: $(OBJECTS) $(top_srcdir)/lib/liblvm-internal.a
+- $(CC) -o clvmd $(OBJECTS) $(CFLAGS) $(LDFLAGS) \
++ $(CC) $(CFLAGS) $(LDFLAGS) -o clvmd $(OBJECTS) \
+ $(LVMLIBS) $(LMLIBS) $(LIBS)
+
+ .PHONY: install_clvmd
+diff -Nuarp --exclude '*.rej' --exclude '*.orig' LVM2.2.02.48.orig/daemons/dmeventd/Makefile.in LVM2.2.02.48/daemons/dmeventd/Makefile.in
+--- LVM2.2.02.48.orig/daemons/dmeventd/Makefile.in 2009-07-05 14:32:41.000000000 -0700
++++ LVM2.2.02.48/daemons/dmeventd/Makefile.in 2009-07-05 14:40:43.094941107 -0700
+@@ -41,12 +41,12 @@ include $(top_srcdir)/make.tmpl
+ all: dmeventd
+ device-mapper: dmeventd $(LIB_STATIC)
+
+-LDFLAGS += -ldl -ldevmapper -lpthread
+-CLDFLAGS += -ldl -ldevmapper -lpthread
++LIBS += -ldl -ldevmapper -lpthread
+
+ dmeventd: $(LIB_SHARED) $(LIB_STATIC) $(VERSIONED_SHLIB) dmeventd.o
+- $(CC) -o $@ dmeventd.o $(CFLAGS) $(LDFLAGS) \
+- -L. -ldevmapper-event $(LIBS) -rdynamic
++ $(CC) $(CFLAGS) $(LDFLAGS) -L. \
++ -o $@ dmeventd.o \
++ -ldevmapper-event $(LIBS) -rdynamic
+
+ .PHONY: install_dynamic install_static install_include \
+ install_pkgconfig install_dmeventd
+diff -Nuarp --exclude '*.rej' --exclude '*.orig' LVM2.2.02.48.orig/daemons/dmeventd/plugins/mirror/Makefile.in LVM2.2.02.48/daemons/dmeventd/plugins/mirror/Makefile.in
+--- LVM2.2.02.48.orig/daemons/dmeventd/plugins/mirror/Makefile.in 2009-05-11 03:28:46.000000000 -0700
++++ LVM2.2.02.48/daemons/dmeventd/plugins/mirror/Makefile.in 2009-07-05 14:33:03.801620744 -0700
+@@ -17,7 +17,8 @@ top_srcdir = @top_srcdir@
+ VPATH = @srcdir@
+
+ INCLUDES += -I${top_srcdir}/tools
+-CLDFLAGS += -L${top_srcdir}/tools -ldevmapper @LVM2CMD_LIB@
++CLDFLAGS += -L${top_srcdir}/tools
++LIBS += -ldevmapper -lpthread @LVM2CMD_LIB@
+
+ SOURCES = dmeventd_mirror.c
+
+diff -Nuarp --exclude '*.rej' --exclude '*.orig' LVM2.2.02.48.orig/daemons/dmeventd/plugins/snapshot/Makefile.in LVM2.2.02.48/daemons/dmeventd/plugins/snapshot/Makefile.in
+--- LVM2.2.02.48.orig/daemons/dmeventd/plugins/snapshot/Makefile.in 2009-05-11 03:28:46.000000000 -0700
++++ LVM2.2.02.48/daemons/dmeventd/plugins/snapshot/Makefile.in 2009-07-05 14:33:03.801620744 -0700
+@@ -17,7 +17,8 @@ top_srcdir = @top_srcdir@
+ VPATH = @srcdir@
+
+ INCLUDES += -I${top_srcdir}/tools
+-CLDFLAGS += -L${top_srcdir}/tools -ldevmapper @LVM2CMD_LIB@
++CLDFLAGS += -L${top_srcdir}/tools
++LIBS += -lpthread -ldevmapper @LVM2CMD_LIB@
+
+ SOURCES = dmeventd_snapshot.c
+
+diff -Nuarp --exclude '*.rej' --exclude '*.orig' LVM2.2.02.48.orig/lib/Makefile.in LVM2.2.02.48/lib/Makefile.in
+--- LVM2.2.02.48.orig/lib/Makefile.in 2009-06-03 04:31:06.000000000 -0700
++++ LVM2.2.02.48/lib/Makefile.in 2009-07-05 14:33:03.801620744 -0700
+@@ -137,7 +137,7 @@ ifeq ("@HAVE_LIBDL@", "yes")
+ endif
+
+ ifeq ("@DMEVENTD@", "yes")
+- CLDFLAGS += -ldevmapper-event
++ LIBS += -ldevmapper-event
+ endif
+
+ LIB_NAME = liblvm-internal
+diff -Nuarp --exclude '*.rej' --exclude '*.orig' LVM2.2.02.48.orig/make.tmpl.in LVM2.2.02.48/make.tmpl.in
+--- LVM2.2.02.48.orig/make.tmpl.in 2009-05-11 03:28:45.000000000 -0700
++++ LVM2.2.02.48/make.tmpl.in 2009-07-05 14:33:03.801620744 -0700
+@@ -28,7 +28,7 @@ GENHTML = @GENHTML@
+ LN_S = @LN_S@
+ SED = @SED@
+
+-LIBS = @LIBS@
++LIBS += @LIBS@ $(LVMLIBS) $(LMLIBS)
+ DEFS += @DEFS@
+ CFLAGS += @CFLAGS@
+ CLDFLAGS += @CLDFLAGS@
+@@ -203,19 +203,19 @@ $(TARGETS): $(OBJECTS)
+ ifeq ("@LIB_SUFFIX@","so")
+ $(LIB_SHARED): $(OBJECTS) $(LDDEPS)
+ $(CC) -shared -Wl,-soname,$(notdir $@).$(LIB_VERSION) \
+- $(CFLAGS) $(CLDFLAGS) $(OBJECTS) $(LIBS) -o $@
++ $(CFLAGS) $(CLDFLAGS) $(LDFLAGS) $(OBJECTS) $(LIBS) -o $@
+ endif
+
+ ifeq ("@LIB_SUFFIX@","dylib")
+ $(LIB_SHARED): $(OBJECTS) $(LDDEPS)
+ $(CC) -dynamiclib -dylib_current_version,$(LIB_VERSION) \
+- $(CFLAGS) $(CLDFLAGS) $(OBJECTS) $(LIBS) -o $@
++ $(CFLAGS) $(CLDFLAGS) $(LDFLAGS) $(OBJECTS) $(LIBS) -o $@
+ endif
+
+ %.so: %.a
+ $(CC) -shared -Wl,-soname,$(notdir $@).$(LIB_VERSION) \
+- $(CFLAGS) $(CLDFLAGS) $(LIBS) -o $@ \
+- @CLDWHOLEARCHIVE@ $< @CLDNOWHOLEARCHIVE@
++ $(CFLAGS) $(CLDFLAGS) $(LDFLAGS) -o $@ \
++ @CLDWHOLEARCHIVE@ $< @CLDNOWHOLEARCHIVE@ $(LIBS)
+
+ $(LIB_STATIC): $(OBJECTS)
+ $(RM) $@
+diff -Nuarp --exclude '*.rej' --exclude '*.orig' LVM2.2.02.48.orig/test/api/Makefile.in LVM2.2.02.48/test/api/Makefile.in
+--- LVM2.2.02.48.orig/test/api/Makefile.in 2009-05-22 07:45:00.000000000 -0700
++++ LVM2.2.02.48/test/api/Makefile.in 2009-07-05 14:39:19.353146953 -0700
+@@ -36,5 +36,5 @@ LDFLAGS = -L$(top_srcdir)/libdm -L$(top_
+ CLDFLAGS = -L$(top_srcdir)/libdm -L$(top_srcdir)/liblvm
+
+ test: $(OBJECTS) $(top_srcdir)/liblvm/liblvm2app.so $(top_srcdir)/libdm/libdevmapper.so
+- $(CC) -o test $(OBJECTS) $(CFLAGS) $(LDFLAGS) $(LVMLIBS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o test $(OBJECTS) $(LVMLIBS) $(LIBS)
+
+diff -Nuarp --exclude '*.rej' --exclude '*.orig' LVM2.2.02.48.orig/tools/Makefile.in LVM2.2.02.48/tools/Makefile.in
+--- LVM2.2.02.48.orig/tools/Makefile.in 2009-05-21 04:11:29.000000000 -0700
++++ LVM2.2.02.48/tools/Makefile.in 2009-07-05 14:38:36.536891908 -0700
+@@ -106,24 +106,30 @@ include $(top_srcdir)/make.tmpl
+ device-mapper: $(TARGETS_DM)
+
+ dmsetup: dmsetup.o $(top_srcdir)/libdm/libdevmapper.$(LIB_SUFFIX)
+- $(CC) -o $@ dmsetup.o $(CFLAGS) $(LDFLAGS) \
+- -L$(top_srcdir)/libdm -ldevmapper $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) \
++ -L$(top_srcdir)/libdm \
++ -o $@ dmsetup.o \
++ -ldevmapper $(LIBS)
+
+ dmsetup.static: dmsetup.o $(interfacedir)/libdevmapper.a
+- $(CC) -o $@ dmsetup.o $(CFLAGS) $(LDFLAGS) -static \
+- -L$(interfacedir) -ldevmapper $(LIBS) \
++ $(CC) $(CFLAGS) $(LDFLAGS) -static \
++ -L$(interfacedir) \
++ -o $@ dmsetup.o \
++ -ldevmapper $(LIBS) \
+ $(LIB_PTHREAD)
+
+ all: device-mapper
+
+ lvm: $(OBJECTS) lvm.o $(top_srcdir)/lib/liblvm-internal.a
+- $(CC) -o $@ $(CFLAGS) $(OBJECTS) lvm.o \
+- $(LDFLAGS) $(LVMLIBS) $(LIBS) -rdynamic
++ $(CC) $(CFLAGS) $(LDFLAGS) \
++ -o $@ $(OBJECTS) lvm.o \
++ $(LVMLIBS) $(LIBS) -rdynamic
+
+ LIB_PTHREAD = @LIB_PTHREAD@
+ lvm.static: $(OBJECTS) lvm-static.o $(top_srcdir)/lib/liblvm-internal.a $(interfacedir)/libdevmapper.a
+- $(CC) -o $@ $(CFLAGS) $(OBJECTS) lvm-static.o -static \
+- -L$(interfacedir) $(LDFLAGS) $(LVMLIBS) $(LIBS) $(LIB_PTHREAD) -rdynamic
++ $(CC) $(CFLAGS) $(LDFLAGS) -static -L$(interfacedir) \
++ -o $@ $(OBJECTS) lvm-static.o \
++ $(LVMLIBS) $(LIBS) $(LIB_PTHREAD) -rdynamic
+
+ liblvm2cmd.a: $(top_srcdir)/lib/liblvm-internal.a $(OBJECTS) lvmcmdlib.o lvm2cmd.o
+ cat $(top_srcdir)/lib/liblvm-internal.a > $@
diff --git a/sys-fs/lvm2/files/lvm2-2.02.48-device-mapper-export-format.patch b/sys-fs/lvm2/files/lvm2-2.02.48-device-mapper-export-format.patch
new file mode 100644
index 000000000000..6e73d414802a
--- /dev/null
+++ b/sys-fs/lvm2/files/lvm2-2.02.48-device-mapper-export-format.patch
@@ -0,0 +1,306 @@
+Add support for exporting the device-mapper table to userspace.
+
+Original patch written by Matthias Schwarzott <zzam@gentoo.org>, in response to
+Gentoo bug #189404.
+
+This makes it possible to have udev rules based on the properties of the
+device-mapper node, such as target types, suspended status etc.
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+diff -Nuar --exclude '*.rej' --exclude '*.orig' LVM2.2.02.48.orig/libdm/libdevmapper.h LVM2.2.02.48/libdm/libdevmapper.h
+--- LVM2.2.02.48.orig/libdm/libdevmapper.h 2009-06-17 13:55:24.000000000 -0700
++++ LVM2.2.02.48/libdm/libdevmapper.h 2009-07-05 14:16:14.331690820 -0700
+@@ -953,6 +953,7 @@
+ #define DM_REPORT_OUTPUT_FIELD_NAME_PREFIX 0x00000008
+ #define DM_REPORT_OUTPUT_FIELD_UNQUOTED 0x00000010
+ #define DM_REPORT_OUTPUT_COLUMNS_AS_ROWS 0x00000020
++#define DM_REPORT_OUTPUT_EXPORT 0x00000040
+
+ struct dm_report *dm_report_init(uint32_t *report_types,
+ const struct dm_report_object_type *types,
+diff -Nuar --exclude '*.rej' --exclude '*.orig' LVM2.2.02.48.orig/libdm/libdm-report.c LVM2.2.02.48/libdm/libdm-report.c
+--- LVM2.2.02.48.orig/libdm/libdm-report.c 2009-02-09 01:45:49.000000000 -0800
++++ LVM2.2.02.48/libdm/libdm-report.c 2009-07-05 14:16:14.331690820 -0700
+@@ -891,6 +891,8 @@
+ uint32_t align;
+ const char *repstr;
+ char buf[4096];
++ const char *fname;
++ char tmp_char;
+
+ if (rh->flags & DM_REPORT_OUTPUT_FIELD_NAME_PREFIX) {
+ if (!(field_id = strdup(rh->fields[field->props->field_num].id))) {
+@@ -921,6 +923,25 @@
+ return 0;
+ }
+ }
++ if (rh->flags & DM_REPORT_OUTPUT_EXPORT) {
++ fname = rh->fields[field->props->field_num].id;
++ if (!dm_pool_grow_object(rh->mem, "DM_", strlen("DM_"))) {
++ log_error("dm_report: Unable to extend output line");
++ return 0;
++ }
++ while (fname && fname[0]) {
++ tmp_char = toupper(fname[0]);
++ if (!dm_pool_grow_object(rh->mem, &tmp_char, 1)) {
++ log_error("dm_report: Unable to extend output line");
++ return 0;
++ }
++ fname++;
++ }
++ if (!dm_pool_grow_object(rh->mem, "=", strlen("="))) {
++ log_error("dm_report: Unable to extend output line");
++ return 0;
++ }
++ }
+
+ repstr = field->report_string;
+ width = field->props->width;
+diff -Nuar --exclude '*.rej' --exclude '*.orig' LVM2.2.02.48.orig/tools/dmsetup.c LVM2.2.02.48/tools/dmsetup.c
+--- LVM2.2.02.48.orig/tools/dmsetup.c 2009-06-03 13:44:49.000000000 -0700
++++ LVM2.2.02.48/tools/dmsetup.c 2009-07-05 14:22:41.972149507 -0700
+@@ -107,6 +107,7 @@
+ enum {
+ READ_ONLY = 0,
+ COLS_ARG,
++ EXPORT_ARG,
+ EXEC_ARG,
+ FORCE_ARG,
+ GID_ARG,
+@@ -142,7 +143,8 @@
+ DR_INFO = 2,
+ DR_DEPS = 4,
+ DR_TREE = 8, /* Complete dependency tree required */
+- DR_NAME = 16
++ DR_NAME = 16,
++ DR_TABLE = 0x20, /* table is required, not just info */
+ } report_type_t;
+
+ static int _switches[NUM_SWITCHES];
+@@ -1217,8 +1219,13 @@
+ name = argv[1];
+ }
+
+- if (!(dmt = dm_task_create(DM_DEVICE_INFO)))
+- return 0;
++ if (_report_type & DR_TABLE ) {
++ if (!(dmt = dm_task_create(DM_DEVICE_TABLE)))
++ return 0;
++ } else {
++ if (!(dmt = dm_task_create(DM_DEVICE_INFO)))
++ return 0;
++ }
+
+ if (!_set_task_device(dmt, name, 0))
+ goto out;
+@@ -1682,6 +1689,16 @@
+ return dm_report_field_uint32(rh, field, &value);
+ }
+
++static int _int_disp(struct dm_report *rh,
++ struct dm_pool *mem __attribute((unused)),
++ struct dm_report_field *field, const void *data,
++ void *private __attribute((unused)))
++{
++ const int value = *(const int *)data;
++
++ return dm_report_field_int(rh, field, &value);
++}
++
+ static int _dm_name_disp(struct dm_report *rh,
+ struct dm_pool *mem __attribute((unused)),
+ struct dm_report_field *field, const void *data,
+@@ -1793,6 +1810,66 @@
+ }
+
+
++static int _dm_info_cleartext_status_disp(struct dm_report *rh,
++ struct dm_pool *mem __attribute((unused)),
++ struct dm_report_field *field, const void *data,
++ void *private __attribute((unused)))
++{
++ const char *buf = "NOTPRESENT";
++ const struct dm_info *info = data;
++
++ if (info->exists) {
++ if (info->suspended)
++ buf = "SUSPENDED";
++ else
++ buf = info->read_only ? " READONLY" : "ACTIVE";
++ }
++
++ return dm_report_field_string(rh, field, &buf);
++}
++
++static int _dm_info_target_types_disp(struct dm_report *rh,
++ struct dm_pool *mem __attribute((unused)),
++ struct dm_report_field *field, const void *data,
++ void *private __attribute((unused)))
++{
++ char buf[1024];
++ char *dest = buf;
++ int remains = sizeof(buf);
++ int written;
++ const char *s = buf;
++ struct dm_task *dmt = (struct dm_task *) data;
++ void *next = NULL;
++ uint64_t start, length;
++ char *target_type = NULL;
++ char *params;
++
++
++ buf[0] = '\0';
++
++ next = dm_get_next_target(dmt, next, &start, &length,
++ &target_type, &params);
++ if (target_type) {
++ written = snprintf(dest, remains, "%s", target_type);
++ dest += written;
++ remains -= written;
++
++ while (remains > 0 && next) {
++ next = dm_get_next_target(dmt, next, &start, &length,
++ &target_type, &params);
++ if (target_type) {
++ written = snprintf(dest, remains, ",%s", target_type);
++ dest += written;
++ remains -= written;
++ }
++ }
++ }
++
++ buf[sizeof(buf)-1] = '\0';
++
++ return dm_report_field_string(rh, field, &s);
++}
++
+ static int _dm_info_devno_disp(struct dm_report *rh, struct dm_pool *mem,
+ struct dm_report_field *field, const void *data,
+ void *private)
+@@ -2057,6 +2134,7 @@
+ { DR_DEPS, "Mapped Device Relationship Information", "", _deps_get_obj },
+ { DR_TREE, "Mapped Device Relationship Information", "", _tree_get_obj },
+ { DR_NAME, "Mapped Device Name Components", "", _split_name_get_obj },
++ { DR_TABLE, "Mapped Device Table", "", _task_get_obj },
+ { 0, "", "", NULL },
+ };
+
+@@ -2076,6 +2154,7 @@
+ FIELD_F(TASK, NUM, "RAhead", 6, dm_read_ahead, "read_ahead", "Read ahead in sectors.")
+
+ FIELD_F(INFO, STR, "Stat", 4, dm_info_status, "attr", "(L)ive, (I)nactive, (s)uspended, (r)ead-only, read-(w)rite.")
++FIELD_F(INFO, STR, "State", 1, dm_info_cleartext_status, "status", "State as cleartext.")
+ FIELD_F(INFO, STR, "Tables", 6, dm_info_table_loaded, "tables_loaded", "Which of the live and inactive table slots are filled.")
+ FIELD_F(INFO, STR, "Suspended", 9, dm_info_suspended, "suspended", "Whether the device is suspended.")
+ FIELD_F(INFO, STR, "Read-only", 9, dm_info_read_only, "readonly", "Whether the device is read-only or writeable.")
+@@ -2086,6 +2165,11 @@
+ FIELD_O(INFO, dm_info, NUM, "Targ", target_count, 4, int32, "segments", "Number of segments in live table, if present.")
+ FIELD_O(INFO, dm_info, NUM, "Event", event_nr, 6, uint32, "events", "Number of most recent event.")
+
++FIELD_O(INFO, dm_info, NUM, "RO", read_only, 2, int, "read_only", "Read only.")
++FIELD_O(INFO, dm_info, NUM, "Ex", exists, 2, int, "exists", "Exists.")
++FIELD_O(INFO, dm_info, NUM, "Susp", suspended, 4, int, "suspended", "Suspended.")
++FIELD_O(INFO, dm_info, NUM, "tab_live", live_table, 8, int, "table_live", "Live table.")
++FIELD_O(INFO, dm_info, NUM, "tab_inact", inactive_table, 9, int, "table_inactive", "Inactive table.")
+ FIELD_O(DEPS, dm_deps, NUM, "#Devs", count, 5, int32, "device_count", "Number of devices used by this one.")
+ FIELD_F(TREE, STR, "DevNames", 8, dm_deps_names, "devs_used", "List of names of mapped devices used by this one.")
+ FIELD_F(DEPS, STR, "DevNos", 6, dm_deps, "devnos_used", "List of device numbers of devices used by this one.")
+@@ -2093,6 +2177,7 @@
+ FIELD_F(TREE, NUM, "#Refs", 5, dm_tree_parents_count, "device_ref_count", "Number of mapped devices referencing this one.")
+ FIELD_F(TREE, STR, "RefNames", 8, dm_tree_parents_names, "names_using_dev", "List of names of mapped devices using this one.")
+ FIELD_F(TREE, STR, "RefDevNos", 9, dm_tree_parents_devs, "devnos_using_dev", "List of device numbers of mapped devices using this one.")
++FIELD_F(TABLE, STR, "Targettypes", 32, dm_info_target_types, "target_types", "Used target types.")
+
+ FIELD_O(NAME, dm_split_name, STR, "Subsys", subsystem, 6, dm_subsystem, "subsystem", "Userspace subsystem responsible for this device.")
+ FIELD_O(NAME, dm_split_name, STR, "VG", vg_name, 4, dm_vg_name, "vg_name", "LVM Volume Group name.")
+@@ -2109,14 +2194,16 @@
+ #undef FIELD_F
+
+ static const char *default_report_options = "name,major,minor,attr,open,segments,events,uuid";
++static const char *default_export_options = "name,major,minor,status,read_only,exists,suspended,table_live,table_inactive,open,segments,events,uuid,target_types";
+ static const char *splitname_report_options = "vg_name,lv_name,lv_layer";
+
+ static int _report_init(struct command *c)
+ {
+- char *options = (char *) default_report_options;
++ char *default_options = (char *) default_report_options;
++ char *options;
+ const char *keys = "";
+ const char *separator = " ";
+- int aligned = 1, headings = 1, buffered = 1, field_prefixes = 0;
++ int aligned = 1, headings = 1, buffered = 1, field_prefixes = 0, export = 0;
+ int quoted = 1, columns_as_rows = 0;
+ uint32_t flags = 0;
+ size_t len = 0;
+@@ -2146,6 +2233,15 @@
+ field_prefixes = 1;
+ }
+
++ if (_switches[EXPORT_ARG]) {
++ default_options = (char *) default_export_options;
++ separator = "\n";
++ aligned = 0;
++ headings = 0;
++ export = 1;
++ }
++
++ options = default_options;
+ if (_switches[OPTIONS_ARG] && _string_args[OPTIONS_ARG]) {
+ if (*_string_args[OPTIONS_ARG] != '+')
+ options = _string_args[OPTIONS_ARG];
+@@ -2197,6 +2293,9 @@
+ if (columns_as_rows)
+ flags |= DM_REPORT_OUTPUT_COLUMNS_AS_ROWS;
+
++ if (export)
++ flags |= DM_REPORT_OUTPUT_EXPORT;
++
+ if (!(_report = dm_report_init(&_report_type,
+ _report_types, _report_fields,
+ options, separator, flags, keys, NULL)))
+@@ -2276,7 +2375,8 @@
+ fprintf(out, "dmsetup [--version] [-v|--verbose [-v|--verbose ...]]\n"
+ " [-r|--readonly] [--noopencount] [--nolockfs]\n"
+ " [--readahead [+]<sectors>|auto|none]\n"
+- " [-c|-C|--columns] [-o <fields>] [-O|--sort <sort_fields>]\n"
++ " [-c|-C|--columns] [-e|--export]\n"
++ " [-o <fields>] [-O|--sort <sort_fields>]\n"
+ " [--nameprefixes] [--noheadings] [--separator <separator>]\n\n");
+ for (i = 0; _commands[i].name; i++)
+ fprintf(out, "\t%s %s\n", _commands[i].name, _commands[i].help);
+@@ -2532,7 +2632,7 @@
+ show_all++;
+ if (c == 'd')
+ delete++;
+- if (c == 'e')
++ if (c == 'E')
+ encrypt_loop++;
+ if (c == 'f')
+ find++;
+@@ -2627,6 +2727,7 @@
+ static struct option long_options[] = {
+ {"readonly", 0, &ind, READ_ONLY},
+ {"columns", 0, &ind, COLS_ARG},
++ {"export", 0, &ind, EXPORT_ARG},
+ {"exec", 1, &ind, EXEC_ARG},
+ {"force", 0, &ind, FORCE_ARG},
+ {"gid", 1, &ind, GID_ARG},
+@@ -2709,12 +2810,16 @@
+
+ optarg = 0;
+ optind = OPTIND_INIT;
+- while ((ind = -1, c = GETOPTLONG_FN(*argc, *argv, "cCfG:j:m:M:no:O:ru:U:v",
++ while ((ind = -1, c = GETOPTLONG_FN(*argc, *argv, "cCefG:j:m:M:no:O:ru:U:v",
+ long_options, NULL)) != -1) {
+ if (c == ':' || c == '?')
+ return 0;
+ if (c == 'c' || c == 'C' || ind == COLS_ARG)
+ _switches[COLS_ARG]++;
++ if (c == 'e' || ind == EXPORT_ARG) {
++ _switches[EXPORT_ARG]++;
++ _switches[COLS_ARG]++;
++ }
+ if (c == 'f' || ind == FORCE_ARG)
+ _switches[FORCE_ARG]++;
+ if (c == 'r' || ind == READ_ONLY)