summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2005-06-21 19:42:17 +0000
committerTim Yamin <plasmaroo@gentoo.org>2005-06-21 19:42:17 +0000
commit62c66b82c6a67b635aacc7f43aeca4a4783e083a (patch)
tree8c16a848465622c0b2bc3d65c15407444585ec26 /sys-fs/ext2resize
parentRemoved hppa and ppc keywords. This is native x86! Fixed BUG #96458. (diff)
downloadgentoo-2-62c66b82c6a67b635aacc7f43aeca4a4783e083a.tar.gz
gentoo-2-62c66b82c6a67b635aacc7f43aeca4a4783e083a.tar.bz2
gentoo-2-62c66b82c6a67b635aacc7f43aeca4a4783e083a.zip
Fix #96699.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-fs/ext2resize')
-rw-r--r--sys-fs/ext2resize/ChangeLog6
-rw-r--r--sys-fs/ext2resize/ext2resize-1.1.19.ebuild4
-rw-r--r--sys-fs/ext2resize/files/ext2resize-1.1.19-linux26.patch10
3 files changed, 18 insertions, 2 deletions
diff --git a/sys-fs/ext2resize/ChangeLog b/sys-fs/ext2resize/ChangeLog
index 20c87964c12b..45bd8a7c8a06 100644
--- a/sys-fs/ext2resize/ChangeLog
+++ b/sys-fs/ext2resize/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/ext2resize
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ChangeLog,v 1.8 2005/06/21 03:54:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ChangeLog,v 1.9 2005/06/21 19:42:17 plasmaroo Exp $
+
+ 21 Jun 2005; <plasmaroo@gentoo.org> ext2resize-1.1.19.ebuild,
+ +files/ext2resize-1.1.19-linux26.patch:
+ Fix #96699.
*ext2resize-1.1.19 (21 Jun 2005)
diff --git a/sys-fs/ext2resize/ext2resize-1.1.19.ebuild b/sys-fs/ext2resize/ext2resize-1.1.19.ebuild
index 361f79e50185..a36929f53541 100644
--- a/sys-fs/ext2resize/ext2resize-1.1.19.ebuild
+++ b/sys-fs/ext2resize/ext2resize-1.1.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ext2resize-1.1.19.ebuild,v 1.1 2005/06/21 03:54:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ext2resize-1.1.19.ebuild,v 1.2 2005/06/21 19:42:17 plasmaroo Exp $
inherit flag-o-matic eutils
@@ -22,6 +22,8 @@ src_unpack() {
# stupid packaged source isn't clean
make -k distclean >& /dev/null
sed -i '/^CFLAGS/d' src/Makefile.in
+
+ epatch ${FILESDIR}/${P}-linux26.patch
}
src_compile() {
diff --git a/sys-fs/ext2resize/files/ext2resize-1.1.19-linux26.patch b/sys-fs/ext2resize/files/ext2resize-1.1.19-linux26.patch
new file mode 100644
index 000000000000..a43cb4cb2253
--- /dev/null
+++ b/sys-fs/ext2resize/files/ext2resize-1.1.19-linux26.patch
@@ -0,0 +1,10 @@
+--- src/ext2_unix_io.c 2005-06-21 20:38:30.000000000 +0100
++++ src/ext2_unix_io.c.plasmaroo 2005-06-21 20:38:22.000000000 +0100
+@@ -35,6 +35,7 @@
+ #include <errno.h>
+ #include <string.h>
+ #include "ext2.h"
++#include <linux/fs.h>
+
+ #ifndef O_LARGEFILE
+ #define O_LARGEFILE 0