summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2005-09-09 20:42:37 +0000
committerWolfram Schlich <wschlich@gentoo.org>2005-09-09 20:42:37 +0000
commit45aa47f73dee7becace079b72e66f94eee785571 (patch)
treede84076b1051d6705ffd912bcebfd4441b0fadd3 /sys-fs/dazuko
parentinitial commit (diff)
downloadgentoo-2-45aa47f73dee7becace079b72e66f94eee785571.tar.gz
gentoo-2-45aa47f73dee7becace079b72e66f94eee785571.tar.bz2
gentoo-2-45aa47f73dee7becace079b72e66f94eee785571.zip
initial import
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-fs/dazuko')
-rw-r--r--sys-fs/dazuko/ChangeLog10
-rw-r--r--sys-fs/dazuko/Manifest4
-rw-r--r--sys-fs/dazuko/dazuko-2.1.0.ebuild56
-rw-r--r--sys-fs/dazuko/files/digest-dazuko-2.1.01
-rw-r--r--sys-fs/dazuko/metadata.xml21
5 files changed, 92 insertions, 0 deletions
diff --git a/sys-fs/dazuko/ChangeLog b/sys-fs/dazuko/ChangeLog
new file mode 100644
index 000000000000..3887966d002c
--- /dev/null
+++ b/sys-fs/dazuko/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-fs/dazuko
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.1 2005/09/09 20:42:37 wschlich Exp $
+
+*dazuko-2.1.0 (09 Sep 2005)
+
+ 09 Sep 2005; Wolfram Schlich <wschlich@gentoo.org> +metadata.xml,
+ +dazuko-2.1.0.ebuild:
+ initial import
+
diff --git a/sys-fs/dazuko/Manifest b/sys-fs/dazuko/Manifest
new file mode 100644
index 000000000000..c91361dde146
--- /dev/null
+++ b/sys-fs/dazuko/Manifest
@@ -0,0 +1,4 @@
+MD5 099358dbc4535c4ca0965cb8ee2b98a1 metadata.xml 985
+MD5 9e26767bc2fc8db3824068ede2bc876a ChangeLog 253
+MD5 c0da19e0d2833e87aad42443d468cf19 dazuko-2.1.0.ebuild 1200
+MD5 c66de473433fc5ed24d6c9f4ebc9ebef files/digest-dazuko-2.1.0 64
diff --git a/sys-fs/dazuko/dazuko-2.1.0.ebuild b/sys-fs/dazuko/dazuko-2.1.0.ebuild
new file mode 100644
index 000000000000..df7635d4e40b
--- /dev/null
+++ b/sys-fs/dazuko/dazuko-2.1.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.1.0.ebuild,v 1.1 2005/09/09 20:42:37 wschlich Exp $
+
+inherit linux-mod eutils
+
+DESCRIPTION="Linux kernel module and interface providing file access control"
+MY_P="${P/_/-}" # for -preN versions
+SRC_URI="http://www.dazuko.org/files/${MY_P}.tar.gz"
+HOMEPAGE="http://www.dazuko.org"
+LICENSE="GPL-2 BSD"
+# use full kernel version as SLOT, preventing removal of dazuko
+# modules for previously used kernels
+SLOT="${KV_FULL:-0}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND=">=virtual/linux-sources-2.2"
+S="${WORKDIR}/${MY_P}"
+
+# kernel settings
+CONFIG_CHECK="SECURITY_CAPABILITIES"
+MODULE_NAMES="dazuko(misc:)"
+BUILD_TARGETS="dummy_rule"
+
+# TODO add 'example' USE flag, install example source code
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ ./configure \
+ --kernelsrcdir="${KERNEL_DIR}" \
+ || die "configure failed"
+ convert_to_m Makefile
+ linux-mod_src_compile
+
+ cd library && emake && cd ..
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dolib.a library/libdazuko.a
+ insinto /usr/include
+ doins dazukoio.h
+
+ dodoc COPYING
+ dodoc README
+ dodoc README.linux26
+ dodoc README.trusted
+# dodoc LICENSE.BSD
+# dodoc LICENSE.GPL
+}
+
diff --git a/sys-fs/dazuko/files/digest-dazuko-2.1.0 b/sys-fs/dazuko/files/digest-dazuko-2.1.0
new file mode 100644
index 000000000000..e05af794d3be
--- /dev/null
+++ b/sys-fs/dazuko/files/digest-dazuko-2.1.0
@@ -0,0 +1 @@
+MD5 f7e5ea23a0b3a1539bd0c0b96df426f0 dazuko-2.1.0.tar.gz 159456
diff --git a/sys-fs/dazuko/metadata.xml b/sys-fs/dazuko/metadata.xml
new file mode 100644
index 000000000000..2712cdb26b8a
--- /dev/null
+++ b/sys-fs/dazuko/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>wschlich@gentoo.org</email>
+ <name>Wolfram Schlich</name>
+ <description>Primary maintainer</description>
+</maintainer>
+<longdescription>
+This project provides a device driver allowing 3rd-party (userland) applications
+to execute file access control. It was originally developed by H+BEDV
+Datentechnik GmbH to allow on-access virus scanning. Other uses include a
+file-access monitor/logger or external security implementations. It operates by
+intercepting file access calls and passing the file information to a 3rd-party
+application. The 3rd-party application then has the opportunity to tell the
+device driver to allow or deny the file access. The 3rd-party application also
+receives information about the access event, such as accessed file, type of
+access, process id, and user id.
+</longdescription>
+</pkgmetadata>