summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-07-12 00:31:59 +0000
committerTim Harder <radhermit@gentoo.org>2011-07-12 00:31:59 +0000
commit29d4258b2877d12aa4e04f77d8a0b1bad0b62f7b (patch)
tree251a2aad0465c663723cb26be9a5ffe392f41f72 /sys-fs/avfs
parentAdd dependency on libgamin (bug #366827 by Sven Eden). Explicitly call (diff)
downloadgentoo-2-29d4258b2877d12aa4e04f77d8a0b1bad0b62f7b.tar.gz
gentoo-2-29d4258b2877d12aa4e04f77d8a0b1bad0b62f7b.tar.bz2
gentoo-2-29d4258b2877d12aa4e04f77d8a0b1bad0b62f7b.zip
Version bump. Update to EAPI 4, remove old kernel version warning, use system zlib/bzip2 libraries, and remove relative path in patch file.
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/avfs')
-rw-r--r--sys-fs/avfs/ChangeLog9
-rw-r--r--sys-fs/avfs/avfs-1.0.0.ebuild65
-rw-r--r--sys-fs/avfs/files/avfs-0.9.8-gcc43_fix_open_missing_mode.patch2
3 files changed, 74 insertions, 2 deletions
diff --git a/sys-fs/avfs/ChangeLog b/sys-fs/avfs/ChangeLog
index 8b3d08ac52c8..03cbebc60dea 100644
--- a/sys-fs/avfs/ChangeLog
+++ b/sys-fs/avfs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/avfs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/ChangeLog,v 1.34 2011/01/13 23:37:09 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/ChangeLog,v 1.35 2011/07/12 00:31:58 radhermit Exp $
+
+*avfs-1.0.0 (12 Jul 2011)
+
+ 12 Jul 2011; Tim Harder <radhermit@gentoo.org>
+ files/avfs-0.9.8-gcc43_fix_open_missing_mode.patch, +avfs-1.0.0.ebuild:
+ Version bump. Update to EAPI 4, remove old kernel version warning, use system
+ zlib/bzip2 libraries, and remove relative path in patch file.
13 Jan 2011; Tim Harder <radhermit@gentoo.org> -avfs-0.9.7-r1.ebuild,
-avfs-0.9.8.ebuild, -avfs-0.9.8-r1.ebuild:
diff --git a/sys-fs/avfs/avfs-1.0.0.ebuild b/sys-fs/avfs/avfs-1.0.0.ebuild
new file mode 100644
index 000000000000..ff7cfd143d34
--- /dev/null
+++ b/sys-fs/avfs/avfs-1.0.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/avfs-1.0.0.ebuild,v 1.1 2011/07/12 00:31:58 radhermit Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="AVFS is a virtual filesystem that allows browsing of compressed files."
+HOMEPAGE="http://sourceforge.net/projects/avf"
+SRC_URI="mirror://sourceforge/avf/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="static-libs +lzma"
+
+DEPEND=">=sys-fs/fuse-2.4
+ sys-libs/zlib
+ app-arch/bzip2
+ lzma? ( app-arch/xz-utils )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Fixes bug #258295
+ epatch "${FILESDIR}/${PN}-0.9.8-gcc43_fix_open_missing_mode.patch"
+}
+
+src_configure() {
+ econf \
+ --enable-fuse \
+ --enable-library \
+ --enable-shared \
+ --with-system-zlib \
+ --with-system-bzlib \
+ $(use_enable static-libs static) \
+ $(use_with lzma xz)
+}
+
+src_install() {
+ default
+
+ # remove cruft
+ rm "${D}"/usr/bin/{davpass,ftppass} || die "rm failed"
+
+ # install docs
+ dodoc doc/{api-overview,background,FORMAT,INSTALL.*,README.avfs-fuse}
+ dosym /usr/lib/avfs/extfs/README /usr/share/doc/${PF}/README.extfs
+
+ docinto scripts
+ dodoc scripts/{avfscoda*,*pass}
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ einfo "This version of AVFS includes FUSE support. It is user-based."
+ einfo "To execute:"
+ einfo "1) as user, mkdir ~/.avfs"
+ einfo "2) make sure fuse is either compiled into the kernel OR"
+ einfo " modprobe fuse or add to startup."
+ einfo "3) run mountavfs"
+ einfo "To unload daemon, type umountavfs"
+ echo
+ einfo "READ the documentation! Enjoy :)"
+}
diff --git a/sys-fs/avfs/files/avfs-0.9.8-gcc43_fix_open_missing_mode.patch b/sys-fs/avfs/files/avfs-0.9.8-gcc43_fix_open_missing_mode.patch
index fff205250af2..f3ef83a7f31c 100644
--- a/sys-fs/avfs/files/avfs-0.9.8-gcc43_fix_open_missing_mode.patch
+++ b/sys-fs/avfs/files/avfs-0.9.8-gcc43_fix_open_missing_mode.patch
@@ -1,4 +1,4 @@
---- ../avfs-0.9.8_orig/modules/urar.c 2007-05-14 20:21:23.000000000 +0200
+--- modules/urar.c 2007-05-14 20:21:23.000000000 +0200
+++ modules/urar.c 2009-02-09 13:48:56.780225932 +0100
@@ -587,7 +587,7 @@
if(res < 0)