summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-05-24 11:02:31 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-05-24 11:02:31 +0000
commitce8e6db1347304f04e1dc6a21344c6ff6f4e038d (patch)
tree03f28eaae1636d7423e58612a07f99d88f864924 /sys-freebsd
parentRemove old. (diff)
downloadgentoo-2-ce8e6db1347304f04e1dc6a21344c6ff6f4e038d.tar.gz
gentoo-2-ce8e6db1347304f04e1dc6a21344c6ff6f4e038d.tar.bz2
gentoo-2-ce8e6db1347304f04e1dc6a21344c6ff6f4e038d.zip
Fix a typo and set MAKEOBJDIRPREFIX when installing too.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-lib/ChangeLog9
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild5
2 files changed, 11 insertions, 3 deletions
diff --git a/sys-freebsd/freebsd-lib/ChangeLog b/sys-freebsd/freebsd-lib/ChangeLog
index ea9882e2af33..cbf7b2fc97bb 100644
--- a/sys-freebsd/freebsd-lib/ChangeLog
+++ b/sys-freebsd/freebsd-lib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-freebsd/freebsd-lib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.138 2012/05/23 21:46:50 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.139 2012/05/24 11:02:31 aballier Exp $
+
+ 24 May 2012; Alexis Ballier <aballier@gentoo.org> freebsd-lib-9.0-r2.ebuild:
+ Fix a typo and set MAKEOBJDIRPREFIX when installing too.
+
+ 23 May 2012; Alexis Ballier <aballier@gentoo.org> freebsd-lib-9.0-r2.ebuild:
+ Add the grounds for multilib and a very very basic multilib support: we only
+ build the csu parts for now.
23 May 2012; Alexis Ballier <aballier@gentoo.org> freebsd-lib-9.0-r2.ebuild:
Add the grounds for multilib and a very very basic multilib support: we only
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild
index fdfccdd2bb77..42d8509ad66f 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild,v 1.24 2012/05/23 21:46:50 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild,v 1.25 2012/05/24 11:02:31 aballier Exp $
EAPI=2
@@ -239,7 +239,7 @@ is_native_abi() {
# Do we need to bootstrap the csu and libssp_nonshared?
need_bootstrap() {
- is_crosscompile || use build || !is_native_abi
+ is_crosscompile || use build || ! is_native_abi
}
# Get the subdirs we are building.
@@ -402,6 +402,7 @@ END_LDSCRIPT
}
do_install() {
+ export MAKEOBJDIRPREFIX="${WORKDIR}/${CHOST}"
for i in $(get_subdirs) ; do
einfo "Installing in ${i}..."
cd "${WORKDIR}/${i}/" || die "missing ${i}."