summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-09-11 17:05:47 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-09-11 17:05:47 +0000
commiteef0208b8757269da24599811bee64947758f441 (patch)
tree69b196d0e3149c8f19c214034e6ee0d0cf5d865c /sys-freebsd/freebsd-sbin
parentbump to 9.1_rc1 from bsd overlay by Yuta SATOH, bug #426838 (diff)
downloadgentoo-2-eef0208b8757269da24599811bee64947758f441.tar.gz
gentoo-2-eef0208b8757269da24599811bee64947758f441.tar.bz2
gentoo-2-eef0208b8757269da24599811bee64947758f441.zip
bump to 9.1_rc1 from bsd overlay by Yuta SATOH, bug #426838
(Portage version: 2.2.0_alpha125/cvs/Linux x86_64)
Diffstat (limited to 'sys-freebsd/freebsd-sbin')
-rw-r--r--sys-freebsd/freebsd-sbin/ChangeLog8
-rw-r--r--sys-freebsd/freebsd-sbin/freebsd-sbin-9.1_rc1.ebuild92
2 files changed, 99 insertions, 1 deletions
diff --git a/sys-freebsd/freebsd-sbin/ChangeLog b/sys-freebsd/freebsd-sbin/ChangeLog
index e72ea6f4f5a7..788866fb4097 100644
--- a/sys-freebsd/freebsd-sbin/ChangeLog
+++ b/sys-freebsd/freebsd-sbin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-freebsd/freebsd-sbin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sbin/ChangeLog,v 1.69 2012/05/12 14:28:56 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sbin/ChangeLog,v 1.70 2012/09/11 17:05:47 aballier Exp $
+
+*freebsd-sbin-9.1_rc1 (11 Sep 2012)
+
+ 11 Sep 2012; Alexis Ballier <aballier@gentoo.org>
+ +freebsd-sbin-9.1_rc1.ebuild:
+ bump to 9.1_rc1 from bsd overlay by Yuta SATOH, bug #426838
12 May 2012; Alexis Ballier <aballier@gentoo.org> -freebsd-sbin-8.2.ebuild,
-freebsd-sbin-9.0.ebuild:
diff --git a/sys-freebsd/freebsd-sbin/freebsd-sbin-9.1_rc1.ebuild b/sys-freebsd/freebsd-sbin/freebsd-sbin-9.1_rc1.ebuild
new file mode 100644
index 000000000000..59c59c495398
--- /dev/null
+++ b/sys-freebsd/freebsd-sbin/freebsd-sbin-9.1_rc1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sbin/freebsd-sbin-9.1_rc1.ebuild,v 1.1 2012/09/11 17:05:47 aballier Exp $
+
+EAPI=2
+
+inherit bsdmk freebsd multilib
+
+DESCRIPTION="FreeBSD sbin utils"
+KEYWORDS="~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+SLOT="0"
+
+SRC_URI="mirror://gentoo/${SBIN}.tar.bz2
+ mirror://gentoo/${CONTRIB}.tar.bz2
+ mirror://gentoo/${LIB}.tar.bz2
+ mirror://gentoo/${LIBEXEC}.tar.bz2
+ mirror://gentoo/${USBIN}.tar.bz2
+ mirror://gentoo/${ETC}.tar.bz2
+ build? ( mirror://gentoo/${SYS}.tar.bz2 )"
+
+RDEPEND="=sys-freebsd/freebsd-lib-${RV}*[ipv6?,atm?,netware?]
+ =sys-freebsd/freebsd-libexec-${RV}*
+ >=dev-libs/expat-2.0.1
+ ssl? ( dev-libs/openssl )
+ >=dev-libs/libedit-20120311.3.0-r1
+ sys-libs/readline
+ sys-process/vixie-cron
+ atm? ( net-analyzer/bsnmp )"
+DEPEND="${RDEPEND}
+ !build? ( =sys-freebsd/freebsd-sources-${RV}* )
+ =sys-freebsd/freebsd-mk-defs-${RV}*"
+
+S="${WORKDIR}/sbin"
+
+IUSE="atm ipfilter +pf ipv6 build ssl +cxx netware"
+
+pkg_setup() {
+ use atm || mymakeopts="${mymakeopts} WITHOUT_ATM= "
+ use cxx || mymakeopts="${mymakeopts} WITHOUT_CXX="
+ use ipfilter || mymakeopts="${mymakeopts} WITHOUT_IPFILTER= "
+ use ipv6 || mymakeopts="${mymakeopts} WITHOUT_INET6= WITHOUT_INET6_SUPPORT="
+ use netware || mymakeopts="${mymakeopts} WITHOUT_IPX= WITHOUT_IPX_SUPPORT= WITHOUT_NCP= "
+ use pf || mymakeopts="${mymakeopts} WITHOUT_PF= "
+ use ssl || mymakeopts="${mymakeopts} WITHOUT_OPENSSL="
+}
+
+REMOVE_SUBDIRS="dhclient pfctl pflogd rcorder resolvconf"
+
+PATCHES=( "${FILESDIR}/${PN}-setXid.patch"
+ "${FILESDIR}/${PN}-7.1-zlib.patch"
+ "${FILESDIR}/${PN}-6.2-ldconfig.patch"
+ "${FILESDIR}/${PN}-6.1-pr102701.patch"
+ "${FILESDIR}/${PN}-bsdxml2expat.patch" )
+
+src_prepare() {
+ use build || ln -s "/usr/src/sys-${RV}" "${WORKDIR}/sys"
+}
+
+src_install() {
+ mymakeopts="${mymakeopts} GEOM_CLASS_DIR=/$(get_libdir)/geom "
+ freebsd_src_install
+ keepdir /var/log
+ # Needed by ldconfig:
+ keepdir /var/run
+
+ # Maybe ship our own sysctl.conf so things like radvd work out of the box.
+ # New wireless config method requires regdomain.xml in /etc
+ cd "${WORKDIR}/etc/"
+ insinto /etc
+ doins minfree sysctl.conf regdomain.xml || die
+
+ # initd script for idmapd
+ newinitd "${FILESDIR}/idmapd.initd" idmapd
+
+ # Install a crontab for adjkerntz
+ insinto /etc/cron.d
+ newins "${FILESDIR}/adjkerntz-crontab" adjkerntz
+
+ # Install the periodic stuff (needs probably to be ported in a more
+ # gentooish way)
+ cd "${WORKDIR}/etc/periodic"
+
+ doperiodic security \
+ security/*.ipfwlimit \
+ security/*.ipfwdenied || die
+
+ use ipfilter && { doperiodic security \
+ security/*.ipfdenied || die ; }
+
+ use pf && { doperiodic security \
+ security/*.pfdenied || die ; }
+}