summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJavier Villavicencio <the_paya@gentoo.org>2009-01-22 21:00:42 +0000
committerJavier Villavicencio <the_paya@gentoo.org>2009-01-22 21:00:42 +0000
commit10a974f74302f2817d982cb7b149aa2396d154b2 (patch)
tree4a8d08cc1545b424474227ef8f5343cff2945eb7 /sys-freebsd/freebsd-bin
parentImport of the 7.1 ebuilds from gentoo-bsd overlay. (diff)
downloadgentoo-2-10a974f74302f2817d982cb7b149aa2396d154b2.tar.gz
gentoo-2-10a974f74302f2817d982cb7b149aa2396d154b2.tar.bz2
gentoo-2-10a974f74302f2817d982cb7b149aa2396d154b2.zip
Import of the 7.1 ebuilds from gentoo-bsd overlay.
(Portage version: 2.2_rc23/cvs/FreeBSD i386)
Diffstat (limited to 'sys-freebsd/freebsd-bin')
-rw-r--r--sys-freebsd/freebsd-bin/ChangeLog10
-rw-r--r--sys-freebsd/freebsd-bin/freebsd-bin-7.1.ebuild37
2 files changed, 45 insertions, 2 deletions
diff --git a/sys-freebsd/freebsd-bin/ChangeLog b/sys-freebsd/freebsd-bin/ChangeLog
index a5f97944208f..fc10d9b7339e 100644
--- a/sys-freebsd/freebsd-bin/ChangeLog
+++ b/sys-freebsd/freebsd-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-freebsd/freebsd-bin
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-bin/ChangeLog,v 1.29 2007/10/02 13:33:19 uberlord Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-bin/ChangeLog,v 1.30 2009/01/22 21:00:42 the_paya Exp $
+
+*freebsd-contrib-7.1 (22 Jan 2009)
+
+ 22 Jan 2009; Javier Villavicencio <the_paya@gentoo.org>
+ +freebsd-bin-7.1.ebuild:
+ Import 7.1 ebuilds from gentoo-bsd overlay.
02 Oct 2007; Roy Marples <uberlord@gentoo.org>
+files/freebsd-bin-6.2-sh-cclass.patch, freebsd-bin-6.2.ebuild:
diff --git a/sys-freebsd/freebsd-bin/freebsd-bin-7.1.ebuild b/sys-freebsd/freebsd-bin/freebsd-bin-7.1.ebuild
new file mode 100644
index 000000000000..ade940bd0fb5
--- /dev/null
+++ b/sys-freebsd/freebsd-bin/freebsd-bin-7.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-bin/freebsd-bin-7.1.ebuild,v 1.1 2009/01/22 21:00:42 the_paya Exp $
+
+inherit bsdmk freebsd
+
+DESCRIPTION="FreeBSD /bin tools"
+SLOT="0"
+KEYWORDS="~sparc-fbsd ~x86-fbsd"
+
+IUSE="nls"
+
+SRC_URI="mirror://gentoo/${BIN}.tar.bz2
+ mirror://gentoo/${SBIN}.tar.bz2
+ mirror://gentoo/${LIB}.tar.bz2"
+
+RDEPEND="=sys-freebsd/freebsd-lib-${RV}*
+ dev-libs/libedit
+ sys-libs/ncurses
+ sys-apps/ed
+ !app-admin/realpath"
+DEPEND="${RDEPEND}
+ =sys-freebsd/freebsd-mk-defs-${RV}*
+ >=sys-devel/flex-2.5.31-r2"
+
+S=${WORKDIR}/bin
+
+PATCHES="${FILESDIR}/${PN}-6.0-flex-2.5.31.patch"
+
+# csh and tcsh are provided by tcsh package, rmail is sendmail stuff.
+REMOVE_SUBDIRS="csh rmail ed"
+
+pkg_setup() {
+ use nls || mymakeopts="${mymakeopts} NO_NLS= "
+
+ mymakeopts="${mymakeopts} NO_TCSH= NO_SENDMAIL= NO_OPENSSL= NO_CRYPT= NO_RCMDS= "
+}