summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-10-26 17:26:41 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-10-26 17:26:41 +0000
commitf84c375d0d7f84a74993550927f2209b10a48f51 (patch)
treef4cc43f149300a9180fd2d557710c8716f50a5c9 /sys-devel
parentFixing dupe Changelog entry (diff)
downloadgentoo-2-f84c375d0d7f84a74993550927f2209b10a48f51.tar.gz
gentoo-2-f84c375d0d7f84a74993550927f2209b10a48f51.tar.bz2
gentoo-2-f84c375d0d7f84a74993550927f2209b10a48f51.zip
Fix documentation Makefile in the same way as llvm
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/ChangeLog6
-rw-r--r--sys-devel/clang/clang-2.6.ebuild8
-rw-r--r--sys-devel/clang/files/clang-2.6-fixdoc.patch53
3 files changed, 64 insertions, 3 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index faab150a8a0e..7edc75dcf372 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.2 2009/10/25 20:21:33 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.3 2009/10/26 17:26:41 voyageur Exp $
+
+ 26 Oct 2009; Bernard Cafarelli <voyageur@gentoo.org> clang-2.6.ebuild,
+ +files/clang-2.6-fixdoc.patch:
+ Fix documentation Makefile in the same way as llvm
*clang-2.6 (25 Oct 2009)
diff --git a/sys-devel/clang/clang-2.6.ebuild b/sys-devel/clang/clang-2.6.ebuild
index e3870f3f8ed8..69c3bc0ae430 100644
--- a/sys-devel/clang/clang-2.6.ebuild
+++ b/sys-devel/clang/clang-2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-2.6.ebuild,v 1.1 2009/10/25 20:21:33 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-2.6.ebuild,v 1.2 2009/10/26 17:26:41 voyageur Exp $
EAPI=2
inherit eutils python
@@ -15,7 +15,7 @@ SRC_URI="http://llvm.org/releases/${PV}/llvm-${PV}.tar.gz
LICENSE="UoI-NCSA"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+static-analyzer test"
+IUSE="debug +static-analyzer test"
# Note: for LTO support, clang will depend on binutils with gold plugins, and LLVM built after that - http://llvm.org/docs/GoldPlugin.html
DEPEND="static-analyzer? ( dev-lang/perl )
@@ -26,6 +26,10 @@ S="${WORKDIR}/llvm-2.6"
src_prepare() {
mv "${WORKDIR}"/clang-2.6 "${S}"/tools/clang || die "clang source directory not found"
+
+ # Same as llvm doc patches
+ epatch "${FILESDIR}"/${PN}-2.6-fixdoc.patch
+
sed -e "s#lib/clang/1.0#$(get_libdir)/clang/1.0#" \
-i "${S}"/tools/clang/lib/Headers/Makefile \
|| die "clang Makefile failed"
diff --git a/sys-devel/clang/files/clang-2.6-fixdoc.patch b/sys-devel/clang/files/clang-2.6-fixdoc.patch
new file mode 100644
index 000000000000..d0d392c87ac1
--- /dev/null
+++ b/sys-devel/clang/files/clang-2.6-fixdoc.patch
@@ -0,0 +1,53 @@
+diff -Naur llvm-2.6.orig/tools/clang/docs/Makefile llvm-2.6/tools/clang/docs/Makefile
+--- llvm-2.6.orig/tools/clang/docs/Makefile 2009-10-26 18:09:24.000000000 +0100
++++ llvm-2.6/tools/clang/docs/Makefile 2009-10-26 18:17:29.000000000 +0100
+@@ -46,13 +46,12 @@
+ # 'make generated BUILD_FOR_WEBSITE=1'
+ generated:: doxygen
+
+-install-html: $(PROJ_OBJ_DIR)/html.tar.gz
++install-html:
+ $(Echo) Installing HTML documentation
+ $(Verb) $(MKDIR) $(PROJ_docsdir)/html
+ $(Verb) $(MKDIR) $(PROJ_docsdir)/html/img
+ $(Verb) $(DataInstall) $(HTML) $(PROJ_docsdir)/html
+ # $(Verb) $(DataInstall) $(IMAGES) $(PROJ_docsdir)/html/img
+- $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/html.tar.gz $(PROJ_docsdir)
+
+ $(PROJ_OBJ_DIR)/html.tar.gz: $(HTML)
+ $(Echo) Packaging HTML documentation
+@@ -64,12 +63,11 @@
+ install-doxygen: doxygen
+ $(Echo) Installing doxygen documentation
+ $(Verb) $(MKDIR) $(PROJ_docsdir)/html/doxygen
+- $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/doxygen.tar.gz $(PROJ_docsdir)
+ $(Verb) cd $(PROJ_OBJ_DIR)/doxygen && \
+ $(FIND) . -type f -exec \
+ $(DataInstall) {} $(PROJ_docsdir)/html/doxygen \;
+
+-doxygen: regendoc $(PROJ_OBJ_DIR)/doxygen.tar.gz
++doxygen: regendoc
+
+ regendoc:
+ $(Echo) Building doxygen documentation
+diff -Naur llvm-2.6.orig/tools/clang/docs/tools/Makefile llvm-2.6/tools/clang/docs/tools/Makefile
+--- llvm-2.6.orig/tools/clang/docs/tools/Makefile 2009-10-26 18:09:24.000000000 +0100
++++ llvm-2.6/tools/clang/docs/tools/Makefile 2009-10-26 18:16:06.000000000 +0100
+@@ -23,7 +23,7 @@
+ DST_PS_DIR=ps/
+
+ # If we are in BUILD_FOR_WEBSITE mode, default to the all target.
+-all:: html man ps
++all:: html man
+
+ clean:
+ rm -f pod2htm*.*~~ $(HTML) $(MAN) $(PS)
+@@ -55,7 +55,7 @@
+ ifdef ONLY_MAN_DOCS
+ INSTALL_TARGETS := install-man
+ else
+-INSTALL_TARGETS := install-html install-man install-ps
++INSTALL_TARGETS := install-html install-man
+ endif
+
+ .SUFFIXES: