summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2006-06-03 18:18:01 +0000
committerGuy Martin <gmsoft@gentoo.org>2006-06-03 18:18:01 +0000
commitf0e7c6d2fa133b722c57934a654fca14531be99e (patch)
tree4b166585deb4feb4a7c9dde63c7dfc7f94c5ded2 /sys-devel
parentOn PA7200, uname -a contains a single quote and we need to filter it otherwis... (diff)
downloadgentoo-2-f0e7c6d2fa133b722c57934a654fca14531be99e.tar.gz
gentoo-2-f0e7c6d2fa133b722c57934a654fca14531be99e.tar.bz2
gentoo-2-f0e7c6d2fa133b722c57934a654fca14531be99e.zip
On PA7200, uname -a contains a single quote and we need to filter it otherwise configure fails. See #125535.
(Portage version: 2.1_rc3-r5)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/libperl/ChangeLog7
-rw-r--r--sys-devel/libperl/files/perl-hppa-pa7200-configure.patch11
-rw-r--r--sys-devel/libperl/libperl-5.8.8-r1.ebuild7
3 files changed, 23 insertions, 2 deletions
diff --git a/sys-devel/libperl/ChangeLog b/sys-devel/libperl/ChangeLog
index cf9e25eb6052..d4e6f911c192 100644
--- a/sys-devel/libperl/ChangeLog
+++ b/sys-devel/libperl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/libperl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.113 2006/05/27 21:34:52 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.114 2006/06/03 18:18:00 gmsoft Exp $
+
+ 03 Jun 2006; Guy Martin <gmsoft@gentoo.org>
+ +files/perl-hppa-pa7200-configure.patch, libperl-5.8.8-r1.ebuild:
+ On PA7200, uname -a contains a single quote and we need to filter it
+ otherwise configure fails. See #125535.
27 May 2006; Bryan Østergaard <kloeri@gentoo.org>
libperl-5.8.8-r1.ebuild:
diff --git a/sys-devel/libperl/files/perl-hppa-pa7200-configure.patch b/sys-devel/libperl/files/perl-hppa-pa7200-configure.patch
new file mode 100644
index 000000000000..396209af112b
--- /dev/null
+++ b/sys-devel/libperl/files/perl-hppa-pa7200-configure.patch
@@ -0,0 +1,11 @@
+--- Configure.orig 2006-06-02 13:14:22.000000000 -0500
++++ Configure 2006-06-02 13:07:03.000000000 -0500
+@@ -2967,7 +2967,7 @@
+ : Try to determine whether config.sh was made on this system
+ case "$config_sh" in
+ '')
+-myuname=`$uname -a 2>/dev/null`
++myuname=`$uname -a | $sed -e "s/'//" 2>/dev/null`
+ $test -z "$myuname" && myuname=`hostname 2>/dev/null`
+ # tr '[A-Z]' '[a-z]' would not work in EBCDIC
+ # because the A-Z/a-z are not consecutive.
diff --git a/sys-devel/libperl/libperl-5.8.8-r1.ebuild b/sys-devel/libperl/libperl-5.8.8-r1.ebuild
index caa965f2ed58..2413ffd6d50b 100644
--- a/sys-devel/libperl/libperl-5.8.8-r1.ebuild
+++ b/sys-devel/libperl/libperl-5.8.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.8-r1.ebuild,v 1.9 2006/05/27 21:34:52 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.8-r1.ebuild,v 1.10 2006/06/03 18:18:00 gmsoft Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -135,6 +135,11 @@ src_unpack() {
# we need the same @INC-inversion magic here we do in perl
cd ${S}; epatch ${FILESDIR}/${P}-reorder-INC.patch
+ # On PA7200, uname -a contains a single quote and we need to
+ # filter it otherwise configure fails. See #125535.
+ epatch ${FILESDIR}/perl-hppa-pa7200-configure.patch
+
+
use amd64 && cd ${S} && epatch ${FILESDIR}/${P}-lib64.patch
[[ ${CHOST} == *-dragonfly* ]] && cd ${S} && epatch ${FILESDIR}/${P}-dragonfly-clean.patch
[[ ${CHOST} == *-freebsd* ]] && cd ${S} && epatch ${FILESDIR}/${P}-fbsdhints.patch