summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-01-19 20:45:11 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-01-19 20:45:11 +0000
commitee97b11b8a9068c022a9af4cb55a913b663bf21c (patch)
tree0d5c5bb47cc450d752687bc840494cc6a167158f /sys-devel
parentUSE=nsplugin relies on GTK+ 2.0, but when someone has USE=gtk3, we won't pull... (diff)
downloadgentoo-2-ee97b11b8a9068c022a9af4cb55a913b663bf21c.tar.gz
gentoo-2-ee97b11b8a9068c022a9af4cb55a913b663bf21c.tar.bz2
gentoo-2-ee97b11b8a9068c022a9af4cb55a913b663bf21c.zip
Add upstream fix by Dennis Schridde for pkglibexec_SCRIPTS handling.
(Portage version: 2.2.0_alpha84_p18/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/automake/ChangeLog9
-rw-r--r--sys-devel/automake/automake-1.11.2-r1.ebuild80
-rw-r--r--sys-devel/automake/files/automake-1.11.2-fix-pkglibexec_SCRIPTS.patch111
3 files changed, 199 insertions, 1 deletions
diff --git a/sys-devel/automake/ChangeLog b/sys-devel/automake/ChangeLog
index 9753422cc0f8..70ee4f2d4769 100644
--- a/sys-devel/automake/ChangeLog
+++ b/sys-devel/automake/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/automake
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.155 2012/01/19 16:17:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.156 2012/01/19 20:45:11 slyfox Exp $
+
+*automake-1.11.2-r1 (19 Jan 2012)
+
+ 19 Jan 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +automake-1.11.2-r1.ebuild,
+ +files/automake-1.11.2-fix-pkglibexec_SCRIPTS.patch:
+ Add upstream fix by Dennis Schridde for pkglibexec_SCRIPTS handling.
19 Jan 2012; Mike Frysinger <vapier@gentoo.org> automake-9999.ebuild:
Execute bootstrap script as pointed out by Sergei Trofimovich.
diff --git a/sys-devel/automake/automake-1.11.2-r1.ebuild b/sys-devel/automake/automake-1.11.2-r1.ebuild
new file mode 100644
index 000000000000..a5e9130ac421
--- /dev/null
+++ b/sys-devel/automake/automake-1.11.2-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.11.2-r1.ebuild,v 1.1 2012/01/19 20:45:11 slyfox Exp $
+
+inherit eutils versionator
+
+if [[ ${PV/_beta} == ${PV} ]]; then
+ MY_P=${P}
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
+ ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.bz2"
+else
+ MY_PV="$(get_major_version).$(($(get_version_component_range 2)-1))b"
+ MY_P="${PN}-${MY_PV}"
+
+ # Alpha/beta releases are not distributed on the usual mirrors.
+ SRC_URI="ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.bz2"
+fi
+
+S="${WORKDIR}/${MY_P}"
+
+# Use Gentoo versioning for slotting.
+SLOT="${PV:0:4}"
+
+DESCRIPTION="Used to generate Makefile.in from Makefile.am"
+HOMEPAGE="http://sources.redhat.com/automake/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ >=sys-devel/automake-wrapper-3-r2
+ >=sys-devel/autoconf-2.62
+ >=sys-apps/texinfo-4.7
+ sys-devel/gnuconfig"
+DEPEND="${RDEPEND}
+ sys-apps/help2man"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-fix-pkglibexec_SCRIPTS.patch
+ chmod a+rx tests/*.test
+ sed -i \
+ -e "s|: (automake)| v${SLOT}: (automake${SLOT})|" \
+ doc/automake.texi || die "sed failed"
+ mv doc/automake{,${SLOT}}.texi
+ sed -i \
+ -e "s:automake.info:automake${SLOT}.info:" \
+ -e "s:automake.texi:automake${SLOT}.texi:" \
+ doc/Makefile.in || die "sed on Makefile.in failed"
+ export WANT_AUTOCONF=2.5
+}
+
+src_compile() {
+ econf --docdir=/usr/share/doc/${PF} HELP2MAN=true || die
+ emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
+
+ local x
+ for x in aclocal automake; do
+ help2man "perl -Ilib ${x}" > doc/${x}-${SLOT}.1
+ done
+}
+
+src_install() {
+ emake DESTDIR="${D}" install \
+ APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
+ dodoc NEWS README THANKS TODO AUTHORS ChangeLog
+
+ rm \
+ "${D}"/usr/bin/{aclocal,automake} \
+ "${D}"/usr/share/man/man1/{aclocal,automake}.1
+
+ # remove all config.guess and config.sub files replacing them
+ # w/a symlink to a specific gnuconfig version
+ local x
+ for x in guess sub ; do
+ dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
+ done
+}
diff --git a/sys-devel/automake/files/automake-1.11.2-fix-pkglibexec_SCRIPTS.patch b/sys-devel/automake/files/automake-1.11.2-fix-pkglibexec_SCRIPTS.patch
new file mode 100644
index 000000000000..fd046c521548
--- /dev/null
+++ b/sys-devel/automake/files/automake-1.11.2-fix-pkglibexec_SCRIPTS.patch
@@ -0,0 +1,111 @@
+upstream: yes
+
+commit 4e4dae500390d2ace681e4e4bc4c590ecdca38c6
+Author: Stefano Lattarini <stefano.lattarini@gmail.com>
+Date: Tue Jan 3 09:06:09 2012 +0100
+
+ install: pkglibexec_SCRIPTS is a valid prefix/primary combination
+
+ It makes little sense for `libexec_SCRIPTS' to be accepted as valid
+ while `pkglibexec_SCRIPTS' is not. So fix this inconsistency by
+ explicitly allowing `pkglibexec_SCRIPTS' as well. It is worth
+ noting that the inconsistency has been there for a long time,
+ but only the quite recent commit `v1.11-373-g9ca6326' "Warnings
+ about primary/prefix mismatch fixed and extended" has made it
+ noisy enough to be noticed.
+
+ * automake.in (handle_scripts): Also list `pkglibexec' among the
+ prefixes valid for the `SCRIPTS' primary.
+ * doc/automake.texi (Scripts): Likewise.
+ * tests/primary-prefix-valid-couples.test: Update.
+ * THANKS: Likewise.
+ * NEWS: Likewise.
+
+ Reported by Dennis Schridde on the automake list:
+ <http://lists.gnu.org/archive/html/automake/2012-01/msg00002.html>
+
+diff --git a/NEWS b/NEWS
+index 599f19f..2e572e4 100644
+--- a/NEWS
++++ b/NEWS
+@@ -82,6 +82,11 @@ New in 1.11.0a:
+
+ Bugs fixed in 1.11.0a:
+
++* Bugs introduced by 1.11.2:
++
++ - Automake now correctly recognizes the prefix/primary combination
++ `pkglibexec_SCRIPTS' as valid.
++
+ * Bugs introduced by 1.11:
+
+ - The `parallel-tests' test driver works around a GNU make 3.80 bug with
+diff --git a/THANKS b/THANKS
+index e9da06c..e9c6db8 100644
+--- a/THANKS
++++ b/THANKS
+@@ -78,6 +78,7 @@ David Pashley david@davidpashley.com
+ David Zaroski cz253@cleveland.Freenet.Edu
+ Dean Povey dpovey@wedgetail.com
+ Dennis J. Linse Dennis.J.Linse@SAIC.com
++Dennis Schridde devurandom@gmx.net
+ Derek R. Price derek.price@openavenue.com
+ Diab Jerius djerius@cfa.harvard.edu
+ Didier Cassirame faded@free.fr
+diff --git a/automake.in b/automake.in
+index a852195..a689b63 100644
+--- a/automake.in
++++ b/automake.in
+@@ -3091,7 +3091,7 @@ sub handle_scripts
+ # useful to sometimes distribute scripts verbatim. This happens
+ # e.g. in Automake itself.
+ &am_install_var ('-candist', 'scripts', 'SCRIPTS',
+- 'bin', 'sbin', 'libexec', 'pkgdata',
++ 'bin', 'sbin', 'libexec', 'pkglibexec', 'pkgdata',
+ 'noinst', 'check');
+ }
+
+diff --git a/doc/automake.texi b/doc/automake.texi
+index cebe084..0c4dc01 100644
+--- a/doc/automake.texi
++++ b/doc/automake.texi
+@@ -7099,11 +7099,12 @@ prefix as with other primaries.
+ @vindex sbin_SCRIPTS
+ @vindex libexec_SCRIPTS
+ @vindex pkgdata_SCRIPTS
++@vindex pkglibexec_SCRIPTS
+ @vindex noinst_SCRIPTS
+ @vindex check_SCRIPTS
+
+ Scripts can be installed in @code{bindir}, @code{sbindir},
+-@code{libexecdir}, or @code{pkgdatadir}.
++@code{libexecdir}, @code{pkglibexecdir}, or @code{pkgdatadir}.
+
+ Scripts that need not be installed can be listed in
+ @code{noinst_SCRIPTS}, and among them, those which are needed only by
+diff --git a/tests/primary-prefix-invalid-couples.test b/tests/primary-prefix-invalid-couples.test
+index 88e0817..c3d6471 100755
+--- a/tests/primary-prefix-invalid-couples.test
++++ b/tests/primary-prefix-invalid-couples.test
+@@ -79,7 +79,7 @@ for primary in $primaries; do
+ prefixes_ok='bin sbin libexec pkglibexec'
+ ;;
+ SCRIPTS)
+- prefixes_ok='bin sbin libexec pkgdata'
++ prefixes_ok='bin sbin libexec pkglibexec pkgdata'
+ ;;
+ DATA)
+ prefixes_ok='data dataroot pkgdata doc html dvi pdf ps
+diff --git a/tests/primary-prefix-valid-couples.test b/tests/primary-prefix-valid-couples.test
+index 36ff5d8..6eb4149 100755
+--- a/tests/primary-prefix-valid-couples.test
++++ b/tests/primary-prefix-valid-couples.test
+@@ -57,7 +57,7 @@ for p in lib pkglib; do
+ echo "${p}_LTLIBRARIES = libd-$p.la" >> Makefile.am
+ done
+
+-for p in bin sbin libexec pkgdata; do
++for p in bin sbin libexec pkglibexec pkgdata; do
+ echo "${p}_SCRIPTS = $p.sh" >> Makefile.am
+ done
+