summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-01-08 10:52:54 +0000
committerMike Frysinger <vapier@gentoo.org>2010-01-08 10:52:54 +0000
commitec3b951914d4c6dffc7a13241b4219a0d8d5ac9c (patch)
treec81df2fdfe49ed950c066622c031fd94017c44ec /sys-devel
parentUnmask JRuby target. (diff)
downloadgentoo-2-ec3b951914d4c6dffc7a13241b4219a0d8d5ac9c.tar.gz
gentoo-2-ec3b951914d4c6dffc7a13241b4219a0d8d5ac9c.tar.bz2
gentoo-2-ec3b951914d4c6dffc7a13241b4219a0d8d5ac9c.zip
Improve .pc sysroot handling #299990.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/crossdev/ChangeLog9
-rw-r--r--sys-devel/crossdev/crossdev-20100108.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index 9b135c04ec90..ed208e3ea595 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/crossdev
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.64 2009/12/10 01:59:02 vapier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.65 2010/01/08 10:52:54 vapier Exp $
+
+*crossdev-20100108 (08 Jan 2010)
+
+ 08 Jan 2010; Mike Frysinger <vapier@gentoo.org> +crossdev-20100108.ebuild:
+ Improve .pc sysroot handling #299990.
*crossdev-20091209 (10 Dec 2009)
diff --git a/sys-devel/crossdev/crossdev-20100108.ebuild b/sys-devel/crossdev/crossdev-20100108.ebuild
new file mode 100644
index 000000000000..1986f0b9dbc3
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20100108.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-20100108.ebuild,v 1.1 2010/01/08 10:52:54 vapier Exp $
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/crossdev.git"
+ inherit git
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.lzma
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.lzma"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ app-shells/bash
+ !sys-devel/crossdev-wrappers"
+DEPEND=""
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}