summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad House <brad_mssw@gentoo.org>2004-02-16 05:20:54 +0000
committerBrad House <brad_mssw@gentoo.org>2004-02-16 05:20:54 +0000
commite463c62c6d8c772ba58adadbba0d9194e3ad3a8b (patch)
tree143325f804d63fac45d8e689f8e77835b4ded972 /sys-devel
parentInitial Import, wvu. (Manifest recommit) (diff)
downloadgentoo-2-e463c62c6d8c772ba58adadbba0d9194e3ad3a8b.tar.gz
gentoo-2-e463c62c6d8c772ba58adadbba0d9194e3ad3a8b.tar.bz2
gentoo-2-e463c62c6d8c772ba58adadbba0d9194e3ad3a8b.zip
spur propagation of fix
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/autoconf/ChangeLog9
-rw-r--r--sys-devel/autoconf/autoconf-2.58-r1.ebuild150
-rw-r--r--sys-devel/autoconf/autoconf-2.59-r2.ebuild150
-rw-r--r--sys-devel/autoconf/files/digest-autoconf-2.58-r12
-rw-r--r--sys-devel/autoconf/files/digest-autoconf-2.59-r22
5 files changed, 312 insertions, 1 deletions
diff --git a/sys-devel/autoconf/ChangeLog b/sys-devel/autoconf/ChangeLog
index 4ff939df069a..86b92bf16ab1 100644
--- a/sys-devel/autoconf/ChangeLog
+++ b/sys-devel/autoconf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/autoconf
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.41 2004/02/16 04:57:01 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.42 2004/02/16 05:20:54 brad_mssw Exp $
+
+*autoconf-2.59-r2 (16 Feb 2004)
+
+ 16 Feb 2004; Brad House <brad_mssw@gentoo.org> autoconf-2.58-r1.ebuild,
+ autoconf-2.59-r2.ebuild:
+ bump versions of autoconf to spur propagation of revertion of ac-wrapper-2.pl
+ goof, as it affects both stable and unstable branches
*autoconf-2.59-r1 (15 Feb 2004)
diff --git a/sys-devel/autoconf/autoconf-2.58-r1.ebuild b/sys-devel/autoconf/autoconf-2.58-r1.ebuild
new file mode 100644
index 000000000000..758ae1c5b400
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.58-r1.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.58-r1.ebuild,v 1.1 2004/02/16 05:20:54 brad_mssw Exp $
+
+IUSE=""
+
+inherit eutils
+
+OLD_PV="2.13"
+OLD_P="${PN}-${OLD_PV}"
+S="${WORKDIR}/${P}"
+OLD_S="${WORKDIR}/${OLD_P}"
+DESCRIPTION="Used to create autoconfiguration files"
+SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.bz2
+ mirror://gnu/${PN}/${P}.tar.bz2
+ mirror://gnu/${PN}/${OLD_P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+
+LICENSE="GPL-2"
+SLOT="2.5"
+KEYWORDS="amd64 x86 ppc sparc alpha hppa mips ~arm ia64 ppc64"
+
+DEPEND=">=sys-apps/texinfo-4.3
+ =sys-devel/m4-1.4*
+ dev-lang/perl"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${OLD_S}
+ epatch ${FILESDIR}/${OLD_P}-configure-gentoo.diff
+ epatch ${FILESDIR}/${OLD_P}-configure.in-gentoo.diff
+
+ cd ${S}
+ # Enable both autoconf-2.1 and autoconf-2.5 info pages
+ epatch ${FILESDIR}/${PN}-2.58-infopage-namechange.patch
+ ln -snf ${S}/doc/autoconf.texi ${S}/doc/autoconf25.texi
+}
+
+src_compile() {
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+ cd ${S}
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+ cd ${OLD_S}
+
+ sed -i 's|\* Autoconf:|\* Autoconf v2.1:|' autoconf.texi
+ cp autoconf.texi autoconf.texi.orig
+ sed -e '/START-INFO-DIR-ENTRY/ i INFO-DIR-SECTION GNU programming tools' \
+ autoconf.texi.orig > autoconf.texi
+
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+}
+
+src_install() {
+
+ # install wrapper script for autodetecting the proper version
+ # to use.
+ exeinto /usr/lib/${PN}
+ newexe ${FILESDIR}/ac-wrapper-2.pl ac-wrapper.pl
+ dosed "s:2\.5x:${PV}:g" /usr/lib/${PN}/ac-wrapper.pl
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+
+ # need to use 'DESTDIR' here, else perl stuff puke
+ cd ${S}
+ make DESTDIR=${D} \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${PV}
+ done
+ # new in 2.5x
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/autom4te
+
+# mv ${D}/usr/share/info/autoconf.info ${D}/usr/share/info/autoconf-2.5.info
+
+ docinto ${PV}
+ dodoc COPYING AUTHORS BUGS NEWS README TODO THANKS
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+
+ # need to use 'prefix' here, else we get sandbox problems
+ cd ${OLD_S}
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${OLD_PV}
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/${x}
+ done
+
+ docinto ${OLD_PV}
+ dodoc COPYING AUTHORS NEWS README TODO
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1
+
+ # from binutils
+ rm -f ${D}/usr/share/info/standards.info*
+}
+
+pkg_preinst() {
+
+ # remove these to make sure symlinks install properly if old versions
+ # was binaries
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ if [ -e ${ROOT}/usr/bin/${x} ]
+ then
+ rm -f ${ROOT}/usr/bin/${x}
+ fi
+ done
+}
+
+pkg_postinst() {
+
+ echo
+ einfo "Please note that the 'WANT_AUTOCONF_?_?=1' have changed to:"
+ echo
+ einfo " WANT_AUTOCONF=<required version>"
+ echo
+ einfo "For instance: WANT_AUTOCONF=2.5"
+ echo
+}
+
diff --git a/sys-devel/autoconf/autoconf-2.59-r2.ebuild b/sys-devel/autoconf/autoconf-2.59-r2.ebuild
new file mode 100644
index 000000000000..b962a34f371e
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.59-r2.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.59-r2.ebuild,v 1.1 2004/02/16 05:20:54 brad_mssw Exp $
+
+IUSE=""
+
+inherit eutils
+
+OLD_PV="2.13"
+OLD_P="${PN}-${OLD_PV}"
+S="${WORKDIR}/${P}"
+OLD_S="${WORKDIR}/${OLD_P}"
+DESCRIPTION="Used to create autoconfiguration files"
+SRC_URI="http://ftp.gnu.org/gnu/${PN}/${P}.tar.bz2
+ mirror://gnu/${PN}/${P}.tar.bz2
+ mirror://gnu/${PN}/${OLD_P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+
+LICENSE="GPL-2"
+SLOT="2.5"
+KEYWORDS="~amd64 ~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm ~ia64 ~ppc64"
+
+DEPEND=">=sys-apps/texinfo-4.3
+ =sys-devel/m4-1.4*
+ dev-lang/perl"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${OLD_S}
+ epatch ${FILESDIR}/${OLD_P}-configure-gentoo.diff
+ epatch ${FILESDIR}/${OLD_P}-configure.in-gentoo.diff
+
+ cd ${S}
+ # Enable both autoconf-2.1 and autoconf-2.5 info pages
+ epatch ${FILESDIR}/${PN}-2.58-infopage-namechange.patch
+ ln -snf ${S}/doc/autoconf.texi ${S}/doc/autoconf25.texi
+}
+
+src_compile() {
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+ cd ${S}
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+ cd ${OLD_S}
+
+ sed -i 's|\* Autoconf:|\* Autoconf v2.1:|' autoconf.texi
+ cp autoconf.texi autoconf.texi.orig
+ sed -e '/START-INFO-DIR-ENTRY/ i INFO-DIR-SECTION GNU programming tools' \
+ autoconf.texi.orig > autoconf.texi
+
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+}
+
+src_install() {
+
+ # install wrapper script for autodetecting the proper version
+ # to use.
+ exeinto /usr/lib/${PN}
+ newexe ${FILESDIR}/ac-wrapper-2.pl ac-wrapper.pl
+ dosed "s:2\.5x:${PV}:g" /usr/lib/${PN}/ac-wrapper.pl
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+
+ # need to use 'DESTDIR' here, else perl stuff puke
+ cd ${S}
+ make DESTDIR=${D} \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${PV}
+ done
+ # new in 2.5x
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/autom4te
+
+# mv ${D}/usr/share/info/autoconf.info ${D}/usr/share/info/autoconf-2.5.info
+
+ docinto ${PV}
+ dodoc COPYING AUTHORS BUGS NEWS README TODO THANKS
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+
+ # need to use 'prefix' here, else we get sandbox problems
+ cd ${OLD_S}
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${OLD_PV}
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/${x}
+ done
+
+ docinto ${OLD_PV}
+ dodoc COPYING AUTHORS NEWS README TODO
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1
+
+ # from binutils
+ rm -f ${D}/usr/share/info/standards.info*
+}
+
+pkg_preinst() {
+
+ # remove these to make sure symlinks install properly if old versions
+ # was binaries
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ if [ -e ${ROOT}/usr/bin/${x} ]
+ then
+ rm -f ${ROOT}/usr/bin/${x}
+ fi
+ done
+}
+
+pkg_postinst() {
+
+ echo
+ einfo "Please note that the 'WANT_AUTOCONF_?_?=1' have changed to:"
+ echo
+ einfo " WANT_AUTOCONF=<required version>"
+ echo
+ einfo "For instance: WANT_AUTOCONF=2.5"
+ echo
+}
+
diff --git a/sys-devel/autoconf/files/digest-autoconf-2.58-r1 b/sys-devel/autoconf/files/digest-autoconf-2.58-r1
new file mode 100644
index 000000000000..0331bc77f727
--- /dev/null
+++ b/sys-devel/autoconf/files/digest-autoconf-2.58-r1
@@ -0,0 +1,2 @@
+MD5 db3fa3069c6554b3505799c7e1022e2b autoconf-2.58.tar.bz2 925208
+MD5 9de56d4a161a723228220b0f425dc711 autoconf-2.13.tar.gz 443844
diff --git a/sys-devel/autoconf/files/digest-autoconf-2.59-r2 b/sys-devel/autoconf/files/digest-autoconf-2.59-r2
new file mode 100644
index 000000000000..a9ae401381fd
--- /dev/null
+++ b/sys-devel/autoconf/files/digest-autoconf-2.59-r2
@@ -0,0 +1,2 @@
+MD5 1ee40f7a676b3cfdc0e3f7cd81551b5f autoconf-2.59.tar.bz2 925073
+MD5 9de56d4a161a723228220b0f425dc711 autoconf-2.13.tar.gz 443844