summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-02-09 15:14:52 +0000
committerMike Frysinger <vapier@gentoo.org>2015-02-09 15:14:52 +0000
commitc99e091194cb2b591d3e3d0914f900f46bfdbb56 (patch)
treeeac0ebabb4d2c3d75b11116d26b2c714934fd28c /sys-devel
parentversion bump (diff)
downloadgentoo-2-c99e091194cb2b591d3e3d0914f900f46bfdbb56.tar.gz
gentoo-2-c99e091194cb2b591d3e3d0914f900f46bfdbb56.tar.bz2
gentoo-2-c99e091194cb2b591d3e3d0914f900f46bfdbb56.zip
Fix by Ruud Koolen for ROOT handling with man/info paths #532610 by Ruud Koolen.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils-config/ChangeLog11
-rw-r--r--sys-devel/binutils-config/binutils-config-4-r2.ebuild24
-rwxr-xr-xsys-devel/binutils-config/files/binutils-config-410
3 files changed, 38 insertions, 7 deletions
diff --git a/sys-devel/binutils-config/ChangeLog b/sys-devel/binutils-config/ChangeLog
index 7b04b8fe2638..38aeb1a8ef29 100644
--- a/sys-devel/binutils-config/ChangeLog
+++ b/sys-devel/binutils-config/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/binutils-config
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/ChangeLog,v 1.67 2014/12/30 15:10:36 blueness Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/ChangeLog,v 1.68 2015/02/09 15:14:52 vapier Exp $
+
+*binutils-config-4-r2 (09 Feb 2015)
+
+ 09 Feb 2015; Mike Frysinger <vapier@gentoo.org> +binutils-config-4-r2.ebuild,
+ files/binutils-config-4:
+ Fix by Ruud Koolen for ROOT handling with man/info paths #532610 by Ruud
+ Koolen.
*binutils-config-4-r1 (30 Dec 2014)
diff --git a/sys-devel/binutils-config/binutils-config-4-r2.ebuild b/sys-devel/binutils-config/binutils-config-4-r2.ebuild
new file mode 100644
index 000000000000..feddfc0bdf41
--- /dev/null
+++ b/sys-devel/binutils-config/binutils-config-4-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/binutils-config-4-r2.ebuild,v 1.1 2015/02/09 15:14:52 vapier Exp $
+
+EAPI="4"
+
+DESCRIPTION="Utility to change the binutils version being used"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+# We also RDEPEND on sys-apps/findutils which is in base @system
+RDEPEND="sys-apps/gentoo-functions"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin "${FILESDIR}"/${PN}-${PV} ${PN}
+ doman "${FILESDIR}"/${PN}.8
+}
diff --git a/sys-devel/binutils-config/files/binutils-config-4 b/sys-devel/binutils-config/files/binutils-config-4
index b860b291b78d..4ddc94b9ea85 100755
--- a/sys-devel/binutils-config/files/binutils-config-4
+++ b/sys-devel/binutils-config/files/binutils-config-4
@@ -1,7 +1,7 @@
#!/bin/bash
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-4,v 1.2 2014/12/30 15:10:36 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-4,v 1.3 2015/02/09 15:14:52 vapier Exp $
# Format of /etc/env.d/binutils/:
# config-TARGET: CURRENT=version for TARGET
@@ -170,8 +170,8 @@ switch_profile() {
local e="${ROOT}"/etc/env.d/05binutils
local ee="${e}.tmp"
rm -f "${ee}"
- [[ -d ${DATAPATH}/man ]] && echo "MANPATH=${DATAPATH}/man" >> "${ee}"
- [[ -d ${DATAPATH}/info ]] && echo "INFOPATH=${DATAPATH}/info" >> "${ee}"
+ [[ -d ${ROOT}/${DATAPATH}/man ]] && echo "MANPATH=${DATAPATH}/man" >> "${ee}"
+ [[ -d ${ROOT}/${DATAPATH}/info ]] && echo "INFOPATH=${DATAPATH}/info" >> "${ee}"
# hmm, `ld` has this in SEARCH_DIR(), but ld.so does not ...
if [[ -d ${ROOT}/etc/ld.so.conf.d ]] ; then
local l="${ROOT}"/etc/ld.so.conf.d/05binutils.conf
@@ -384,7 +384,7 @@ while [[ $# -gt 0 ]] ; do
-h|--help) usage 0 ;;
-V|--version)
unset Header
- cvsver="$Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-4,v 1.2 2014/12/30 15:10:36 blueness Exp $"
+ cvsver="$Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-4,v 1.3 2015/02/09 15:14:52 vapier Exp $"
cvsver=${cvsver##*binutils-config-}
bver=${cvsver%%,v *}
cvsver=${cvsver#* }