summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2003-03-15 22:23:35 +0000
committerJon Portnoy <avenj@gentoo.org>2003-03-15 22:23:35 +0000
commit8b9d369e7adb310028bf6fd2baa2c4a2693360b5 (patch)
tree5b0693a9dd9e19399065b4ee5feba3e71e168c37 /sys-devel
parentAdded sparc64_limit_fix.patch.bz2 back into the files directory. (diff)
downloadgentoo-2-8b9d369e7adb310028bf6fd2baa2c4a2693360b5.tar.gz
gentoo-2-8b9d369e7adb310028bf6fd2baa2c4a2693360b5.tar.bz2
gentoo-2-8b9d369e7adb310028bf6fd2baa2c4a2693360b5.zip
Initial import of OSKit, submitted in bug 17218
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/oskit/ChangeLog9
-rw-r--r--sys-devel/oskit/files/digest-oskit-200203171
-rw-r--r--sys-devel/oskit/oskit-20020317.ebuild68
3 files changed, 78 insertions, 0 deletions
diff --git a/sys-devel/oskit/ChangeLog b/sys-devel/oskit/ChangeLog
new file mode 100644
index 000000000000..3935744d1596
--- /dev/null
+++ b/sys-devel/oskit/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-devel/oskit
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/oskit/ChangeLog,v 1.1 2003/03/15 22:23:35 avenj Exp $
+
+*oskit-20020317 (15 March 2003)
+
+ 15 March 2003; Jon Portnoy <avenj@gentoo.org> oskit-20020317.ebuild :
+ Initial import of OSKit. Ebuild submitted in bug #17218 by
+ Zhen Lin (lowlz [at] hotmail [dot] com).
diff --git a/sys-devel/oskit/files/digest-oskit-20020317 b/sys-devel/oskit/files/digest-oskit-20020317
new file mode 100644
index 000000000000..4a84e2c348ff
--- /dev/null
+++ b/sys-devel/oskit/files/digest-oskit-20020317
@@ -0,0 +1 @@
+MD5 258f256a87c19bf1a49090c46ea0e51b oskit-20020317.tar.gz 11252678
diff --git a/sys-devel/oskit/oskit-20020317.ebuild b/sys-devel/oskit/oskit-20020317.ebuild
new file mode 100644
index 000000000000..2c67dc1e257d
--- /dev/null
+++ b/sys-devel/oskit/oskit-20020317.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/oskit/oskit-20020317.ebuild,v 1.1 2003/03/15 22:23:35 avenj Exp $
+inherit flag-o-matic
+
+DESCRIPTION="Building blocks for a x86 operating system."
+HOMEPAGE="http://www.cs.utah.edu/flux/oskit/"
+SRC_URI="http://savannah.nongnu.org/download/oskit/snapshots.pkg/${PV}/oskit-${PV}.tar.gz
+ ftp://flux.cs.utah.edu/flux/oskit/oskit-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -alpha -mips -hppa"
+DEPEND="doc? ( app-text/tetex )"
+S=${WORKDIR}/${P}
+IUSE="oskit-debug oskit-profiling oskit-noassert doc oskit-nobuild oskit-noconf"
+
+src_compile() {
+ local myconf
+ if [ -n "$(use oskit-debug && use oskit-noassert)" ] ; then
+ ewarn "Configuring for debugging without assertions!"
+ echo -e '\a' 1>&2
+ sleep 5
+ fi
+ #if [ -z $(use oskit-nobuild) ] && [ ! -z $(use oskit-noconf) ] ; then
+ # eerror "Building but not configuring"
+ # die
+ #fi
+ use oskit-debug && myconf="${myconf} --enable-debug"
+ use oskit-profiling && myconf="${myconf} --enable-profiling"
+ use oskit-noassert && myconf="${myconf} --disable-asserts"
+ use doc && myconf="${myconf} --enable-doc"
+ if [ -n "${OSKIT_MODULEFILE}" ] ; then
+ if [ -f "${OSKIT_MODULEFILE}" ] ; then
+ myconf="${myconf} --enable-modulefile=${OSKIT_MODULEFILE}"
+ else
+ ewarn "Modulefile ${OSKIT_MODULEFILE} does not exist or is not a file, not using!"
+ echo -e '\a' 1>&2
+ sleep 5
+ fi
+ fi
+ if [ -n "$(use oskit-nobuild)" ] ; then
+ if [ -n "$(use oskit-noconf)" ] ; then
+ einfo "Configuring OSKit, but not building..."
+ econf ${myconf} || die
+ fi
+ else
+ einfo "Configuring OSKit..."
+ econf ${myconf} || die
+ einfo "Compiling OSKit..."
+ make || die
+ fi
+}
+
+src_install() {
+ if [ -n "$(use oskit-nobuild)" ] ; then
+ dodir /usr/src
+ cd ${WORKDIR}
+ einfo "Fixing permissions and ownership..."
+ chown -R root:root * || die
+ chmod -R a+r-w+X,u+w * || die
+ einfo "Installing OSKit sources..."
+ mv ${S} ${D}/usr/src || die
+ rm -f ${WORKDIR}/../.unpacked
+ else
+ einfo "Installing OSKit..."
+ einstall || die
+ fi
+}