summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-29 00:02:30 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-29 00:02:30 +0000
commit7f49b5b90bb983db60b95120f89676407a12c24e (patch)
tree27a846ca2078dcfa889f8a17a2e0b18fb0b1d232 /sys-devel
parentfix upstream bug url (diff)
downloadgentoo-2-7f49b5b90bb983db60b95120f89676407a12c24e.tar.gz
gentoo-2-7f49b5b90bb983db60b95120f89676407a12c24e.tar.bz2
gentoo-2-7f49b5b90bb983db60b95120f89676407a12c24e.zip
Add fix from upstream for archive targets with multiple objects #334889 by Diego E. Pettenò.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/make/ChangeLog7
-rw-r--r--sys-devel/make/files/make-3.82-archives-many-objs.patch60
-rw-r--r--sys-devel/make/make-3.82.ebuild3
3 files changed, 68 insertions, 2 deletions
diff --git a/sys-devel/make/ChangeLog b/sys-devel/make/ChangeLog
index 4521922153f3..c21c8c6a8cfb 100644
--- a/sys-devel/make/ChangeLog
+++ b/sys-devel/make/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/make
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/ChangeLog,v 1.71 2010/08/18 04:22:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/ChangeLog,v 1.72 2010/08/29 00:02:30 vapier Exp $
+
+ 29 Aug 2010; Mike Frysinger <vapier@gentoo.org> make-3.82.ebuild,
+ +files/make-3.82-archives-many-objs.patch:
+ Add fix from upstream for archive targets with multiple objects #334889 by
+ Diego E. Pettenò.
18 Aug 2010; Jeroen Roovers <jer@gentoo.org> make-3.81-r2.ebuild:
Stable for HPPA (bug #331717).
diff --git a/sys-devel/make/files/make-3.82-archives-many-objs.patch b/sys-devel/make/files/make-3.82-archives-many-objs.patch
new file mode 100644
index 000000000000..abdcd3228014
--- /dev/null
+++ b/sys-devel/make/files/make-3.82-archives-many-objs.patch
@@ -0,0 +1,60 @@
+http://bugs.gentoo.org/334889
+https://savannah.gnu.org/bugs/?30612
+
+revision 1.194
+date: 2010-08-13 22:50:14 -0400; author: psmith; state: Exp; lines: +9 -6; commitid: 4UaslPqQHZTs5wKu;
+- Fix Savannah bug #30612: handling of archive references with >1 object
+
+Index: read.c
+===================================================================
+RCS file: /sources/make/make/read.c,v
+retrieving revision 1.193
+retrieving revision 1.194
+diff -u -p -r1.193 -r1.194
+--- read.c 13 Jul 2010 01:20:42 -0000 1.193
++++ read.c 14 Aug 2010 02:50:14 -0000 1.194
+@@ -3028,7 +3028,7 @@ parse_file_seq (char **stringp, unsigned
+ {
+ /* This looks like the first element in an open archive group.
+ A valid group MUST have ')' as the last character. */
+- const char *e = p + nlen;
++ const char *e = p;
+ do
+ {
+ e = next_token (e);
+@@ -3084,19 +3084,19 @@ parse_file_seq (char **stringp, unsigned
+ Go to the next item in the string. */
+ if (flags & PARSEFS_NOGLOB)
+ {
+- NEWELT (concat (2, prefix, tp));
++ NEWELT (concat (2, prefix, tmpbuf));
+ continue;
+ }
+
+ /* If we get here we know we're doing glob expansion.
+ TP is a string in tmpbuf. NLEN is no longer used.
+ We may need to do more work: after this NAME will be set. */
+- name = tp;
++ name = tmpbuf;
+
+ /* Expand tilde if applicable. */
+- if (tp[0] == '~')
++ if (tmpbuf[0] == '~')
+ {
+- tildep = tilde_expand (tp);
++ tildep = tilde_expand (tmpbuf);
+ if (tildep != 0)
+ name = tildep;
+ }
+@@ -3152,7 +3152,10 @@ parse_file_seq (char **stringp, unsigned
+ else
+ {
+ /* We got a chain of items. Attach them. */
+- (*newp)->next = found;
++ if (*newp)
++ (*newp)->next = found;
++ else
++ *newp = found;
+
+ /* Find and set the new end. Massage names if necessary. */
+ while (1)
diff --git a/sys-devel/make/make-3.82.ebuild b/sys-devel/make/make-3.82.ebuild
index 6ca817112147..cdb10c0292ef 100644
--- a/sys-devel/make/make-3.82.ebuild
+++ b/sys-devel/make/make-3.82.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/make-3.82.ebuild,v 1.3 2010/08/14 04:52:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/make-3.82.ebuild,v 1.4 2010/08/29 00:02:30 vapier Exp $
EAPI="2"
@@ -19,6 +19,7 @@ DEPEND="nls? ( sys-devel/gettext )"
RDEPEND="nls? ( virtual/libintl )"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-archives-many-objs.patch #334889
epatch "${FILESDIR}"/${P}-MAKEFLAGS-reexec.patch #31975
}