summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-10-13 16:51:59 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-10-13 16:51:59 +0000
commit592044a0df1d0194bac07327a7fbac85bc12962e (patch)
tree7353072c739fdb4f7fdba71ea1f763e0678063ac /sys-devel
parentsys-kernel/aufs-sources: Add support for vanilla-sources (diff)
downloadgentoo-2-592044a0df1d0194bac07327a7fbac85bc12962e.tar.gz
gentoo-2-592044a0df1d0194bac07327a7fbac85bc12962e.tar.bz2
gentoo-2-592044a0df1d0194bac07327a7fbac85bc12962e.zip
Version bump (bug #487444)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/make/ChangeLog7
-rw-r--r--sys-devel/make/make-4.0.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/sys-devel/make/ChangeLog b/sys-devel/make/ChangeLog
index 218fb112022d..58a27c932c2d 100644
--- a/sys-devel/make/ChangeLog
+++ b/sys-devel/make/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/make
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/ChangeLog,v 1.115 2013/02/19 03:00:42 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/ChangeLog,v 1.116 2013/10/13 16:51:59 polynomial-c Exp $
+
+*make-4.0 (13 Oct 2013)
+
+ 13 Oct 2013; Lars Wendler <polynomial-c@gentoo.org> +make-4.0.ebuild:
+ Version bump (bug #487444).
19 Feb 2013; Zac Medico <zmedico@gentoo.org> make-3.82-r4.ebuild:
Add ~arm-linux keyword.
diff --git a/sys-devel/make/make-4.0.ebuild b/sys-devel/make/make-4.0.ebuild
new file mode 100644
index 000000000000..0993335e96c8
--- /dev/null
+++ b/sys-devel/make/make-4.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/make/make-4.0.ebuild,v 1.1 2013/10/13 16:51:59 polynomial-c Exp $
+
+EAPI="2"
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Standard tool to compile source trees"
+HOMEPAGE="http://www.gnu.org/software/make/make.html"
+SRC_URI="mirror://gnu//make/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="guile nls static"
+
+CDEPEND="guile? ( >=dev-scheme/guile-1.8 )"
+DEPEND="${CDEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${CDEPEND}
+ nls? ( virtual/libintl )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.82-darwin-library_search-dylib.patch
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ econf \
+ --program-prefix=g \
+ $(use_with guile) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README*
+ if [[ ${USERLAND} == "GNU" ]] ; then
+ # we install everywhere as 'gmake' but on GNU systems,
+ # symlink 'make' to 'gmake'
+ dosym gmake /usr/bin/make
+ dosym gmake.1 /usr/share/man/man1/make.1
+ fi
+}