summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2013-11-10 11:07:02 +0000
committerAgostino Sarubbo <ago@gentoo.org>2013-11-10 11:07:02 +0000
commit3960dc0b304128566e6a55a000105d9b7981bfeb (patch)
tree3fb88e49fc564dbb2e780fc0f86455c13a3c4abc /sys-devel
parentVersion bump, drop old, this is being only maintained by gnome team for a lon... (diff)
downloadgentoo-2-3960dc0b304128566e6a55a000105d9b7981bfeb.tar.gz
gentoo-2-3960dc0b304128566e6a55a000105d9b7981bfeb.tar.bz2
gentoo-2-3960dc0b304128566e6a55a000105d9b7981bfeb.zip
Version bump to 0.16.20
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 7194459F)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bin86/ChangeLog7
-rw-r--r--sys-devel/bin86/bin86-0.16.20.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/sys-devel/bin86/ChangeLog b/sys-devel/bin86/ChangeLog
index 56da592949d5..8ac1da28d7cb 100644
--- a/sys-devel/bin86/ChangeLog
+++ b/sys-devel/bin86/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/bin86
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/ChangeLog,v 1.26 2013/06/25 12:53:51 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/ChangeLog,v 1.27 2013/11/10 11:07:02 ago Exp $
+
+*bin86-0.16.20 (10 Nov 2013)
+
+ 10 Nov 2013; Agostino Sarubbo <ago@gentoo.org> +bin86-0.16.20.ebuild:
+ Version bump to 0.16.20
25 Jun 2013; Agostino Sarubbo <ago@gentoo.org> bin86-0.16.19.ebuild:
Stable for amd64, wrt bug #474304
diff --git a/sys-devel/bin86/bin86-0.16.20.ebuild b/sys-devel/bin86/bin86-0.16.20.ebuild
new file mode 100644
index 000000000000..7a0ff2a52ee0
--- /dev/null
+++ b/sys-devel/bin86/bin86-0.16.20.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/bin86-0.16.20.ebuild,v 1.1 2013/11/10 11:07:02 ago Exp $
+
+EAPI="5"
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Assembler and loader used to create kernel bootsector"
+HOMEPAGE="http://v3.sk/~lkundrak/dev86/"
+SRC_URI="http://v3.sk/~lkundrak/dev86/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ sed -i \
+ -e '/^PREFIX/s:=.*:=$(DESTDIR)/usr:' \
+ -e '/^MANDIR/s:)/man/man1:)/share/man/man1:' \
+ -e '/^INSTALL_OPTS/s:-s::' \
+ -e "/^CFLAGS/s:=.*:=${CFLAGS} -D_POSIX_SOURCE ${CPPFLAGS}:" \
+ -e "/^LDFLAGS/s:=.*:=${LDFLAGS}:" \
+ Makefile || die
+ epatch "${FILESDIR}"/${PN}-0.16.17-amd64-build.patch
+ tc-export CC
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1
+ default
+}