summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-07-06 23:37:38 +0000
committerUlrich Müller <ulm@gentoo.org>2007-07-06 23:37:38 +0000
commit2eb8b1262d889d20888c62a3a6710c7968624861 (patch)
tree4cbaa15e13c21bb803bda776c9600bdbc942ffba /sys-devel
parentInitial import, bug #149431. (diff)
downloadgentoo-2-2eb8b1262d889d20888c62a3a6710c7968624861.tar.gz
gentoo-2-2eb8b1262d889d20888c62a3a6710c7968624861.tar.bz2
gentoo-2-2eb8b1262d889d20888c62a3a6710c7968624861.zip
Split off Emacs support to package app-emacs/po-mode, bug #149431.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gettext/ChangeLog7
-rw-r--r--sys-devel/gettext/files/digest-gettext-0.16.1-r13
-rw-r--r--sys-devel/gettext/gettext-0.16.1-r1.ebuild107
3 files changed, 116 insertions, 1 deletions
diff --git a/sys-devel/gettext/ChangeLog b/sys-devel/gettext/ChangeLog
index 5fd4554e1541..d13b0b627dc1 100644
--- a/sys-devel/gettext/ChangeLog
+++ b/sys-devel/gettext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gettext
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.143 2007/03/16 17:24:25 yoswink Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.144 2007/07/06 23:37:38 ulm Exp $
+
+*gettext-0.16.1-r1 (06 Jul 2007)
+
+ 06 Jul 2007; Ulrich Mueller <ulm@gentoo.org> +gettext-0.16.1-r1.ebuild:
+ Split off Emacs support to package app-emacs/po-mode, bug #149431.
16 Mar 2007; Jose Luis Rivero <yoswink@gentoo.org> gettext-0.16.1.ebuild:
Stable on alpha wrt bug #163178
diff --git a/sys-devel/gettext/files/digest-gettext-0.16.1-r1 b/sys-devel/gettext/files/digest-gettext-0.16.1-r1
new file mode 100644
index 000000000000..7785bc5c3076
--- /dev/null
+++ b/sys-devel/gettext/files/digest-gettext-0.16.1-r1
@@ -0,0 +1,3 @@
+MD5 3d9ad24301c6d6b17ec30704a13fe127 gettext-0.16.1.tar.gz 8539634
+RMD160 0fa96b2d005e2490e8603a0a3612041086d5aea1 gettext-0.16.1.tar.gz 8539634
+SHA256 0bf850d1a079fb5a61f0a47b1a9efd35eb44032255375e1cedb0253bc27b376d gettext-0.16.1.tar.gz 8539634
diff --git a/sys-devel/gettext/gettext-0.16.1-r1.ebuild b/sys-devel/gettext/gettext-0.16.1-r1.ebuild
new file mode 100644
index 000000000000..1a700aa73923
--- /dev/null
+++ b/sys-devel/gettext/gettext-0.16.1-r1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.16.1-r1.ebuild,v 1.1 2007/07/06 23:37:38 ulm Exp $
+
+inherit flag-o-matic eutils multilib toolchain-funcs mono libtool
+
+DESCRIPTION="GNU locale utilities"
+HOMEPAGE="http://www.gnu.org/software/gettext/gettext.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="emacs nls doc nocxx"
+
+DEPEND="virtual/libiconv
+ dev-libs/expat"
+PDEPEND="emacs? ( virtual/emacs )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epunt_cxx
+
+ epatch "${FILESDIR}"/${PN}-0.14.1-lib-path-tests.patch #81628
+ epatch "${FILESDIR}"/${PN}-0.14.2-fix-race.patch #85054
+ epatch "${FILESDIR}"/${PN}-0.15-expat-no-dlopen.patch #146211
+
+ # bundled libtool seems to be broken so skip certain rpath tests
+ # http://lists.gnu.org/archive/html/bug-libtool/2005-03/msg00070.html
+ sed -i \
+ -e '2iexit 77' \
+ autoconf-lib-link/tests/rpath-3*[ef] || die "sed tests"
+
+ # sanity check for Bug 105304
+ if [[ -z ${USERLAND} ]] ; then
+ eerror "You just hit Bug 105304, please post your 'emerge info' here:"
+ eerror "http://bugs.gentoo.org/105304"
+ die "Aborting to prevent screwing your system"
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ # Build with --without-included-gettext (on glibc systems)
+ if use elibc_glibc ; then
+ myconf="${myconf} --without-included-gettext $(use_enable nls)"
+ else
+ myconf="${myconf} --with-included-gettext --enable-nls"
+ fi
+ use nocxx && export CXX=$(tc-getCC)
+
+ # Emacs support is now in a separate package, so configure --without-emacs
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --without-emacs \
+ --disable-java \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "install failed"
+ use nls || rm -r "${D}"/usr/share/locale
+ dosym msgfmt /usr/bin/gmsgfmt #43435
+ dobin gettext-tools/misc/gettextize || die "gettextize"
+
+ # remove stuff that glibc handles
+ if use elibc_glibc ; then
+ rm -f "${D}"/usr/include/libintl.h
+ rm -f "${D}"/usr/$(get_libdir)/libintl.*
+ fi
+ rm -f "${D}"/usr/share/locale/locale.alias "${D}"/usr/lib/charset.alias
+
+ if [[ ${USERLAND} == "BSD" ]] ; then
+ libname="libintl$(get_libname 8)"
+ # Move dynamic libs and creates ldscripts into /usr/lib
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/${libname}* "${D}"/$(get_libdir)/
+ gen_usr_ldscript ${libname}
+ fi
+
+ if use doc ; then
+ dohtml "${D}"/usr/share/doc/${PF}/*.html
+ else
+ rm -rf "${D}"/usr/share/doc/${PF}/{csharpdoc,examples,javadoc2,javadoc1}
+ fi
+ rm -f "${D}"/usr/share/doc/${PF}/*.html
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}
+
+pkg_preinst() {
+ # older gettext's sometimes installed libintl ...
+ # need to keep the linked version or the system
+ # could die (things like sed link against it :/)
+ preserve_old_lib /{,usr/}$(get_libdir)/libintl$(get_libname 7)
+}
+
+pkg_postinst() {
+ ewarn "Any package that linked against the previous version"
+ ewarn "of gettext will have to be rebuilt."
+ ewarn "Please 'emerge gentoolkit' and run:"
+ ewarn "revdep-rebuild --library libintl.so.7"
+}