summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-02-18 21:33:18 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-02-18 21:33:18 +0000
commit0e79ac8fc6f6c1bd773e181ff46477cd733b67e4 (patch)
tree20f938bedd06f0c8223002e3d48d0d8813f7bb91 /sys-devel
parentAdd missing dev-haskell/hsb2hs depend for USE=embed_data_files (bug #540432 b... (diff)
downloadgentoo-2-0e79ac8fc6f6c1bd773e181ff46477cd733b67e4.tar.gz
gentoo-2-0e79ac8fc6f6c1bd773e181ff46477cd733b67e4.tar.bz2
gentoo-2-0e79ac8fc6f6c1bd773e181ff46477cd733b67e4.zip
Check the active gcc version (4.9 does not work), thanks everyone in bug #511640
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/dragonegg/ChangeLog7
-rw-r--r--sys-devel/dragonegg/dragonegg-3.5.0.ebuild48
-rw-r--r--sys-devel/dragonegg/dragonegg-3.5.1.ebuild12
-rw-r--r--sys-devel/dragonegg/dragonegg-9999.ebuild6
4 files changed, 19 insertions, 54 deletions
diff --git a/sys-devel/dragonegg/ChangeLog b/sys-devel/dragonegg/ChangeLog
index 2e8888e552e1..66793608501e 100644
--- a/sys-devel/dragonegg/ChangeLog
+++ b/sys-devel/dragonegg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/dragonegg
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/ChangeLog,v 1.21 2015/01/21 09:26:42 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/ChangeLog,v 1.22 2015/02/18 21:33:18 voyageur Exp $
+
+ 18 Feb 2015; Bernard Cafarelli <voyageur@gentoo.org> -dragonegg-3.5.0.ebuild,
+ dragonegg-3.5.1.ebuild, dragonegg-9999.ebuild:
+ Check the active gcc version (4.9 does not work), thanks everyone in bug
+ #511640
*dragonegg-3.5.1 (21 Jan 2015)
diff --git a/sys-devel/dragonegg/dragonegg-3.5.0.ebuild b/sys-devel/dragonegg/dragonegg-3.5.0.ebuild
deleted file mode 100644
index 8bed3ff9669f..000000000000
--- a/sys-devel/dragonegg/dragonegg-3.5.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/dragonegg-3.5.0.ebuild,v 1.1 2014/09/17 23:13:12 voyageur Exp $
-
-EAPI=5
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="GCC plugin that uses LLVM for optimization and code generation"
-HOMEPAGE="http://dragonegg.llvm.org/"
-SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.xz
- test? ( http://llvm.org/releases/${PV}/llvm-${PV}.src.tar.xz )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux"
-IUSE="test"
-
-DEPEND=">=sys-devel/gcc-4.5
- =sys-devel/llvm-${PV}*"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${P}.src
-
-src_compile() {
- # GCC: compiler to use plugin with
- emake CC="$(tc-getCC)" GCC="$(tc-getCC)" CXX="$(tc-getCXX)" VERBOSE=1
-}
-
-src_test() {
- # GCC languages are determined via locale-dependant gcc -v output
- export LC_ALL=C
-
- emake LIT_DIR="${WORKDIR}"/llvm-${PV}.src/utils/lit check
-}
-
-src_install() {
- exeinto /usr/$(get_libdir)
- doexe dragonegg.so
-
- dodoc README
-}
-
-pkg_postinst() {
- elog "To use dragonegg, run gcc as usual, with an extra command line argument:"
- elog " -fplugin=/usr/$(get_libdir)/dragonegg.so"
- elog "If you change the active gcc profile, or update gcc to a new version,"
- elog "you will have to remerge this package to update the plugin"
-}
diff --git a/sys-devel/dragonegg/dragonegg-3.5.1.ebuild b/sys-devel/dragonegg/dragonegg-3.5.1.ebuild
index 98ae5a6cde88..15f6746eaf6d 100644
--- a/sys-devel/dragonegg/dragonegg-3.5.1.ebuild
+++ b/sys-devel/dragonegg/dragonegg-3.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/dragonegg-3.5.1.ebuild,v 1.1 2015/01/21 09:26:42 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/dragonegg-3.5.1.ebuild,v 1.2 2015/02/18 21:33:18 voyageur Exp $
EAPI=5
inherit eutils multilib toolchain-funcs
@@ -15,12 +15,20 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux"
IUSE="test"
-DEPEND=">=sys-devel/gcc-4.5
+DEPEND=">=sys-devel/gcc-4.5:*
=sys-devel/llvm-${PV}*"
RDEPEND="${DEPEND}"
S=${WORKDIR}/${P}.src
+pkg_pretend() {
+ # Bug #511640: gcc 4.9 removed a required header
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(gcc-version) > 4.8 || $(gcc-version) < 4.5 ]] && \
+ die 'The active compiler needs to be gcc 4.[5-8])'
+ fi
+}
+
src_compile() {
# GCC: compiler to use plugin with
emake CC="$(tc-getCC)" GCC="$(tc-getCC)" CXX="$(tc-getCXX)" VERBOSE=1
diff --git a/sys-devel/dragonegg/dragonegg-9999.ebuild b/sys-devel/dragonegg/dragonegg-9999.ebuild
index ac428252b1c9..59f6df981a03 100644
--- a/sys-devel/dragonegg/dragonegg-9999.ebuild
+++ b/sys-devel/dragonegg/dragonegg-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/dragonegg-9999.ebuild,v 1.7 2014/09/17 23:13:12 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/dragonegg-9999.ebuild,v 1.8 2015/02/18 21:33:18 voyageur Exp $
EAPI=5
inherit git-r3 multilib toolchain-funcs
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS=""
IUSE=""
-DEPEND=">=sys-devel/gcc-4.5
+DEPEND=">=sys-devel/gcc-4.5:*
~sys-devel/llvm-${PV}"
RDEPEND="${DEPEND}"