summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-11-01 16:14:42 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-11-01 16:14:42 +0000
commit8b1c4d9af7b17751e32cb01146ccd568a4324609 (patch)
tree308ae5bca17e3827d2de8593136ba20e8aeb2f8a /sys-devel/omni/omni-1.4a.ebuild
parentVersion bump (diff)
downloadgentoo-2-8b1c4d9af7b17751e32cb01146ccd568a4324609.tar.gz
gentoo-2-8b1c4d9af7b17751e32cb01146ccd568a4324609.tar.bz2
gentoo-2-8b1c4d9af7b17751e32cb01146ccd568a4324609.zip
Remove packages scheduled for removal.
Diffstat (limited to 'sys-devel/omni/omni-1.4a.ebuild')
-rw-r--r--sys-devel/omni/omni-1.4a.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/sys-devel/omni/omni-1.4a.ebuild b/sys-devel/omni/omni-1.4a.ebuild
deleted file mode 100644
index badb634fe6ed..000000000000
--- a/sys-devel/omni/omni-1.4a.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/omni/omni-1.4a.ebuild,v 1.7 2007/07/15 04:37:55 mr_bones_ Exp $
-
-IUSE="java doc"
-
-MY_P=Omni-${PV}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="The Omni OpenMP Compiler"
-HOMEPAGE="http://phase.hpcc.jp/Omni/home.html"
-
-SLOT="0"
-LICENSE="Omni"
-KEYWORDS="x86"
-
-RESTRICT="fetch"
-
-DEPEND="java? ( virtual/jdk
- app-arch/zip )
- sys-apps/sed"
-
-RDEPEND="java? ( virtual/jdk )"
-
-src_unpack() {
-
- if [ ! -e ${DISTDIR}/${MY_P}.tar.gz ] ; then
- einfo "Due to license issues you have to download"
- einfo "the appropriate Omni archive:"
- einfo "http://phase.etl.go.jp/Omni/Omni-release.html"
- einfo "Please get the file "${MY_P}.tar.gz
- einfo ""
- einfo "The archive should be placed into ${DISTDIR}."
-
- die "package archive not found"
- fi
-
- unpack ${MY_P}.tar.gz
-
-}
-
-src_compile() {
- local myconf
-
- myconf=""
-
- # There is no configure script for the doc
- if ! use doc ; then
- dosed s/doc// Makefile.in
- fi
-
- use java && myconf="${myconf} --with-jvm=yes"
- use java || myconf="${myconf} --with-jvm=no"
-
- use doc && myconf="${myconf} --enable-installSample"
-
- # scoredoc is just about the placement of the doc
- econf ${myconf} --enable-gcc --disable-scoreDoc \
- --with-thread=pthread || die
-
- emake || die
-}
-
-src_install() {
- make DESTDIR=${D} install || die
-
- # Put the doc in the right place
- dodir /usr/share/doc/
- use doc && mv ${D}usr/lib/openmp/doc ${D}usr/share/doc/${P}
- use doc && mv ${D}usr/lib/openmp/examples ${D}usr/share/doc/${P}
-
- dodoc README COPYRIGHT LICENSE
-}