summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-04-16 11:55:18 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-04-16 11:55:18 +0000
commit0bc454f6f1742b758fab3f3d5c5ffcd41ce5ca03 (patch)
tree7f5b98ddf3490abffe288d6ac175bc59ca298e96 /sys-devel/llvm
parentRemove USE=libav default. See news item 2015-04-16 ffmpeg default. (diff)
downloadgentoo-2-0bc454f6f1742b758fab3f3d5c5ffcd41ce5ca03.tar.gz
gentoo-2-0bc454f6f1742b758fab3f3d5c5ffcd41ce5ca03.tar.bz2
gentoo-2-0bc454f6f1742b758fab3f3d5c5ffcd41ce5ca03.zip
Update debug CFLAGS check, bug #545630
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 00F7AB331B0F097F)
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/ChangeLog7
-rw-r--r--sys-devel/llvm/llvm-3.3-r3.ebuild4
-rw-r--r--sys-devel/llvm/llvm-3.4.2.ebuild4
-rw-r--r--sys-devel/llvm/llvm-3.5.0.ebuild4
-rw-r--r--sys-devel/llvm/llvm-3.5.1.ebuild4
-rw-r--r--sys-devel/llvm/llvm-3.5.2.ebuild4
-rw-r--r--sys-devel/llvm/llvm-3.6.0.ebuild6
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild4
8 files changed, 21 insertions, 16 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index ba79048a7676..5f23b58dc492 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.237 2015/04/08 18:25:48 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.238 2015/04/16 11:55:18 voyageur Exp $
+
+ 16 Apr 2015; Bernard Cafarelli <voyageur@gentoo.org> llvm-3.3-r3.ebuild,
+ llvm-3.4.2.ebuild, llvm-3.5.0.ebuild, llvm-3.5.1.ebuild, llvm-3.5.2.ebuild,
+ llvm-3.6.0.ebuild, llvm-9999.ebuild:
+ Update debug CFLAGS check, bug #545630
08 Apr 2015; Michał Górny <mgorny@gentoo.org> llvm-3.2.ebuild,
llvm-3.3-r3.ebuild:
diff --git a/sys-devel/llvm/llvm-3.3-r3.ebuild b/sys-devel/llvm/llvm-3.3-r3.ebuild
index db348181da8e..b9bd74f5061b 100644
--- a/sys-devel/llvm/llvm-3.3-r3.ebuild
+++ b/sys-devel/llvm/llvm-3.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.3-r3.ebuild,v 1.13 2015/04/08 18:25:48 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.3-r3.ebuild,v 1.14 2015/04/16 11:55:18 voyageur Exp $
EAPI=5
@@ -88,7 +88,7 @@ pkg_pretend() {
ewarn
(( build_size *= 14 ))
- elif is-flagq -g || is-flagq -ggdb; then
+ elif is-flagq '-g?(gdb)?([1-9])'; then
ewarn "The C++ compiler -g option is known to increase the size of the package"
ewarn "considerably. If you run out of space, please consider removing it."
ewarn
diff --git a/sys-devel/llvm/llvm-3.4.2.ebuild b/sys-devel/llvm/llvm-3.4.2.ebuild
index 17bf89dd8ecf..200255d140bf 100644
--- a/sys-devel/llvm/llvm-3.4.2.ebuild
+++ b/sys-devel/llvm/llvm-3.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4.2.ebuild,v 1.9 2015/01/31 19:48:12 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4.2.ebuild,v 1.10 2015/04/16 11:55:18 voyageur Exp $
EAPI=5
@@ -98,7 +98,7 @@ pkg_pretend() {
ewarn
(( build_size *= 14 ))
- elif is-flagq -g || is-flagq -ggdb; then
+ elif is-flagq '-g?(gdb)?([1-9])'; then
ewarn "The C++ compiler -g option is known to increase the size of the package"
ewarn "considerably. If you run out of space, please consider removing it."
ewarn
diff --git a/sys-devel/llvm/llvm-3.5.0.ebuild b/sys-devel/llvm/llvm-3.5.0.ebuild
index 96a4a05df2ce..2ef3bff56195 100644
--- a/sys-devel/llvm/llvm-3.5.0.ebuild
+++ b/sys-devel/llvm/llvm-3.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.5.0.ebuild,v 1.14 2015/02/21 10:07:58 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.5.0.ebuild,v 1.15 2015/04/16 11:55:18 voyageur Exp $
EAPI=5
@@ -94,7 +94,7 @@ pkg_pretend() {
ewarn
(( build_size *= 14 ))
- elif is-flagq -g || is-flagq -ggdb; then
+ elif is-flagq '-g?(gdb)?([1-9])'; then
ewarn "The C++ compiler -g option is known to increase the size of the package"
ewarn "considerably. If you run out of space, please consider removing it."
ewarn
diff --git a/sys-devel/llvm/llvm-3.5.1.ebuild b/sys-devel/llvm/llvm-3.5.1.ebuild
index 0ee9e1abe7b7..347e73182048 100644
--- a/sys-devel/llvm/llvm-3.5.1.ebuild
+++ b/sys-devel/llvm/llvm-3.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.5.1.ebuild,v 1.7 2015/03/03 10:00:26 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.5.1.ebuild,v 1.8 2015/04/16 11:55:18 voyageur Exp $
EAPI=5
@@ -94,7 +94,7 @@ pkg_pretend() {
ewarn
(( build_size *= 14 ))
- elif is-flagq -g || is-flagq -ggdb; then
+ elif is-flagq '-g?(gdb)?([1-9])'; then
ewarn "The C++ compiler -g option is known to increase the size of the package"
ewarn "considerably. If you run out of space, please consider removing it."
ewarn
diff --git a/sys-devel/llvm/llvm-3.5.2.ebuild b/sys-devel/llvm/llvm-3.5.2.ebuild
index 4b2c6147b2b9..7e8f4ca0bc73 100644
--- a/sys-devel/llvm/llvm-3.5.2.ebuild
+++ b/sys-devel/llvm/llvm-3.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.5.2.ebuild,v 1.1 2015/04/03 08:59:51 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.5.2.ebuild,v 1.2 2015/04/16 11:55:18 voyageur Exp $
EAPI=5
@@ -94,7 +94,7 @@ pkg_pretend() {
ewarn
(( build_size *= 14 ))
- elif is-flagq -g || is-flagq -ggdb; then
+ elif is-flagq '-g?(gdb)?([1-9])'; then
ewarn "The C++ compiler -g option is known to increase the size of the package"
ewarn "considerably. If you run out of space, please consider removing it."
ewarn
diff --git a/sys-devel/llvm/llvm-3.6.0.ebuild b/sys-devel/llvm/llvm-3.6.0.ebuild
index e66aa11144ff..b045d61b4921 100644
--- a/sys-devel/llvm/llvm-3.6.0.ebuild
+++ b/sys-devel/llvm/llvm-3.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.6.0.ebuild,v 1.1 2015/02/28 09:38:22 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.6.0.ebuild,v 1.2 2015/04/16 11:55:18 voyageur Exp $
EAPI=5
@@ -19,7 +19,7 @@ SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.xz
LICENSE="UoI-NCSA"
SLOT="0/3.6"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="clang debug doc gold libedit +libffi multitarget ncurses ocaml python
+static-analyzer test xml video_cards_radeon
kernel_Darwin kernel_FreeBSD"
@@ -94,7 +94,7 @@ pkg_pretend() {
ewarn
(( build_size *= 14 ))
- elif is-flagq -g || is-flagq -ggdb; then
+ elif is-flagq '-g?(gdb)?([1-9])'; then
ewarn "The C++ compiler -g option is known to increase the size of the package"
ewarn "considerably. If you run out of space, please consider removing it."
ewarn
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 5e3962e15efa..51a3ff251dc6 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.103 2015/04/02 15:05:26 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.104 2015/04/16 11:55:18 voyageur Exp $
EAPI=5
@@ -88,7 +88,7 @@ pkg_pretend() {
ewarn
(( build_size *= 14 ))
- elif is-flagq -g || is-flagq -ggdb; then
+ elif is-flagq '-g?(gdb)?([1-9])'; then
ewarn "The C++ compiler -g option is known to increase the size of the package"
ewarn "considerably. If you run out of space, please consider removing it."
ewarn