summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-11-05 22:52:12 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-11-05 22:52:12 +0000
commit093939c077420d5c6ee44127acf4ca8831318052 (patch)
tree03c4ca7a05c32ac8e1ffe274acf9ce9dbb9bd1cf /sys-devel/distcc
parentamd64 stable wrt bug #245688 (diff)
downloadgentoo-2-093939c077420d5c6ee44127acf4ca8831318052.tar.gz
gentoo-2-093939c077420d5c6ee44127acf4ca8831318052.tar.bz2
gentoo-2-093939c077420d5c6ee44127acf4ca8831318052.zip
Added GCC_SPECS to init.d, bug #164818. Fixed uninitialized issue, bug #244847. Removed DISTCC_POTENTIAL_HOSTS variable. Added IPv6 elog.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'sys-devel/distcc')
-rw-r--r--sys-devel/distcc/ChangeLog14
-rw-r--r--sys-devel/distcc/distcc-3.0-r4.ebuild164
-rwxr-xr-xsys-devel/distcc/files/3.0/init4
-rw-r--r--sys-devel/distcc/files/distcc-3.0-uninitialized.patch13
4 files changed, 193 insertions, 2 deletions
diff --git a/sys-devel/distcc/ChangeLog b/sys-devel/distcc/ChangeLog
index 76dee61a59ca..a2c8aab0c11c 100644
--- a/sys-devel/distcc/ChangeLog
+++ b/sys-devel/distcc/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for sys-devel/distcc
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.180 2008/11/02 22:24:23 gengor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.181 2008/11/05 22:52:11 matsuu Exp $
+
+*distcc-3.0-r4 (05 Nov 2008)
+
+ 05 Nov 2008; MATSUU Takuto <matsuu@gentoo.org> files/3.0/init,
+ +files/distcc-3.0-uninitialized.patch, +distcc-3.0-r4.ebuild:
+ Added GCC_SPECS to init.d, bug #164818. Fixed uninitialized issue, bug
+ #244847. Removed DISTCC_POTENTIAL_HOSTS variable. Added IPv6 elog.
+
+ 05 Nov 2008; MATSUU Takuto <matsuu@gentoo.org> files/3.0/init,
+ distcc-3.0-r3.ebuild:
+ Added GCC_SPECS to init.d, bug #164818. Removed DISTCC_POTENTIAL_HOSTS
+ variable. Added IPv6 elog.
02 Nov 2008; Gordon Malm <gengor@gentoo.org> +files/distcc-hardened.patch,
distcc-2.18.3-r10.ebuild, distcc-2.18.3-r13.ebuild, distcc-3.0-r3.ebuild:
diff --git a/sys-devel/distcc/distcc-3.0-r4.ebuild b/sys-devel/distcc/distcc-3.0-r4.ebuild
new file mode 100644
index 000000000000..2433d288fbd8
--- /dev/null
+++ b/sys-devel/distcc/distcc-3.0-r4.ebuild
@@ -0,0 +1,164 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-3.0-r4.ebuild,v 1.1 2008/11/05 22:52:11 matsuu Exp $
+
+inherit eutils fdo-mime flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+HOMEPAGE="http://distcc.org/"
+SRC_URI="http://distcc.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi gnome gtk hardened ipv6 selinux xinetd"
+
+RESTRICT="test"
+
+RDEPEND=">=dev-lang/python-2.4
+ dev-libs/popt
+ avahi? ( >=net-dns/avahi-0.6 )
+ gnome? (
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=x11-libs/gtk+-2
+ x11-libs/pango
+ )
+ gtk? (
+ >=x11-libs/gtk+-2
+ )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${RDEPEND}
+ !net-misc/pump
+ >=sys-devel/gcc-config-1.3.1
+ selinux? ( sec-policy/selinux-distcc )
+ xinetd? ( sys-apps/xinetd )"
+
+DISTCC_LOG=""
+DCCC_PATH="/usr/$(get_libdir)/distcc/bin"
+DISTCC_VERBOSE="0"
+
+pkg_setup() {
+ enewuser distcc 240 -1 -1 daemon
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch "${FILESDIR}/${P}-svn617.patch"
+ epatch "${FILESDIR}/${P}-xinetd.patch"
+ epatch "${FILESDIR}/${P}-uninitialized.patch"
+ sed -i -e "/PATH/s:\$distcc_location:${DCCC_PATH}:" pump.in || die
+
+ # Bugs #120001, #167844 and probably more. See patch for description.
+ use hardened && epatch "${FILESDIR}/distcc-hardened.patch"
+}
+
+src_compile() {
+ # More legacy stuff?
+ [ "$(gcc-major-version)" = "2" ] && filter-lfs-flags
+
+ # -O? is required
+ [ "${CFLAGS/-O}" = "${CFLAGS}" ] && CFLAGS="${CFLAGS} -O2"
+
+ econf \
+ $(use_with avahi) \
+ $(use_with gtk) \
+ $(use_with gnome) \
+ $(use_enable ipv6 rfc2553) \
+ --with-docdir="/usr/share/doc/${PF}" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dobin "${FILESDIR}/${PV}/distcc-config"
+
+ newinitd "${FILESDIR}/${PV}/init" distccd
+
+ cp "${FILESDIR}/${PV}/conf" "${T}/distccd"
+ if use avahi; then
+ cat >> "${T}/distccd" <<-EOF
+
+ # Enable zeroconf support in distccd
+ DISTCCD_OPTS="\${DISTCCD_OPTS} --zeroconf"
+ EOF
+ fi
+ doconfd "${T}/distccd"
+
+ cat > "${T}/02distcc" <<-EOF
+ # This file is managed by distcc-config; use it to change these settings.
+ DISTCC_LOG="${DISTCC_LOG}"
+ DCCC_PATH="${DCCC_PATH}"
+ DISTCC_VERBOSE="${DISTCC_VERBOSE}"
+ EOF
+ doenvd "${T}/02distcc"
+
+ # create the masquerade directory
+ dodir "${DCCC_PATH}"
+ for f in cc c++ gcc g++; do
+ dosym /usr/bin/distcc "${DCCC_PATH}/${f}"
+ if [ "${f}" != "cc" ]; then
+ dosym /usr/bin/distcc "${DCCC_PATH}/${CTARGET:-${CHOST}}-${f}"
+ fi
+ done
+
+ # create the distccd pid directory
+ keepdir /var/run/distccd
+ fowners distcc:daemon /var/run/distccd
+
+ if use gnome || use gtk; then
+ einfo "Renaming /usr/bin/distccmon-gnome to /usr/bin/distccmon-gui"
+ einfo "This is to have a little sensability in naming schemes between distccmon programs"
+ mv "${D}/usr/bin/distccmon-gnome" "${D}/usr/bin/distccmon-gui" || die
+ dosym distccmon-gui /usr/bin/distccmon-gnome
+ fi
+
+ if use xinetd; then
+ insinto /etc/xinetd.d
+ newins "doc/example/xinetd" distcc
+ fi
+
+ rm -rf "${D}/etc/default"
+ rm -f "${D}/etc/distcc/clients.allow"
+ rm -f "${D}/etc/distcc/commands.allow.sh"
+ prepalldocs
+}
+
+pkg_postinst() {
+ use gnome && fdo-mime_desktop_database_update
+
+ if use ipv6; then
+ elog
+ elog "IPv6 has not supported yet by ${P}."
+ fi
+ elog
+ elog "Tips on using distcc with Gentoo can be found at"
+ elog "http://www.gentoo.org/doc/en/distcc.xml"
+ elog
+ elog "How to use pump mode with Gentoo:"
+ elog "# distcc-config --set-hosts \"foo,cpp,lzo bar,cpp,lzo baz,cpp,lzo\""
+ elog "# pump emerge -u world"
+ elog
+ elog "To use the distccmon programs with Gentoo you should use this command:"
+ elog "# DISTCC_DIR=\"${DISTCC_DIR}\" distccmon-text 5"
+
+ if use gnome || use gtk; then
+ elog "Or:"
+ elog "# DISTCC_DIR=\"${DISTCC_DIR}\" distccmon-gnome"
+ fi
+
+ elog
+ elog "***SECURITY NOTICE***"
+ elog "If you are upgrading distcc please make sure to run etc-update to"
+ elog "update your /etc/conf.d/distccd and /etc/init.d/distccd files with"
+ elog "added security precautions (the --listen and --allow directives)"
+ elog
+}
+
+pkg_postrm() {
+ use gnome && fdo-mime_desktop_database_update
+}
diff --git a/sys-devel/distcc/files/3.0/init b/sys-devel/distcc/files/3.0/init
index 6f7150f94af9..dfae3b719194 100755
--- a/sys-devel/distcc/files/3.0/init
+++ b/sys-devel/distcc/files/3.0/init
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/files/3.0/init,v 1.2 2008/10/25 06:39:17 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/files/3.0/init,v 1.3 2008/11/05 22:52:11 matsuu Exp $
depend() {
need net
@@ -10,6 +10,8 @@ depend() {
start() {
ebegin "Starting distccd"
+ # Load GCC_SPECS from profile.env bug #164818
+ GCC_SPECS="$(. /etc/profile.env; echo "${GCC_SPECS}")" \
PATH="$(gcc-config --get-bin-path):${PATH}" \
start-stop-daemon --start --quiet --exec "${DISTCCD_EXEC}" -- \
--daemon --pid-file "${DISTCCD_PIDFILE}" --user distcc \
diff --git a/sys-devel/distcc/files/distcc-3.0-uninitialized.patch b/sys-devel/distcc/files/distcc-3.0-uninitialized.patch
new file mode 100644
index 000000000000..28b226b7966c
--- /dev/null
+++ b/sys-devel/distcc/files/distcc-3.0-uninitialized.patch
@@ -0,0 +1,13 @@
+Index: src/where.c
+===================================================================
+--- src/where.c (revision 622)
++++ src/where.c (working copy)
+@@ -190,7 +190,7 @@
+ int dcc_lock_local_cpp(int *cpu_lock_fd)
+ {
+ int ret;
+- struct dcc_hostdef *chosen;
++ struct dcc_hostdef *chosen = NULL;
+ ret = dcc_lock_one(dcc_hostdef_local_cpp, &chosen, cpu_lock_fd);
+ dcc_note_state(DCC_PHASE_CPP, NULL, chosen->hostname);
+ return ret;